Totem set as default music player after install instead of Banshee

Bug #805938 reported by Brendan Donegan on 2011-07-05
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
banshee (Ubuntu)
Low
Unassigned
Oneiric
Low
Unassigned
desktop-file-utils (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned
unity (Ubuntu)
Medium
Canonical Desktop Experience Team
Oneiric
Medium
Canonical Desktop Experience Team

Bug Description

Not really sure where the blame lies for this one, but it could be Banshee hasn't registered itself as the default music player so starting there.

Basically when opening the Dash the icon is 'wrong' for 'Listen to Music'. Going into System Info > Default Applications shows Totem set as the default music player. This should actually be Banshee.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: banshee 2.1.0-1ubuntu3
ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
Uname: Linux 3.0-3-generic i686
Architecture: i386
Date: Tue Jul 5 13:55:46 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: banshee
UpgradeStatus: No upgrade log present (probably fresh install)

tags: added: iso-testing
summary: - [iso testing] Totem set as default music player after install instead of
- Banshee
+ Totem set as default music player after install instead of Banshee
Moussouni Mehdi (mmoussouni47) wrote :

Sorry I begin and I don't read all the bug before assigned it to me.
Sorry again.

Changed in banshee (Ubuntu):
assignee: nobody → Moussouni Mehdi (mmoussouni47)
status: New → In Progress
assignee: Moussouni Mehdi (mmoussouni47) → nobody
status: In Progress → New
Kamus (kamus) wrote :

Have you checked your preferences in nautilus about which media player is predefined to open music files?
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in banshee (Ubuntu):
importance: Undecided → Low

You're missing the point. This is a fresh install (iso-testing tag gives it away) so I haven't touched anything. As mentioned in the bug I checked in the settings and Totem was set as the default player for music files which it shouldn't be. I don't think we want to ship Oneiric with these defaults so Low isn't really a good importance for this.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Kamus (kamus) wrote :

Right, I said that because I saw this issue before with an upgrade installation and that was the main reason. In the other hand I marked this bug as low with not incompleted status because I want to be confident about if this behaviour was the same seen a few weeks ago (I can't find the bug number!), however please feel free to change the importance of this issue to a highest if the case applied.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Pedro Villavicencio (pedro) wrote :

i'm also seeing this on a fresh install.

Changed in banshee (Ubuntu):
status: New → Confirmed

On 07/07/2011 02:24, Pedro Villavicencio wrote:
> i'm also seeing this on a fresh install.
>
> ** Changed in: banshee (Ubuntu)
> Status: New => Confirmed
>

Okay, for the Unity bug, there are two things:
1. `gconftool-2 --get /desktop/gnome/applications/media/exec'
2. Unity's fallback seems to probe banshee-1 instead of banshee. I could have
sworn I this for Natty. Here's the patch against Oneiric's Unity anyway.

Adding a Unity task..
  affects ubuntu/unity
  status triaged

--
Kind regards,
Loong Jin

Kate Stewart (kate.stewart) wrote :

Defaults need to match expectations, have set this to at least medium for now.

Changed in unity (Ubuntu):
importance: Undecided → Medium
Martin Pitt (pitti) wrote :

Closing banshee task, as this needs to be fixed in unity itself.

Changed in banshee (Ubuntu):
status: Confirmed → Invalid
affects: banshee → unity
Martin Pitt (pitti) wrote :

Unity developers, can you please apply this upstream, too?

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
tags: added: patch
Neil J. Patel (njpatel) on 2011-07-08
Changed in unity:
milestone: none → 4.4.0
Chow Loong Jin (hyperair) wrote :

For the other half of this bug, it seems that g-c-c looks at the handler for
audio/x-vorbis+ogg and displays that as the default handler for audio files.
Thanks to seb128 for pointing that out on IRC.

And this is set in desktop-file-utils. Please see the attached patch which
changes the default handler for supported audio mimetypes by Banshee to
banshee.desktop.

  affects ubuntu/desktop-file-utils
  status triaged
  subscribe ubuntu-sponsors

--
Kind regards,
Loong Jin

Changed in desktop-file-utils (Ubuntu Oneiric):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.18-0ubuntu6

---------------
desktop-file-utils (0.18-0ubuntu6) oneiric; urgency=low

  * debian/defaults.list: set Banshee as default handler for audio files
    (LP: #805938)
 -- Chow Loong Jin <email address hidden> Sat, 09 Jul 2011 02:33:55 +0800

Changed in desktop-file-utils (Ubuntu Oneiric):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.2.0-0ubuntu3

---------------
unity (4.2.0-0ubuntu3) oneiric; urgency=low

  [ Chow Loong Jin ]
  * plugins/unityshell/src/PlacesHomeView.cpp: update banshee-1 to banshee in
    _music_alternatives (LP: #805938)
 -- Jamie Strandboge <email address hidden> Wed, 13 Jul 2011 08:22:38 -0500

Changed in unity (Ubuntu Oneiric):
status: Triaged → Fix Released
Jamie Strandboge (jdstrand) wrote :

FYI, I uploaded this debdiff to fix unity in Ubuntu. I could not apply it to the Vcs branch because bzr kept crashing on fetching the tree.

Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Jorge Castro (jorge) on 2011-09-02
Changed in unity:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers