Banshee crashes every time immediately after startup

Bug #774820 reported by Captain Chaos on 2011-05-01
This bug report is a duplicate of:  Bug #668725: banshee crash on start. Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Banshee
Unknown
Unknown
banshee (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: banshee

After upgrading my system from 10.10 to 11.04 (64-bit), the default music player had been changed from Rhythmbox to Banshee. However, Banshee fails to start every time. The main window will be displayed for a second or so, and then it disappears. When I run it in a terminal, the following output is produced:

[Info 13:22:58.576] Running Banshee 2.0.0: [Ubuntu Natty (development branch) (linux-gnu, x86_64) @ 2011-04-18 16:18:52 UTC]
Xlib: extension "RANDR" missing on display ":0.0".
[Info 13:23:00.175] Updating web proxy from GConf
[Info 13:23:00.623] All services are started 1.619662
** (Banshee:26843): DEBUG: SyncDaemon already running, initializing SyncdaemonDaemon object

(Banshee:26843): libsoup-WARNING **: No feature manager for feature of type 'U1RequestChrome'

** (Banshee:26843): WARNING **: Error calling get_info: Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/pymodules/python2.7/ubuntuone-client/ubuntuone/platform/linux/dbus_interface.py", line 992, in get_info
    return self.syncdaemon_folders.get_info(path)
  File "/usr/lib/pymodules/python2.7/ubuntuone-client/ubuntuone/syncdaemon/interaction_interfaces.py", line 634, in get_info
    mdobj = self.fs.get_by_path(path.encode('utf-8'))
  File "/usr/lib/pymodules/python2.7/ubuntuone-client/ubuntuone/syncdaemon/filesystem_manager.py", line 773, in get_by_path
    mdid = self._idx_path[path]
KeyError: '/home/pepijn/.ubuntuone/Purchased from Ubuntu One'

** (Banshee:26843): CRITICAL **: syncdaemon_folder_info_get_subscribed: assertion `SYNCDAEMON_IS_FOLDER_INFO (finfo)' failed

** (Banshee:26843): WARNING **: Error rescanning Purchased Music: No such file or directory
** (Banshee:26843): DEBUG: Loading the real store page

** (Banshee:26843): WARNING **: Got less number of items in credentials hash table than expected!
[Info 13:23:01.931] nereid Client Started
[Info 13:23:02.016] GStreamer version 0.10.32.0, gapless: True, replaygain: False

Unhandled Exception: GLib.GException: Can't recursively copy directory
  at GLib.FileAdapter.Move (File destination, FileCopyFlags flags, GLib.Cancellable cancellable, GLib.FileProgressCallback progress_callback) [0x00000] in <filename unknown>:0
  at Banshee.IO.Gio.Directory.Move (Hyena.SafeUri from, Hyena.SafeUri to) [0x00000] in <filename unknown>:0
  at Banshee.IO.Directory.Move (Hyena.SafeUri from, Hyena.SafeUri to) [0x00000] in <filename unknown>:0
  at Banshee.Podcasting.PodcastService.<DelayedInitialize>m__11 () [0x00000] in <filename unknown>:0

Please let me know what other information I can produce to help debug this problem.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: banshee 2.0.0-2ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun May 1 13:23:27 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: banshee
UpgradeStatus: Upgraded to natty on 2011-04-30 (0 days ago)

Captain Chaos (launchpad-chaos) wrote :
Chow Loong Jin (hyperair) wrote :

Out of curiosity, do you have the LibraryWatcher extension enabled? If so, could you try disabling that extension and seeing if that helps?

At this point, you probably can't get Banshee to stay open long enough to disable it through the GUI, so try changing this line in ~/.config/banshee-1/addin-db-001/config.xml, from..
    <Addin id="Banshee.LibraryWatcher,1.0" enabled="True" />

to..
    <Addin id="Banshee.LibraryWatcher,1.0" enabled="False" />

Chow Loong Jin (hyperair) wrote :

Actually scratch that, it looks like something the podcasting extension is trying to do. Try disabling that extension instead.

Changed in banshee (Ubuntu):
status: New → Triaged
Captain Chaos (launchpad-chaos) wrote :

It's possible (I don't remember) that Banshee was already installed before the upgrade. I wasn't using it, but I did play around with a few media players. Is there a way I can check?

This is the entire contents on my ~/.config/banshee-1/addin-db-001/config.xml fle:

<Configuration>
  <AddinStatus>
    <Addin id="Banshee.LastfmStreaming,1.0" enabled="False" />
  </AddinStatus>
</Configuration>

There doesn't seem to be a podcasting extension to disable (nor a library watcher one).

Chow Loong Jin (hyperair) wrote :

Upstream duplicate bug.

Captain Chaos (launchpad-chaos) wrote :

I tried the workaround mentioned in that bug, of creating a Podcasts directory in my home directory. Banshee then started up correctly! Even after I subsequently deleted the Podcasts directory again, Banshee continued to start up successfully.

It did not migrate my Rhythmbox music library though. Is it mean to? It seems a bit rude to change people's default media player without asking, and then making them import their music all over again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.