Banshee fails on podcasts with "_" in the URL

Bug #761167 reported by ssdg on 2011-04-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Banshee
New
High
banshee (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: banshee

When adding this podcast feed (and any from the same radio for that matter):
http://radiofrance-podcast.net/podcast09/rss_14864.xml

banshee never adds it to the podcasts sources.

More, I added a few from the same source a few months ago.( maybe more) and tried to download the mp3 files via banshee, nothing happens. (except for a small stacktrace stating a 404 errors happened... except there was none, I checked with wireshark, no request was sent and the url is valid and points to the file.

According to this mailing list post, updating mono could fix the problem:
http://osdir.com/ml/banshee-list/2010-09/msg00078.html

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: banshee 1.8.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-28.50-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic i686
Architecture: i386
Date: Thu Apr 14 23:24:01 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANGUAGE=fr_FR:fr:en_GB:en
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: banshee

ssdg (sylvain-delafoy) wrote :
Victor Vargas (kamus) wrote :

Please could you post another podcast url example because it seems that one doesn't have any episodes, yet?

Changed in banshee (Ubuntu):
importance: Undecided → Low
ssdg (sylvain-delafoy) wrote :

as of this moment, this URL contains a few podcasts:
http://radiofrance-podcast.net/podcast09/rss_10265.xml

The problem with this radio station (in addition to the "_") is that most of the time they keep one podcast on each feed at a time.

PS:

You can find a lot of podcasts created the same way here:
http://sites.radiofrance.fr/franceinter/pod/index.php

- a bit of translation: "s'abonner au podcast" => "subscribe to the podcast"
- what looks like a text field on the "subscribe" popup is in fact a link to the RSS feed. Don't be surprised)

Victor Vargas (kamus) wrote :

ssdg, I tried to reproduce this issue with banshee 2.0 included in Ubuntu Natty but it works fine for me, see attached screenshot below. Is it possible to use our latest banshee release from PPA repository?

Victor Vargas (kamus) wrote :

Banshee running the french podcast

ssdg (sylvain-delafoy) wrote :

Hello,

I can test, but I already tested with a ppa (that one: http://ppa.launchpad.net/banshee-team/ppa/ubuntu once added) iis it another?

And did you try to download the podcasted file? It's weird, listening works, but downloading fails and without a copy of the file it's impossible to put it on a MTP enabled device.

Anyway, thank you for you for investigating this issue.

Victor Vargas (kamus) wrote :

ssdg, I haven't tried to download an episode in my last chance, give me a time to do it and to test it.

Victor Vargas (kamus) wrote :

Ok, I am able to reproduce it here too and also I have found the upstream report about this problem, so you can track and follow status of this issue at https://bugzilla.gnome.org/show_bug.cgi?id=643052 , Thanks in advance.

Changed in banshee (Ubuntu):
status: New → Triaged
Changed in banshee:
importance: Unknown → Medium
status: Unknown → Confirmed
ssdg (sylvain-delafoy) wrote :

Kamus, thanks a lot for reporting the bug.

Unfortunatelly, it looks like fixing this in ubuntu means updating mono to a new version and I doubt it could be done before natty being released.

Anyway, thanks again for confirming for your time and work.

Changed in banshee:
status: Confirmed → Invalid
Victor Vargas (kamus) wrote :

This issue now is a duplicate of bug https://bugzilla.gnome.org/show_bug.cgi?id=583655

Changed in banshee:
importance: Medium → Unknown
status: Invalid → Unknown
ssdg (sylvain-delafoy) wrote :

Kamus > Wasn't this fixed upstream by using a more recent version of mono?

That what I though while reading this comment ( https://bugzilla.gnome.org/show_bug.cgi?id=643052#c5 ) but because I'm not native, I might have misunderstood.

Is there a PPA with an up to date mono package so I can test again?

Changed in banshee:
importance: Unknown → High
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.