banshee 1.9.4-1ubuntu1 crashes on now playing view with wikipedia plugin enabled (by default, main banshee package)

Bug #725316 reported by Christian Niemeyer on 2011-02-25
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Banshee
Fix Released
High
banshee (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: banshee

New banshee version works ok, but always and immediately when clicked on "Now Playing" it crashes. This happens all time time, if music is playing or not.

Steps to reproduce:
1) Click on "Now Playing" on the browser list at the left side. This should give you a nice view on the cover.
2) it crashes and gives at last an X error (X Window System error, see bottom log)

I'm running compiz (nouveau) without unity enabled. Runs stable though. On natty 64bit.

I have only installed the banshee package. I tried with extensions, but it crashes too, so no impact on that.

$ dpkg -l banshee
||/ Name Version Description
ii banshee 1.9.3-2ubuntu1 Media Management and Playback application

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Natty (development branch)
Release: 11.04
Codename: natty

$ uname -a
Linux natty 2.6.38-5-generic #32-Ubuntu SMP Tue Feb 22 16:10:15 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

$ cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 39
model name : AMD Athlon(tm) 64 Processor 3700+
stepping : 1
cpu MHz : 1000.000
cache size : 1024 KB
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow up rep_good nopl pni lahf_lm
bogomips : 2009.43
TLB size : 1024 4K pages
clflush size : 64
cache_alignment : 64
address sizes : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc

Here's the error from the command line:

$ banshee
[Info 23:28:50.962] Running Banshee 1.9.3: [Ubuntu natty (development branch) (linux-gnu, x86_64) @ 2011-02-20 07:36:24 UTC]
[Warn 23:28:51.311] DBus support could not be started. Disabling for this session.
[Warn 23:28:51.470] Cannot connect to NetworkManager or Wicd - An available, working network connection will be assumed
(Banshee:17074): GVFS-RemoteVolumeMonitor-WARNING **: invoking IsSupported() failed for remote volume monitor with dbus name org.gtk.Private.GduVolumeMonitor: org.freedesktop.DBus.Error.Spawn.ChildSignaled: Process /usr/lib/gvfs/gvfs-gdu-volume-monitor received signal
(Banshee:17074): Gtk-WARNING **: Could not find the icon 'context-pane-maximize'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
        http://icon-theme.freedesktop.org/releases
[Warn 23:28:52.407] Caught an exception - GLib.GException: Icon 'process-working' not present in theme (in `gtk-sharp')
  at Gtk.IconTheme.LoadIcon (System.String icon_name, Int32 size, IconLookupFlags flags) [0x00000] in <filename unknown>:0
  at Banshee.Gui.Widgets.TaskStatusIcon..ctor () [0x00000] in <filename unknown>:0
[Warn 23:28:52.734] Caught an exception - System.ApplicationException: No support GNOME Settings Daemon could be reached. (in `Banshee.MultimediaKeys')
  at Banshee.MultimediaKeys.MultimediaKeysService.Banshee.ServiceStack.IExtensionService.Initialize () [0x00000] in <filename unknown>:0
  at Banshee.ServiceStack.ServiceManager.StartExtension (Mono.Addins.TypeExtensionNode node) [0x00000] in <filename unknown>:0
[Warn 23:28:52.735] Extension `Banshee.MultimediaKeys.MultimediaKeysService' not started: No support GNOME Settings Daemon could be reached.
[Info 23:28:52.772] Updating web proxy from GConf
[Warn 23:28:52.849] Caught an exception - System.ApplicationException: No support GNOME Settings Daemon could be reached. (in `Banshee.MultimediaKeys')
  at Banshee.MultimediaKeys.MultimediaKeysService.Banshee.ServiceStack.IExtensionService.Initialize () [0x00000] in <filename unknown>:0
  at Banshee.ServiceStack.ServiceManager.StartExtension (Mono.Addins.TypeExtensionNode node) [0x00000] in <filename unknown>:0
[Warn 23:28:52.849] Extension `Banshee.MultimediaKeys.MultimediaKeysService' not started: No support GNOME Settings Daemon could be reached.
[Info 23:28:52.850] All services are started 1.537392
[Info 23:28:53.852] nereid Client Started
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
[Info 23:28:59.701] Uncached artwork size 34 requested
[Info 23:29:00.884] GNOME screensaver service not found
The program 'Banshee' received an X Window System error.
This probably reflects a bug in the program.

The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 32426 error_code 8 request_code 70 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

$

Related branches

description: updated

Hint: I found a work around. Though I have only installed the banshee package, it comes with some default extensions.

I went in the Menu to > Edit > Preferences > Extensions and un-checked ALL of them. Quit the program. Restart.

Not it works perfectly. Changing to Now Playing. Even changing to complete fullscreen.

Console output from this successful run/workaround:
(At the end it says something about "NowPlaying." however it works with all extensions disabled..., but this maybe a good hint)

$ banshee
[Info 23:45:41.543] Running Banshee 1.9.3: [Ubuntu natty (development branch) (linux-gnu, x86_64) @ 2011-02-20 07:36:24 UTC]
[Warn 23:45:41.955] DBus support could not be started. Disabling for this session.
[Warn 23:45:42.127] Cannot connect to NetworkManager or Wicd - An available, working network connection will be assumed

(Banshee:17261): GVFS-RemoteVolumeMonitor-WARNING **: invoking IsSupported() failed for remote volume monitor with dbus name org.gtk.Private.GduVolumeMonitor: org.freedesktop.DBus.Error.Spawn.ChildSignaled: Process /usr/lib/gvfs/gvfs-gdu-volume-monitor received signal 6

(Banshee:17261): Gtk-WARNING **: Could not find the icon 'context-pane-maximize'. The 'hicolor' theme
was not found either, perhaps you need to install it.
You can get a copy from:
        http://icon-theme.freedesktop.org/releases
[Warn 23:45:42.972] Caught an exception - GLib.GException: Icon 'process-working' not present in theme (in `gtk-sharp')
  at Gtk.IconTheme.LoadIcon (System.String icon_name, Int32 size, IconLookupFlags flags) [0x00000] in <filename unknown>:0
  at Banshee.Gui.Widgets.TaskStatusIcon..ctor () [0x00000] in <filename unknown>:0
[Info 23:45:43.163] Updating web proxy from GConf
[Info 23:45:43.205] All services are started 1.247349
[Info 23:45:44.097] nereid Client Started
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
[Info 23:45:45.846] Uncached artwork size 34 requested
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
[Info 23:45:48.634] GNOME screensaver service not found
[Warn 23:45:49.849] Could not configure libwnck support -

System.DllNotFoundException: libgobject-2.0.so (in `Banshee.NowPlaying.X11')
  at (wrapper managed-to-native) Banshee.NowPlaying.X11.FullscreenAdapter/WnckActiveWorkspaceMonitor:g_signal_connect_data (intptr,string,Banshee.NowPlaying.X11.FullscreenAdapter/WnckActiveWorkspaceMonitor/WnckActiveWorkspaceChangedHandler,intptr,intptr,uint)
  at Banshee.NowPlaying.X11.FullscreenAdapter+WnckActiveWorkspaceMonitor..cctor () [0x00000] in <filename unknown>:0
System.TypeInitializationException: An exception was thrown by the type initializer for WnckActiveWorkspaceMonitor (in `Banshee.NowPlaying.X11')
  at Banshee.NowPlaying.X11.FullscreenAdapter..ctor () [0x00000] in <filename unknown>:0
[Info 23:45:50.220] Inhibiting screensaver during fullscreen playback
[Info 23:45:51.248] Uninhibiting screensaver

$

(PS: Please ignore the warnings about icons, indeed I messed up my icon themes on this test system)

Update:

I went to every extension enabled/disabled and it seems to be related with the Wikipedia extension, which is in the default set and enabled by default.

However, enabling/disabling extension only has an impact, when before quitting banhee completely and restarting. In the following two cases with the extension, hope that makes it clearer:

Case1: DOESN'T CRASH
>Edit >Preferences
>Extensions
(Context Pane extensions)
Wikipedia DISABLED
YouTube ON
(Core extensions)
Audio CD Support ON
Audiobooks Library ON
File System Preview Queue ON
Internet Radio ON
Play Queue ON
Podcasts ON
(Device Support Extensions)
Apple device support ON
Mass Storage Media Player Support ON
MTP Media Player Support ON
(Online Sources extensions)
Amazon MP3 Import ON
Amazon MP3 Store Source ON
eMusic Import ON
Internet Archive ON
Last.fm Radio ON
Last.fm Scrobbling ON
Miro Guide Podcast Directory ON
(Utilities extensions)
BPM detection ON
Cover Art Fetching ON
DAAP Sharing ON
Importers for Amarok, Rhythmbox and iTunes ON
Library Watcher ON
Metadate Fixup ON
Mini Mode ON
MPRIS D-Bus Interface ON
Multimedia Keys ON
Notification Area Icon ON
Sound Menu Integration for Banshee (not installed or disabled because Notification Area is ON)

In >Preferences > General:
ReplayGain correction ON
Gapless Playback ON
Internet access NOT disabled / ON
Send anonymous user data DISABLED
Everything else default settings.

So all these make no problem for me. However, if I active the WIKIPEDIA Extension in running the program and playing music switching the view, it works.

But then restarting with the Wikipedia extension activated, Banshee crashes immediately when clicking on "Now Playing" again. Disabling Wikipedia and restarting again: Banshee works fine in "Now Playing" mode.

I guess this wikipedia extension is in the default set of banshee-package and enabled by default. That seem to be the problem for me. However, this can also be related to dependencies or libwebkit... ?

summary: - banshee 1.9.3-2ubuntu1 crashes when changing to now playing view
+ banshee 1.9.3-2ubuntu1 crashes on now playing view with wikipedia plugin
+ enabled (by default, main banshee package)

setting the bug status to 'confirmed'

Changed in banshee (Ubuntu):
status: New → Confirmed
tags: added: natty
Victor Vargas (kamus) wrote :

I cannot reproduce it here with 1.9.4-1ubuntu1, please could you upgrade your banshee to the latest available in Natty and check if this issue persists for you?

Changed in banshee (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
summary: - banshee 1.9.3-2ubuntu1 crashes on now playing view with wikipedia plugin
+ banshee 1.9.4-1ubuntu1 crashes on now playing view with wikipedia plugin
enabled (by default, main banshee package)

Hi, I just upgraded to the new version and the behaviour is the same. I updated the bug description. Please see exact steps to reproduce below. Error message still:

The program 'Banshee' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 22997 error_code 8 request_code 70 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

With Wikipedia plugin enabled (which is by default) changing to "Now Playing" view. Mhm, these are ogg-files, which I play. Cover fetching works fine though for the browser view. Nothing related to that, I guess.

$ dpkg -l banshee

ii banshee 1.9.4-1ubuntu1 Media Management and Playback application

I tried now with ALL plugins disabled, and only Wikipedia plugin enabled. It crashes.
With all plugins enabled, but Wikipedia plugin not enabled it does not crash on the "now playing" view.

IMPORTANT to reproduce:
Please keep in mind, to activate the Wikipedia plugin in the Preferences dialog. Then fully exit Banshee (Strg+Q, not just in the tray, exit the program completely) then restart Banshee. Start a song or music track, change to "Now Playing view" then it crashes.

Victor Vargas (kamus) wrote :

Christian, it doesn't crashed for me but while I was running banshee (1.9.4 in a fresh install of Natty daily build) with debug I get a similar output:

Could not configure libwnck support - System.DllNotFoundException: libgobject-2.0.so (in `Banshee.NowPlaying.X11')
  at (wrapper managed-to-native) Banshee.NowPlaying.X11.FullscreenAdapter/WnckActiveWorkspaceMonitor:g_signal_connect_data (intptr,string,Banshee.NowPlaying.X11.FullscreenAdapter/WnckActiveWorkspaceMonitor/WnckActiveWorkspaceChangedHandler,intptr,intptr,uint)
  at Banshee.NowPlaying.X11.FullscreenAdapter+WnckActiveWorkspaceMonitor..cctor () [0x0001d] in /build/buildd/banshee-1.9.4/src/Backends/Banshee.NowPlaying.X11/Banshee.NowPlaying.X11/FullscreenAdapter.cs:197
System.TypeInitializationException: An exception was thrown by the type initializer for WnckActiveWorkspaceMonitor (in `Banshee.NowPlaying.X11')
  at Banshee.NowPlaying.X11.FullscreenAdapter..ctor () [0x00006] in /build/buildd/banshee-1.9.4/src/Backends/Banshee.NowPlaying.X11/Banshee.NowPlaying.X11/FullscreenAdapter.cs:101

however, such as said before it doesn't crash.

Victor Vargas (kamus) wrote :

Well, since this is a weird behaviou I have sent this issue to upstream tracker so please keep an eye over https://bugzilla.gnome.org/show_bug.cgi?id=643616

Changed in banshee (Ubuntu):
status: Incomplete → Triaged
Victor Vargas (kamus) wrote :

wow, that was fast, according to upstream tracker this issue is a duplicate of bug https://bugzilla.gnome.org/show_bug.cgi?id=641515

Changed in banshee:
importance: Unknown → High
status: Unknown → Confirmed
Victor Vargas (kamus) on 2011-03-01
Changed in banshee (Ubuntu):
importance: Medium → High
Chow Loong Jin (hyperair) wrote :

Christian, you're actually seeing a different bug. Notice that in the description, the error message is an X11 message about BadMatch or something. Your error message is about a DllNotFoundException, which I have just committed a fix for in the Debian packaging. The DllNotFoundException issue can be worked around by installing libglib2.0-dev.

Please do not hijack bugs like this in the future, as it can cause quite a bit of confusion, and cause bugs to be erroneously closed. Similar symptoms do not always mean that the bug is the one and the same.

Changed in banshee:
status: Confirmed → Fix Released
Changed in banshee (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.