banshee cannot load music on mtp device

Bug #712957 reported by psypher on 2011-02-04
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Banshee
Expired
Medium
banshee (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: banshee

Hi All,

This is the first time I am trying my Creative Zen 16GB device in Maverick, worked fine in Lucid. When I plug the device in, while banshee is open, the device screen flashes between mounted and not mounted screens a few times then i mounts. I only got it to mount by formatting the entire device and starting again. When I try copy a song I get a sync error: Argument cannot be null. parameters name:obj.

This happens with ever song. I have attached the debug while attempting an upload.

When i try running banshee-1 it seems to work. I was able to successfully copy several gigs without a single error.

Scratch that, when trying to do it again, it has now crashed my player, having to hard reboot it. And now I can no longer copy any files. Cannot reproduce a working debug anymore.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: banshee 1.8.0-2ubuntu1~maverick2
ProcVersionSignature: Ubuntu 2.6.35-25.44-generic 2.6.35.10
Uname: Linux 2.6.35-25-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri Feb 4 11:08:43 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_ZA.utf8
 SHELL=/bin/bash
SourcePackage: banshee

psypher (psypher246) wrote :
psypher (psypher246) wrote :
psypher (psypher246) wrote :
Victor Vargas (kamus) wrote :

psyquer, Please could you check if this behaviour is still occurring with latest release of banshee 1.9.2 from daily ppa repository? by the way, did you run banshee-1 with or without parameters?

Changed in banshee (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
psypher (psypher246) wrote :

Hi Kamus,

I now have the latest 1.9.3 installed via PPA. Problem still occuring. I have attached 2 debugs again for banshee and banshee-1. The procedure I use is:
Start Banshee in debug
Connect Zen
Copy file (fails with same Argument cannot be null. parameters name:obj error)
Attempt to disconnect (fails with same Argument cannot be null. parameters name:obj error)
Quit

I do not use any parameters except --debug.

Thanks

Victor Vargas (kamus) wrote :

Since you have provided us enough information I have sent this issue to upstream tracker, Thanks!

Changed in banshee (Ubuntu):
status: Incomplete → Triaged
Changed in banshee:
importance: Unknown → Medium
status: Unknown → New
psypher (psypher246) wrote :

Thanks!

Victor Vargas (kamus) wrote :

Upstream said:

Can you please attach the information requested in the Filing bugs section
here:

http://live.gnome.org/Banshee/LibgpodTransition

Also can you attach the output from mtp-detect when the device is attached.

Changed in banshee:
status: New → Incomplete
psypher (psypher246) wrote :

Creative ZEN 16GB (Black)
V: 1.21.01

The part number is not on the device software, just the info above

As far as I can tell this is the S/N on the outside, it's very small text:

mapf 2161 821m 0133 1e

dvpfl0001

psypher (psypher246) wrote :

HI, any update on this? The status still says incomplete but I have provided the required info.

Thanks

Chow Loong Jin (hyperair) wrote :

The log needs to be sent upstream, if not already (see the gnome-bugs link). However, it looks like bugzilla.gnome.org is currently down, so it'll need to be done later when it comes back up.

psypher (psypher246) wrote :

Hi, I have provided all the information requested. Please could you provide the upstream bug report number so I can follow up there.

Thanks

Changed in banshee:
status: Incomplete → New
Changed in banshee:
status: New → Incomplete

The bug is still present in Oneiric.

Changed in banshee:
status: Incomplete → Invalid
Chow Loong Jin (hyperair) wrote :

Upstream bug marked as duplicate of https://bugzilla.gnome.org/show_bug.cgi?id=627698.

Changed in banshee:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in banshee:
importance: Unknown → Medium
status: Unknown → New
Changed in banshee:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.