Banshee.exe crashed with SIGSEGV in g_cclosure_marshal_VOID__BOXED()

Bug #706535 reported by Jean-Baptiste Lallement on 2011-01-23
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
banshee (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: banshee

Test Case:
- Open a terminal
- Launch Banshee from the command line
- In the global menu select 'Media/Quit'

This is reproducible.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: banshee 1.9.1-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic i686
Architecture: i386
Date: Sun Jan 23 12:26:25 2011
Disassembly: => 0x36483d0: Cannot access memory at address 0x36483d0
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/banshee-1/Banshee.exe
InterpreterPath: /usr/bin/mono
ProcCmdline: banshee-1 /usr/lib/banshee-1/Banshee.exe
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LC_MESSAGES=en_US.utf8
 LANG=en_US.utf8
 LANGUAGE=en_US:en
SegvAnalysis:
 Segfault happened at: 0x36483d0: Cannot access memory at address 0x36483d0
 PC (0x036483d0) not located in a known VMA region (needed executable region)!
SegvReason: executing unknown VMA
Signal: 11
SourcePackage: banshee
StacktraceTop:
 ?? ()
 g_cclosure_marshal_VOID__BOXED () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
Title: Banshee.exe crashed with SIGSEGV in g_cclosure_marshal_VOID__BOXED()
UserGroups: adm admin audio cdrom dialout dip floppy fuse libvirtd lpadmin netdev plugdev scanner sudo video

Jean-Baptiste Lallement (jibel) wrote :

StacktraceTop:
 ?? ()
 g_type_class_meta_marshal (closure=0xb76ff128,
 g_closure_invoke (closure=0xb76ff128, return_value=0x0,
 signal_emit_unlocked_R (node=0xb76e2700, detail=0,
 g_signal_emit_valist (instance=0xb050ec10, signal_id=18,

Changed in banshee (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Kamus (kamus) wrote :

Not reproducible here with latest release, please could you upgrade to 1.9.2-1ubuntu1 and check if this issue persists for you? Thanks

visibility: private → public
Changed in banshee (Ubuntu):
status: New → Incomplete
Jean-Baptiste Lallement (jibel) wrote :

Yes, it's still there with the latest update.

On the terminal the following error is displayed:
$ banshee
[Info 22:26:08.673] Running Banshee 1.9.2: [Ubuntu natty (development branch) (linux-gnu, i686) @ 2011-01-24 15:11:29 UTC]
[Info 22:26:09.903] Updating web proxy from GConf
[Info 22:26:09.958] All services are started 1.046424
[Info 22:26:11.143] nereid Client Started
[Info 22:26:11.332] AppleDeviceSource is ignoring unmounted volume cdrom0
[Warn 22:26:11.335] Caught an exception - System.InvalidOperationException: Operation is not valid due to the current state of the object (in `Banshee.Dap.AppleDevice')
  at Banshee.Dap.AppleDevice.AppleDeviceSource.DeviceInitialize (IDevice device) [0x00000] in <filename unknown>:0
  at Banshee.Dap.DapService.FindDeviceSource (IDevice device) [0x00000] in <filename unknown>:0
[Warn 22:26:11.355] Caught an exception - System.ArgumentNullException: Argument cannot be null.
Parameter name: s (in `mscorlib')
  at System.Int32.Parse (System.String s) [0x00000] in <filename unknown>:0
  at Banshee.Hardware.Gio.UsbDevice.GetBusNumber (IUsbDevice device) [0x00000] in <filename unknown>:0
  at Banshee.Hardware.Gio.UsbDevice.get_BusNumber () [0x00000] in <filename unknown>:0
  at Banshee.Hardware.Gio.Device.ResolveUsbPortInfo () [0x00000] in <filename unknown>:0
  at Banshee.Dap.Mtp.MtpSource.DeviceInitialize (IDevice device) [0x00000] in <filename unknown>:0
  at Banshee.Dap.DapService.FindDeviceSource (IDevice device) [0x00000] in <filename unknown>:0
[Warn 22:26:11.410] Caught an exception - System.ArgumentNullException: Argument cannot be null. (in `mscorlib')
  at System.Int32.Parse (System.String s, NumberStyles style, IFormatProvider provider) [0x00000] in <filename unknown>:0
  at System.Int32.Parse (System.String s, NumberStyles style) [0x00000] in <filename unknown>:0
  at Banshee.Hardware.Gio.UsbDevice.GetVendorId (IUsbDevice device) [0x00000] in <filename unknown>:0
  at Banshee.Hardware.Gio.UsbDevice.get_VendorId () [0x00000] in <filename unknown>:0
  at Banshee.Dap.MassStorage.DeviceMapper.Map (Banshee.Dap.MassStorage.MassStorageSource source) [0x00000] in <filename unknown>:0
  at Banshee.Dap.MassStorage.MassStorageSource.DeviceInitialize (IDevice device) [0x00000] in <filename unknown>:0
  at Banshee.Dap.DapService.FindDeviceSource (IDevice device) [0x00000] in <filename unknown>:0
[Info 22:26:11.561] Creating Accessible for Banshee.Collection.Gui.TrackListView
Segmentation fault (core dumped)

Changed in banshee (Ubuntu):
status: Incomplete → Confirmed
Patrick Wright (patrickmwright) wrote :

I just tested this in Natty Beta 2. The Quit menu item has been changed to Close, and the banshee closes without any error in the terminal.

Changed in banshee (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers