Unable to recognize active pane

Bug #678116 reported by David Prieto on 2010-11-21
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Banshee
Confirmed
Medium
banshee (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: banshee

I have noticed that Banshee does not seem to follow the way other apps in Ubuntu highlight items, or show the active pane; normally apps highlight items using an orange colour, which changes to grey when that pane (or the whole app) is not focused.

Instead, Banshee seems to use orange for all panes, the focused one as well as the unfocused, and shows which pane is focused by drawing a second border inside it. This deviation from the norm makes more difficult to guess what will happen if you press a given key (e.g. the tab key or a direction key), so using the standard way would be beneficial.

Victor Vargas (kamus) wrote :

What version of banshee do you use (and theme)? because I am working with release 1.9.0 and tried with differents gnome themes and show me active panes with the appropiate colors according to the theme.

Changed in banshee (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

I'm also using the 1.9 version, more specifically the one in the Natty repos; I'm using Ubuntu's default theme. Kamus, could you please attach a screenie showing how banshee looks there? I'd like to compare.

Victor Vargas (kamus) wrote :

Attached screenshot of Banshee with Human theme,

Regards

Alright, that's exactly what I mean. If that were a typical gnome app the "music" and "all albums" items would be highlighted grey, not brown; also, "Foo Fighters" would be highlighted brown but the artists pane wouldn't have a thicker border to indicate that it's the active pane.

Vish (vish) on 2010-12-04
Changed in banshee (Ubuntu):
status: Incomplete → Confirmed
Vish (vish) wrote :

What David is referring to is the selected color.
Attaching a comparison with a GNOME app,[RB just happened to be the one I could
find with 3panes]

Notice that all the three panes appear with the same 'active orange' color,
irrespective of where the cursor is pressed.

This is because Banshee uses only bg[SELECTED] for the color in all three panes
and only text[SELECTED] in the browser view.

Oddly, Banshee uses the text[ACTIVE] color in the source view alone. Hence we
can notice that once the selection is in the other two panes, the font color
changes to black.

Usually themes define :
    bg[SELECTED] = "#foo"
    bg[ACTIVE] = "#foo"

    text[SELECTED] = "#foo"
    text[ACTIVE] = "#foo"

Most of the GNOME apps use this to differentiate the selected/active colors.

Changed in banshee (Ubuntu):
status: Confirmed → Triaged
summary: - Use a standard way to highlight elements
+ Unable to recognize active pane
Vish (vish) on 2010-12-04
Changed in hundredpapercuts:
assignee: nobody → Papercuts Ninja (papercuts-ninja)
importance: Undecided → Low
milestone: none → nt1-music
status: New → Triaged
Vish (vish) wrote :

David, if you have already forwarded a bug upstream then do mention the bug number here as well, saves some work for others. ;-)

Bilal Akhtar (bilalakhtar) wrote :

Working on this one upstream.

Changed in hundredpapercuts:
assignee: Papercuts Ninja (papercuts-ninja) → Bilal Akhtar (bilalakhtar)
status: Triaged → In Progress
Bilal Akhtar (bilalakhtar) wrote :

Upstream guys seem to be working on this already, and I think it would be better to leave this one to them

However, still someone can help them by submitting a patch.

Changed in hundredpapercuts:
assignee: Bilal Akhtar (bilalakhtar) → Papercuts Ninja (papercuts-ninja)
status: In Progress → Triaged
Vish (vish) wrote :

Bilal Akhtar , From upstream bug "Just a tip for anyone who feels like working on this. The class to edit is
probably Hyena.Data.Gui.ListView_Rendering.cs"

So, no one is working on it yet. They have given a hint how to fix it.

Victor Vargas (kamus) wrote :

thanks for sent this to upstream Vish, David now I am clear :)

Changed in banshee:
importance: Unknown → Medium
status: Unknown → Confirmed

Thanks a lot for reporting this, however since Banshee is due to be dropped from the default installation, this bug no longer constitutes a papercut.

More information on what constitutes a papercut may be found here https://wiki.ubuntu.com/PaperCut

Changed in hundredpapercuts:
status: Triaged → Invalid
assignee: Papercuts Ninja (papercuts-ninja) → nobody
milestone: nt1-music → none

  affects hundredpapercuts
  status new

The discussion regarding Banshee is still ongoing and a decision has not been
made yet. Please wait a while longer before closing all these bugs.

--
Kind regards,
Loong Jin

Changed in hundredpapercuts:
status: Invalid → New
Changed in hundredpapercuts:
status: New → Triaged

Thanks a lot for reporting this, however since Banshee is due to be dropped from the default installation, this bug no longer constitutes a papercut.

More information on what constitutes a papercut may be found here https://wiki.ubuntu.com/PaperCut

Changed in hundredpapercuts:
status: Triaged → Invalid
no longer affects: hundredpapercuts
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.