Banshee is not translated in the menu

Bug #677173 reported by Gianvito Cavasoli on 2010-11-18
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
banshee (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

The desktop file of Banshee in Ubuntu Maverick replaced all the localized Name fields with X-Ubuntu-Gettext-Domain=banshee. However, Banshee's .mo files were called banshee-1.mo. Hence, they ended up untranslated.

TEST CASE:
1. Log into a non-English locale
2. Open Applications Menu
3. Navigate to Sound & Video (whatever it's called in the locale you've chosen)
4. Check that "Banshee Media Player" is properly localized.

On Friday 19,November,2010 04:32 AM, Gianvito Cavasoli wrote:
> Public bug reported:
>
> Binary package hint: banshee
>
> In the .desktop file of Banshee missing the strings of the translation
> languages. This bug affects Banshee in Maverick and Natty.

The .desktop file has the X-Ubuntu-Gettext-Domain=banshee field which should
make Banshee appear in the menu and other applications properly anyway. See
https://wiki.ubuntu.com/LangpacksDesktopfiles for more information

Which locale are you seeing this issue in?

  affects ubuntu/banshee
  status incomplete

--
Kind regards,
Loong Jin

Changed in banshee (Ubuntu):
status: New → Incomplete
Gianvito Cavasoli (janvitus) wrote :

Italian.

Gabor Kelemen (kelemeng) wrote :

"The .desktop file has the X-Ubuntu-Gettext-Domain=banshee field which should
make Banshee appear in the menu and other applications properly anyway. "

This is the problem, because the .mo file is called banshee-1.mo, not banshee.mo. I just changed /usr/share/applications/banshee-1.desktop to use X-Ubuntu-Gettext-Domain=banshee-1 and the menu item became translated.

Changed in banshee (Ubuntu):
status: Incomplete → Confirmed
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium

On Thursday 25,November,2010 05:29 AM, Gabor Kelemen wrote:
> "The .desktop file has the X-Ubuntu-Gettext-Domain=banshee field which should
> make Banshee appear in the menu and other applications properly anyway. "
>
> This is the problem, because the .mo file is called banshee-1.mo, not
> banshee.mo. I just changed /usr/share/applications/banshee-1.desktop to
> use X-Ubuntu-Gettext-Domain=banshee-1 and the menu item became
> translated.

  affects ubuntu/banshee
  status confirmed

Thanks for identifying the issue! I'll commit a patch to fix this.

--
Kind regards,
Loong Jin

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package banshee - 1.9.0+git20101121.r1.b13266e-0ubuntu4

---------------
banshee (1.9.0+git20101121.r1.b13266e-0ubuntu4) natty; urgency=low

  * debian/rules: Fix gettext domain (LP: #677173)
 -- Chow Loong Jin <email address hidden> Thu, 25 Nov 2010 11:30:48 +0800

Changed in banshee (Ubuntu):
status: Confirmed → Fix Released
Chow Loong Jin (hyperair) wrote :

Uploaded an SRU for Maverick

  affects ubuntu/maverick/banshee
  status fixcommitted
  subscribe ubuntu-sru

--
Kind regards,
Loong Jin

description: updated
David Planella (dpm) on 2010-11-25
Changed in ubuntu-translations:
status: Triaged → Fix Released

Accepted banshee into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Gianvito Cavasoli (janvitus) wrote :

Work properly.

Martin Pitt (pitti) on 2010-11-30
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package banshee - 1.8.0-2ubuntu1~maverick2

---------------
banshee (1.8.0-2ubuntu1~maverick2) maverick-proposed; urgency=low

  * debian/rules: Fix gettext domain (LP: #677173)
 -- Chow Loong Jin <email address hidden> Thu, 25 Nov 2010 12:05:09 +0800

Changed in banshee (Ubuntu Maverick):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers