Internet Radio doesn't function when banshee launched by music applet

Bug #674116 reported by eyrieowl on 2010-11-11
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Banshee
Fix Released
Medium
banshee (Ubuntu)
Medium
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: banshee

I added this stream: http://ktru.org/audiometa/listen3.m3u to banshee. At first I thought that banshee internet radio wasn't working. I tried all the other streaming urls at http://ktru.org/ (they have 3 mp3 streams, 2 AAC, 1 real audio, 1 wma), and none of them worked. They had, however, been working when I'd previously been using rhythmbox. I verified they were still working in rhythmbox. I didn't see anything relevant in the banshee log...so I tried running banshee from the command line. lo-and-behold, the radio worked. I changed the music-applet to use the banshee-1 command instead of DBus...still didn't work. I also tried banshee command, still no love. So, it works from the command line, works from the Applications menu. I then went to the music-applet page, saw that it's being replaced with panflute. I installed panflute...still had the same issue. I suspect there's something about how Banshee reports to the applets when it starts a stream which causes Banshee to end up failing to play the stream. All the Banshee tells me is "unspecified error". The work around, of course, is to not use the music applet or panflute to run banshee. However, the player should probably be able to play the streams regardless of how it was invoked. Hence the bug-report.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: banshee 1.6.1-1~lucid1
ProcVersionSignature: Ubuntu 2.6.32-25.45-generic 2.6.32.21+drm33.7
Uname: Linux 2.6.32-25-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CheckboxSubmission: 37894631f5c420e18ac8edbbb2af3541
CheckboxSystem: edda5d4f616ca792bf437989cb597002
Date: Thu Nov 11 10:21:28 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/usr/bin/tcsh
SourcePackage: banshee

eyrieowl (eyrieowl) wrote :
eyrieowl (eyrieowl) wrote :

Oh, and it's worth noting that the streams work with music-applet/panflute running *as long as* banshee is NOT started by the applet. They only fail to function when Banshee is run from the applet itself.

On Friday 12,November,2010 12:31 AM, eyrieowl wrote:
> Oh, and it's worth noting that the streams work with music-
> applet/panflute running *as long as* banshee is NOT started by the
> applet. They only fail to function when Banshee is run from the applet
> itself.
>

Alright, can you try uploading the contents of the ~/.config/banshee-1/log file
when that happens? i.e. Launch Banshee from Panflute and try to get it to play
the stream, and then upload the log file.

  affects ubuntu/banshee
  status incomplete

--
Kind regards,
Loong Jin

Changed in banshee (Ubuntu):
status: New → Incomplete
eyrieowl (eyrieowl) wrote :

Hrm...well, no, I don't think I can. I don't get anything written to log when running from the applet. If I remove the log file, and run banshee from the applet, and try playing the stream, and then exit banshee...at no point during or after that process is there a ~/.config/banshee-1/log file. However, as soon as I run banshee from the applications menu, I get a log file. Of course, that one is less useful for this problem b/c the stream works in that scenario.

Chow Loong Jin (hyperair) wrote :

On Friday 12,November,2010 01:16 AM, eyrieowl wrote:
> Hrm...well, no, I don't think I can. I don't get anything written to
> log when running from the applet. If I remove the log file, and run
> banshee from the applet, and try playing the stream, and then exit
> banshee...at no point during or after that process is there a
> ~/.config/banshee-1/log file. However, as soon as I run banshee from
> the applications menu, I get a log file. Of course, that one is less
> useful for this problem b/c the stream works in that scenario.
>

Okay, can you tell Panflute to run Banshee like this: "banshee --debug
--redirect-log"

--
Kind regards,
Loong Jin

eyrieowl (eyrieowl) wrote :

oh, and just to note, I did use music-applet and not panflute because I didn't see where in panflute to change how it launches the application. It's probably in a config file somewhere but since music-applet makes it easy and has the same behaviour I just used it.

Chow Loong Jin (hyperair) wrote :

On Friday 12,November,2010 02:00 AM, eyrieowl wrote:
>
> ** Attachment added: "log file for banshee run from command line with --debug --redirect-log"
> https://bugs.launchpad.net/ubuntu/+source/banshee/+bug/674116/+attachment/1730238/+files/bansheeWorking.log
>

Are you adding the streams into Banshee via Panflute? It looks like it was
trying to parse an invalid URL.

--
Kind regards,
Loong Jin

eyrieowl (eyrieowl) wrote :

No. I'm using the URL pasted above, and I'm not editing the station between runs of banshee. The station is configured (and was initially configured) from within Banshee. The only difference is how Banshee was invoked. The same station configuration is present with either way of invoking the application, but when I attempt to play it, I get different behaviour.

eyrieowl (eyrieowl) wrote :

To follow up, is there any extra info you require? I can consistently replicate this result, every time.

Changed in banshee:
importance: Unknown → Medium
status: Unknown → Confirmed

I can confirm this. I'm using the sound indicator and internet doesn't work. Running through terminal works fine.

I've tried both 1.8 and the latest unstable 1.9

Victor Vargas (kamus) wrote :

Confirmed under release 1.9.0-1ubuntu1~hyper1+maverick

Changed in banshee (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged

Same here:

I use banshee 1.8 (maverick proposed) and there are definitely problems when switching radio channels, radio gets unuseable after some zapping of radio streams whereas mp3 playing stays functional.

Also after some zapping the audio menu integration stops working, banshee works again when loading from the gnome menu.

I tried banshee after i have read that banshee becomes the default ubuntu audio player and really very fast stumbled over this bug.

Clementine works nice and is also available with windows, btw., but it is qt-based.

Erlan Sergaziev (sergeant) wrote :

Also affects Banshee on Natty.

Changed in banshee:
status: Confirmed → Fix Released

Accepted banshee into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in banshee (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed

It works just fine for me. The fix is good.

Changed in banshee (Ubuntu):
status: Triaged → Fix Committed
Martin Pitt (pitti) on 2011-02-02
tags: added: verification-done
removed: verification-needed
Victor Vargas (kamus) wrote :

According to last duplicate report, this issue is still happening in Natty with 1.9.2 release. By the way and for the record, there is a video available at https://bugs.launchpad.net/ubuntu/+source/banshee/+bug/704381/+attachment/1851397/+files/out-1.ogv

The fix is included in both in the 1.8.1 stable release, and the recent 1.9.3 development release, which should become available in Natty at some point.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package banshee - 1.9.3-2ubuntu1

---------------
banshee (1.9.3-2ubuntu1) natty; urgency=low

  * Merge from Debian Experimental, remaining changes:
    + Enable SoundMenu and Disable NotificationArea by default
    + Disable boo and karma extensions
    + Enable and recommnd u1ms and soundmenu extensions
    + Move desktop file for Meego UI to /usr/share/une/applications

banshee (1.9.3-2) unstable; urgency=low

  * [c349fbb] Bump gdata-sharp build-dep to accomodate ABI bump

banshee (1.9.3-1ubuntu1) UNRELEASED; urgency=low

  * Merge from Debian Experimental, remaining changes:
    + Enable SoundMenu and Disable NotificationArea by default
    + Disable boo and karma extensions
    + Enable and recommnd u1ms and soundmenu extensions
    + Move desktop file for Meego UI to /usr/share/une/applications
  * [aa23652] Drop libindicate0.1-cil-dev

banshee (1.9.3-1) unstable; urgency=low

  * [e588bea] New upstream release:
    + Enhancements:
      - Various fixes and improvements to the Windows build
      - MPRIS: Implement the recently added PlaylistChanged signal
      - SoundMenu: Implement the new registration process
      - Daap: Keep a list of recently used remote servers
      - Add back counts for top level libraries
    + Notable Bugs Fixed (36 fixed since 1.9.2):
      - bgo#639603: Fix NRE when current track doesn't have a Uri
      - bgo#486543: Playlists: Fix parsing when started from root directory
      - bgo#640276: AmazonMp3.Store: Fix country detection for United Kingdom
      - bgo#638070: LibraryWatcher: Don't watch non-existing dirs
      - bgo#635779: Fix crash after disabling some extensions (LP: #681362)
      - bgo#636435: PlayQueueSource: Fix track prepending when not playing
      - bgo#641000: NowPlaying: Fix resizing fullscreen control bar
      - bgo#640455: PlayQueue: Additional padding for the fill controls
    + Launchpad bugs fixed:
      - Cannot export Banshee playlist (LP: #392015)
      - Internet Radio doesn't function when Banshee is launched by Music Applet
        (LP: #674116)
 -- Chow Loong Jin <email address hidden> Sun, 20 Feb 2011 14:48:54 +0800

Changed in banshee (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package banshee - 1.8.1-0ubuntu1

---------------
banshee (1.8.1-0ubuntu1) maverick-proposed; urgency=low

  * [338f8fe] New upstream bugfix release:
    + Sync dialog would sometimes be displayed forever
    + Nereid: Always grab search entry focus on ctrl+f
    + Lastfm: Fix NRE in LastfmRequest when the request times out
    + bgo#486543: Playlists: Fix parsing when started from root directory
      (LP: #674116)
    + bgo#540394: AudioCdRipper: Don't overwrite existing files when
      ripping (LP: #348502)
    + bgo#540525: TrackActions: Stop when the playing track is deleted
      (LP: #366893)
    + bgo#587936: AppleDevice: Sync the Sort+ fields
    + bgo#609463: Equalizer: Fix distortion by using floating math
    + bgo#620010: Fix displaying random image for "All Albums"
    + bgo#623441: DatabaseImportManager: Fix duplicates on import
    + bgo#624734: InternetRadio: Allow editing stations again
    + bgo#629005: FullscreenWindow: Fix full-screen on multi-head displays
    + bgo#630209: AppleDevice: Fix podcast flag for video podcasts
    + bgo#631172: AppleDevice: Fix podcast support
    + bgo#631961: Gio: Fix InvalidCastException
    + bgo#632114: Fix hang when replaying video
    + bgo#632196: AlbumListView: Fix MissingIntPtrCtorException
    + bgo#632246: ThickClient: Fix IntPtr ctor issue in SourceComboBox
      (LP: #669857)
    + bgo#632420: Booter: Use the MeeGo client if appropriate
    + bgo#632715: Bookmarks: Fix UI not getting loaded
    + bgo#633764: Dap: Fix not transcoding some files when we should
    + bgo#633841: StreamTagger: Recognize webm as video (LP: #669682)
    + bgo#634652: AppleDevice: Remove invalid tracks before syncing
    + bgo#634686: Streaming: Fix streaming broken after first play
    + bgo#635453: Importing: Fix regression with importing mkv
    + bgo#635776: build: Ensure karma-sharp's DLLmap is copied in the
      build
    + bgo#635791: Metrics: Fix translation of the preference label
    + bgo#637303: FileChooserDialog: Fix error message on first launch
      (LP: #687402)
    + bgo#637627: FullscreenWindow: Keep fullscreen when showing volume
      osd
    + bgo#637991: SourceRowRenderer: Fix vertical alignment calculation
    + bgo#638477: X11NotificationArea: Enhance check for RGBA visual
      (LP: #689505)
    + bgo#638755: Dap.MassStorage: Add support for Xperia X10 mini pro
    + bgo#638989: Dap.MassStorage: Add support for Nexus S
    + bgo#635088: Dap.MassStorage: Add support for the LG Ally phone
    + bgo#633551: Dap.MassStorage: Add support for Huawei Ideos Android
      phones
    + bgo#631687: Dap.MassStorage: Fix extensionless files
    + bgo#639603: PlayerEngine: Fix NRE when current track doesn't have a
      Uri
    + bnc#642505: Fix insecure LD_LIBRARY_PATH
  * [7fd9862] Drop patch for bgo#623441 (applied upstream)
 -- Chow Loong Jin <email address hidden> Sun, 30 Jan 2011 02:42:20 +0800

Changed in banshee (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.