Banshee Ubuntu One Music Store extension fails to load

Bug #623089 reported by Scott Sweeny on 2010-08-24
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
banshee (Ubuntu)
Low
Unassigned
Maverick
Undecided
Unassigned
libubuntuone (Ubuntu)
Undecided
Rodrigo Moya
Maverick
Undecided
Rodrigo Moya

Bug Description

Binary package hint: banshee

I just upgraded to Maverick and noticed that when I loaded Banshee the U1MS source didn't appear. I went into the preferences and unchecked/re-checked the option and Banshee crashed. I then started Banshee from the command line and have pasted the output below:

ssweeny[~]$ banshee
[Info 21:07:59.914] Running Banshee 1.7.3: [Ubuntu maverick (development branch) (linux-gnu, i686) @ 2010-08-06 16:24:30 UTC]
/home/ssweeny/.themes/Sonar-Dust/gtk-2.0/gtkrc:92: Murrine configuration option "gradients" is no longer supported and will be ignored.
/home/ssweeny/.themes/Sonar-Dust/gtk-2.0/gtkrc:163: Murrine configuration option "gradients" is no longer supported and will be ignored.
/home/ssweeny/.themes/Sonar-Dust/gtk-2.0/gtkrc:198: Murrine configuration option "gradients" is no longer supported and will be ignored.
/home/ssweeny/.themes/Sonar-Dust/gtk-2.0/gtkrc:205: Murrine configuration option "profile" is no longer supported and will be ignored.
/home/ssweeny/.themes/Sonar-Dust/gtk-2.0/gtkrc:558: Murrine configuration option "gradients" is no longer supported and will be ignored.
/home/ssweeny/.themes/Sonar-Dust/gtk-2.0/gtkrc:606: error: invalid string constant "spinbutton", expected valid string constant
[Info 21:08:00.343] Starting collection of anonymous usage data
[Info 21:08:01.305] Updating web proxy from GConf

(Banshee:1943): Gtk-WARNING **: Refusing to add non-unique action 'CloseAction' to action group 'Global'
[Info 21:08:01.492] All services are started 1.266668

** (Banshee:1943): WARNING **: The class UbuntuOne.U1MusicStore could not be loaded, used in ubuntuone-sharp, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756

System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.TypeLoadException: A type load exception has occurred.
  at (wrapper managed-to-native) System.Reflection.MonoCMethod:InternalInvoke (object,object[],System.Exception&)
  at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0
  --- End of inner exception stack trace ---
  at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0
  at System.Reflection.MonoCMethod.Invoke (BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0
  at System.Reflection.ConstructorInfo.Invoke (System.Object[] parameters) [0x00000] in <filename unknown>:0
  at System.Activator.CreateInstance (System.Type type, Boolean nonPublic) [0x00000] in <filename unknown>:0
  at System.Activator.CreateInstance (System.Type type) [0x00000] in <filename unknown>:0
  at Mono.Addins.TypeExtensionNode.CreateInstance () [0x00000] in <filename unknown>:0
  at Banshee.Sources.SourceManager.OnExtensionChanged (System.Object o, Mono.Addins.ExtensionNodeEventArgs args) [0x00000] in <filename unknown>:0
  at Mono.Addins.ExtensionNode.add_ExtensionNodeChanged (Mono.Addins.ExtensionNodeEventHandler value) [0x00000] in <filename unknown>:0
[Info 21:08:02.491] nereid Client Started

Additionally, below is the output when I uncheck/recheck the U1MS option (leading to the crash):
Marshaling toggled signal
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.TypeLoadException: A type load exception has occurred.
  at (wrapper managed-to-native) System.Reflection.MonoCMethod:InternalInvoke (object,object[],System.Exception&)
  at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0
  --- End of inner exception stack trace ---
  at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0
  at System.Reflection.MonoCMethod.Invoke (BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0
  at System.Reflection.ConstructorInfo.Invoke (System.Object[] parameters) [0x00000] in <filename unknown>:0
  at System.Activator.CreateInstance (System.Type type, Boolean nonPublic) [0x00000] in <filename unknown>:0
  at System.Activator.CreateInstance (System.Type type) [0x00000] in <filename unknown>:0
  at Mono.Addins.TypeExtensionNode.CreateInstance () [0x00000] in <filename unknown>:0
  at Banshee.Sources.SourceManager.OnExtensionChanged (System.Object o, Mono.Addins.ExtensionNodeEventArgs args) [0x00000] in <filename unknown>:0
  at Mono.Addins.ExtensionNode.OnChildNodeAdded (Mono.Addins.ExtensionNode node) [0x00000] in <filename unknown>:0
  at Mono.Addins.ExtensionNode.NotifyChildChanged () [0x00000] in <filename unknown>:0
  at Mono.Addins.TreeNode.NotifyChildrenChanged () [0x00000] in <filename unknown>:0
  at Mono.Addins.ExtensionTree.LoadExtensionElement (Mono.Addins.TreeNode tnode, System.String addin, Mono.Addins.Description.ExtensionNodeDescriptionCollection extension, System.Int32& curPos, Mono.Addins.BaseCondition parentCondition, Boolean inComplextCondition, System.Collections.ArrayList addedNodes) [0x00000] in <filename unknown>:0
  at Mono.Addins.ExtensionTree.LoadExtension (System.String addin, Mono.Addins.Description.Extension extension, System.Collections.ArrayList addedNodes) [0x00000] in <filename unknown>:0
  at Mono.Addins.ExtensionContext.LoadModuleExtensionNodes (Mono.Addins.Description.Extension extension, System.String addinId, Mono.Addins.Description.ExtensionNodeSet nset, System.Collections.ArrayList loadedNodes) [0x00000] in <filename unknown>:0
  at Mono.Addins.ExtensionContext.ActivateAddinExtensions (System.String id) [0x00000] in <filename unknown>:0
  at Mono.Addins.AddinSessionService.ActivateAddin (System.String id) [0x00000] in <filename unknown>:0
  at Mono.Addins.Database.AddinDatabase.EnableAddin (System.String domain, System.String id, Boolean exactVersionMatch) [0x00000] in <filename unknown>:0
  at Mono.Addins.Addin.set_Enabled (Boolean value) [0x00000] in <filename unknown>:0
  at Banshee.Addins.Gui.AddinView+<AddinView>c__AnonStorey6.<>m__5 (System.Object o, Gtk.ToggledArgs a) [0x00000] in <filename unknown>:0
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0
  --- End of inner exception stack trace ---
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0
  at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] in <filename unknown>:0
  at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x00000] in <filename unknown>:0
  at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00000] in <filename unknown>:0
  at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000] in <filename unknown>:0
  at GLib.Signal.ClosureInvokedCB (System.Object o, GLib.ClosureInvokedArgs args) [0x00000] in <filename unknown>:0
  at GLib.SignalClosure.Invoke (GLib.ClosureInvokedArgs args) [0x00000] in <filename unknown>:0
  at GLib.SignalClosure.MarshalCallback (IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data) [0x00000] in <filename unknown>:0
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at GLib.SignalClosure.MarshalCallback(IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data)
   at Gtk.Dialog.gtk_dialog_run(IntPtr )
   at Gtk.Dialog.Run()
   at Banshee.Gui.Dialogs.BansheeDialog.Run()
   at Banshee.Gui.GlobalActions.OnPreferences(System.Object o, System.EventArgs args)
   at System.Reflection.MonoMethod.InternalInvoke(System.Object , System.Object[] , System.Exception ByRef )
   at System.Reflection.MonoMethod.Invoke(System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture)
   at System.Reflection.MethodBase.Invoke(System.Object obj, System.Object[] parameters)
   at System.Delegate.DynamicInvokeImpl(System.Object[] args)
   at System.MulticastDelegate.DynamicInvokeImpl(System.Object[] args)
   at System.Delegate.DynamicInvoke(System.Object[] args)
   at GLib.Signal.ClosureInvokedCB(System.Object o, GLib.ClosureInvokedArgs args)
   at GLib.SignalClosure.Invoke(GLib.ClosureInvokedArgs args)
   at GLib.SignalClosure.MarshalCallback(IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Banshee.Gui.GtkBaseClient.Run()
   at Banshee.Gui.GtkBaseClient.Startup()
   at Hyena.Gui.CleanRoomStartup.Startup(Hyena.Gui.StartupInvocationHandler startup)
   at Banshee.Gui.GtkBaseClient.Startup()
   at Banshee.Gui.GtkBaseClient.Startup(System.String[] args)
   at Nereid.Client.Main(System.String[] args)
   at System.AppDomain.ExecuteAssembly(System.Reflection.Assembly , System.String[] )
   at System.AppDomain.ExecuteAssemblyInternal(System.Reflection.Assembly a, System.String[] args)
   at System.AppDomain.ExecuteAssembly(System.String assemblyFile, System.Security.Policy.Evidence assemblySecurity, System.String[] args)
   at System.AppDomain.ExecuteAssembly(System.String assemblyFile)
   at Booter.Booter.BootClient(System.String clientName)
   at Booter.Booter.Main()

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: banshee 1.7.3-2ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-17.23-generic 2.6.35.2
Uname: Linux 2.6.35-17-generic i686
Architecture: i386
Date: Mon Aug 23 21:12:20 2010
ExecutablePath: /usr/lib/banshee-1/Banshee.exe
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
InterpreterPath: /usr/bin/mono
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.utf8
SourcePackage: banshee

Related branches

Scott Sweeny (ssweeny) wrote :
Andrew Mitchell (ajmitch) wrote :

The current libubuntuone bindings for mono are broken in maverick at the moment due to the codegen tools not creating the C# source. I've been trying to track down why it's not generating the source properly but gapi2-codegen is not very helpful in its errors..

Changed in libubuntuone (Ubuntu):
status: New → Confirmed
Changed in libubuntuone (Ubuntu):
assignee: nobody → Rodrigo Moya (rodrigo-moya)
Andrew Mitchell (ajmitch) wrote :

I've found a (very) ugly workaround in the linked branch that gets the bindings working until gtk-sharp2-gapi is fixed properly.

tags: added: u1-maverick
Changed in libubuntuone (Ubuntu Maverick):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libubuntuone - 0.3.5-0ubuntu1

---------------
libubuntuone (0.3.5-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - - Fix generation of Mono bindings (Rodrigo Moya) (LP: #623089)
 -- Rodrigo Moya <email address hidden> Tue, 31 Aug 2010 17:47:52 +0200

Changed in libubuntuone (Ubuntu Maverick):
status: In Progress → Fix Released
Matt Griffin (mattgriffin) wrote :

Rodrigo - Tested with libubuntuone 0.3.5-0ubuntu1 installed and Software Center gives me an error message when I try to install banshee-extension-ubuntuonemusicstore. "Package dependencies cannot be resolved"

Changed in libubuntuone (Ubuntu Maverick):
status: Fix Released → Confirmed
Andrew Mitchell (ajmitch) wrote :

Banshee will still fail to load the right .dll because the dllmap (bindings/mono/ubuntuone-sharp.dll.config.in) needs to be fixed, since the banshee plugin refers to libubuntuone-1.0.dll. There's a branch linked (lp:~laney/libubuntuone/fix-dllmap) that fixes this.

Changed in libubuntuone (Ubuntu Maverick):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libubuntuone - 0.3.6-0ubuntu1

---------------
libubuntuone (0.3.6-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Show an error dialog when we can't authenticate (Rodrigo Moya)
      (LP: #615832)
    - Fix dllmap config for Mono bindings (Iain Lane) (LP: #623089)
 -- Rodrigo Moya <email address hidden> Wed, 08 Sep 2010 11:25:30 +0200

Changed in libubuntuone (Ubuntu Maverick):
status: In Progress → Fix Released
Victor Vargas (kamus) wrote :

I tried to reproduce this issue with 1.9.0.x from PPA repository and works fine for me, Scott please could you check if this behaviour is still affecting you? Thanks

Changed in banshee (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Scott Sweeny (ssweeny) wrote :

This was actually fixed by an update to libubuntuone. I'm sorry I didn't close this at the time.

Changed in banshee (Ubuntu):
status: Incomplete → Invalid
papukaija (papukaija) wrote :

Should the Maverick task be closed too?

Scott Sweeny (ssweeny) on 2010-12-04
Changed in banshee (Ubuntu Maverick):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers