Music purchased from the Ubuntu One Music Store does not appear in music library

Bug #604699 reported by Matt Griffin on 2010-07-12
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Banshee
Fix Released
Medium
libubuntuone
Medium
dobey
banshee (Ubuntu)
Medium
dobey
libubuntuone (Ubuntu)
Medium
dobey

Bug Description

Binary package hint: banshee-community-extensions

Songs are in ~/.ubuntuone on my desktop but it looks like Banshee isn't searching for music in that folder. This may also affect the download status message for each song on the store's My Downloads page and showing that a purchase has completed.

Related branches

summary: - Music purchased from the Ubuntu One Music Store isn't appearing in music
+ Music purchased from the Ubuntu One Music Store does not appear in music
library
Nick Vanadium (nvanadium) wrote :

I am experience this issue as well. My songs won't show up in "My Downloads" section. All I get is "There was a (temporary) problem getting your list of purchased songs. Please wait a short time and then try again, or return to the music store."

Changed in banshee-community-extensions:
status: Unknown → New
Changed in banshee-community-extensions:
importance: Unknown → Medium
papukaija (papukaija) on 2010-11-05
Changed in banshee-community-extensions (Ubuntu):
status: New → Confirmed
dobey (dobey) on 2011-02-28
affects: banshee-community-extensions → banshee
affects: banshee-community-extensions (Ubuntu) → banshee (Ubuntu)
Jono Bacon (jonobacon) wrote :

I am experiencing this too - surely given the importance of delivering Ubuntu One music in Banshee in Natty, this should be set to High or Critical?

This would depend on extending the library watcer which isn't to my knowledge on anyones to do list. However i believe the core of the problem is that the ubuntuone# bindings has a bug which Rhythmbox' U1MS implementation depends on. If we could get this fixed so the interface actually works as advertised. I think Jo Shields (directhex) is the man to ask if I talk complete bull.

Also extending the library watcher in the manner required would be a major change, Banshee would likely have concerns merging it this late in the cycle (Video and DVD already having been pushed to post 2.0).

Victor Vargas (kamus) on 2011-03-25
Changed in banshee (Ubuntu):
importance: Undecided → Medium
Jono Bacon (jonobacon) wrote :

Can anyone provide an update on this bug? I am a bit worried that we are about to hit Beta 1 and such core piece of functionality in Ubuntu One with potentially significant implementation requirements, is not resolved.

Jono, I believe my comments in #3+4 still stand. You should ask Directhex regarding the libubuntuone problem, it seems like your best option at this stage considering that the library watcher change would likely not be accepted at this stage upstream and nobody has stepped up to write it.

dobey (dobey) on 2011-03-31
Changed in banshee (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
Jono Bacon (jonobacon) wrote :

Strange - when I go to the My Downloads link in the Ubuntu One Music Store it pops up bubbles saying it is transferring a few files, and hung Banshee (I filed this at https://bugs.launchpad.net/ubuntu/+source/banshee/+bug/746592), After this process it seems part of my Ubuntu One music was imported into Banshee (I assume part was imported because it hung and I killed it before it could complete.

dobey (dobey) wrote :

It wasn't actually hung, but rather the GUI was just blocking. If you let it sit, I am almost certain all your music will show up.

dobey (dobey) on 2011-04-06
Changed in libubuntuone:
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → Medium
status: New → In Progress
dobey (dobey) on 2011-04-06
Changed in libubuntuone (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → Medium
status: New → In Progress
dobey (dobey) on 2011-04-07
Changed in libubuntuone:
status: In Progress → Fix Committed
dobey (dobey) on 2011-04-07
Changed in libubuntuone:
status: Fix Committed → Fix Released
Changed in banshee:
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libubuntuone - 0.9.2-0ubuntu1

---------------
libubuntuone (0.9.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Distribution series hardcoded for codec installation (LP: #693536)
    - [UIFE] Notify user of missing MP3 suupport (LP: #733327)
    - Music purchased from U1MS not appear in music library (LP: #604699)
 -- Rodney Dawes <email address hidden> Thu, 07 Apr 2011 11:33:11 -0400

Changed in libubuntuone (Ubuntu):
status: In Progress → Fix Released
James Schriver (dashua) wrote :

@jono, I noticed the same thing here. I just did a clean install from a daily build and the "Purchased Music" from the u1 control panel was unchecked. I figured this would be default, but once activated the purchased u1ms music began syncing.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package banshee - 2.0.0-1ubuntu2

---------------
banshee (2.0.0-1ubuntu2) natty; urgency=low

  * 90_amazon_url.patch:
    - Change the url for the Amazon store redirector (LP: #745194)
  * 91_u1ms-initialize-earlier.patch:
    - Create the U1MusicStore widget earlier (LP: #604699)
    - Require libubuntuone >= 0.9.2
 -- Rodney Dawes <email address hidden> Fri, 08 Apr 2011 23:37:37 -0400

Changed in banshee (Ubuntu):
status: Confirmed → Fix Released
Changed in banshee:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.