Samsung F480 wont run as mtp device

Bug #569446 reported by EricDHH on 2010-04-24
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
banshee (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: banshee

Description: Ubuntu 10.04 LTS
Release: 10.04

Like my nokia 6310 the samsung f480 can act as mtp device and should work with the banshee mtp plugin. When plugged and touched to be mtp, this happens.

[Info 16:59:03.458] Running Banshee 1.6.0: [Ubuntu lucid (development branch) (linux-gnu, x86_64) @ 2010-04-04 14:20:11 UTC]

(Banshee:17241): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.
[Info 16:59:04.311] All services are started 0,691295s
[Info 16:59:05.704] nereid Client Started
Device 0 (VID=04e8 and PID=5a0f) is a Samsung YH-999 Portable Media Center/SGH-A707/SGH-L760V/SGH-U900/Verizon Intensity.
PTP_ERROR_IO: Trying again after re-initializing USB interface
LIBMTP PANIC: Could not open session! (Return code 767)
  Try to reset the device.
[Warn 16:59:42.456] Caught an exception - Mtp.LibMtpException: Connecting (in `Mtp')
  at Mtp.Error.CheckError (ErrorCode errorCode) [0x00000]
  at Mtp.MtpDevice.GetConnectedDevices (System.IntPtr& list) [0x00000]
  at Mtp.MtpDevice.Detect () [0x00000]
  at Banshee.Dap.Mtp.MtpSource.DeviceInitialize (IDevice device) [0x00000]

Thats the end, the handy waits for something from banshee and there is no device visible.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: banshee 1.6.0-1
ProcVersionSignature: Ubuntu 2.6.32-21.32-genusername 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CheckboxSubmission: 72ffaca291c05635776d4a13f9e644e4
CheckboxSystem: 32980ee028b29311fef8e195a759b031
Date: Sat Apr 24 17:00:16 2010
ProcEnviron:
 LANGUAGE=de_DE:de:en_GB:en
 PATH=(custom, no user)
 LANG=de_DE.utf8
 SHELL=/bin/bash
SourcePackage: banshee

EricDHH (ericdhh) wrote :
EricDHH (ericdhh) wrote :

Found a workaround. Placing a .is_audio_player file in the root of samsungs sd card, ubuntu recognise the handy in mass-storage mode as usb player device, banshee accepts this too.
Status now: Handy in MTP wont play from banshee and banshee did not play from the handy. Data exchange isnt possible in MTP mode.
In Mass-storage mode with .is_audio_player the musicfiles can easy exchanged between player and banshee. The wrong recognition without the file workaround seems to be in udev.

Pedro Villavicencio (pedro) wrote :

does that works fine on rhythmbox if you remove the ,is_audio_player key?

Changed in banshee (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Victor Vargas (kamus) wrote :

EricW, any news about this issue? Have you tried to reproduce this issue with Banshee 1.8.0 release?

EricDHH (ericdhh) wrote :

For the usb subsystem and banshee my f480 / intenso musicwalker are only usb sticks now, Both get only the usb stick symbol an no more playersymbol on the desktop. The players did not recognize them as player devices, if there is no .is_audio_player file defined. The intenso works up to ubuntu 10.04 as mtp device and player, now it needs a .is_audio_player too.
This bug seems to be in the udev replace, it did not recognize the right device type.

Launchpad Janitor (janitor) wrote :

[Expired for banshee (Ubuntu) because there has been no activity for 60 days.]

Changed in banshee (Ubuntu):
status: Incomplete → Expired
Luis Silva (lacsilva) wrote :

Same here with the Samsung M1.
The output of mtp-detect is:

> mtp-detect
libmtp version: 1.0.4

Listing raw device(s)
Device 0 (VID=04e8 and PID=5a0f) is a Samsung YH-999 Portable Media Center/SGH-A707/SGH-L760V/SGH-U900/Verizon Intensity.
   Found 1 device(s):
   Samsung: YH-999 Portable Media Center/SGH-A707/SGH-L760V/SGH-U900/Verizon Intensity (04e8:5a0f) @ bus 2, dev 11
Attempting to connect device(s)
ignoring usb_claim_interface = -110PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
inep: usb_get_endpoint_status(): Connection timed out
outep: usb_get_endpoint_status(): Protocol error
usb_clear_halt() on IN endpoint: Protocol error
usb_clear_halt() on OUT endpoint: Protocol error
usb_clear_halt() on INTERRUPT endpoint: Protocol error
LIBMTP libusb: Attempt to reset device
ignoring usb_claim_interface = -71LIBMTP PANIC: failed to open session on second attempt
Unable to open raw device 0
OK.

Changed in banshee (Ubuntu):
status: Expired → New
Victor Vargas (kamus) wrote :

Luis, which version of banshee are you running?

Victor Vargas (kamus) wrote :

Please also add this as a separated file, please run in a terminal:

* udevadm info --export-db
* gvfs-mount --list

Victor Vargas (kamus) wrote :

EricDHH, please could you attach the required information in comment #9? Thanks.

Changed in banshee (Ubuntu):
status: New → Incomplete
EricDHH (ericdhh) wrote :

Sorry have sold the device and cannot make more tests.

Victor Vargas (kamus) wrote :

EricDHH no problem, please if someone is facing this behaviour with latest release of banshee feel free to fill new a report about it, closed for now.

Changed in banshee (Ubuntu):
status: Incomplete → Invalid
Changed in banshee (Ubuntu):
assignee: nobody → Sergio Ibarra (zergioibarra)
assignee: Sergio Ibarra (zergioibarra) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers