Shuffling through a series of music tracks creates loads of irrelivent notifications

Bug #568718 reported by Connel Hooley on 2010-04-22
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
banshee (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: notify-osd

Not sure if this is a Banshee / Rhythmbox problem so move/delete if this is in the wrong place (first time I've made a bug report :p)

If I use Banshee's indicator applet to shuffle through say ten songs before finding a song I want to listen to I get a series of notifications regarding songs I have already skipped and are therefore are irrelevant / incorrect. I know that one of the features of Notify-OSD is to queue all the notifications and show them one at a time, but I believe an exception should be made for when shuffling music tracks and other similar tasks.

Mirco Müller (macslow) wrote :

This is clearly a banshee bug (in regards to notify-osd for sure). Check rhythmbox, which does correctly update an already existing notification-bubble and thus avoiding queuing up outdated notifications, when quickly skipping tracks. notify-osd provides code-examples in C, C# and Python (but stick to the C-examples, as they are most up-to-date) demonstrating how to properly update an already existing bubble.

Changed in notify-osd (Ubuntu):
status: New → Invalid
affects: notify-osd (Ubuntu) → banshee (Ubuntu)
Connel Hooley (connelhooley) wrote :

ah ok my bad sorry!

Changed in banshee (Ubuntu):
status: Invalid → New
Changed in banshee (Ubuntu):
status: New → Confirmed
Victor Vargas (kamus) wrote :

Since original reporter has gone and we have not heard any news about this issue I will close this report for now but if somebody can confirm that is still occurring with latest release of banshee included in Maverick please reopened again. Thanks

Changed in banshee (Ubuntu):
importance: Undecided → Low
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers