banshee 100% cpu after 20 rss feeds loaded and then reboot pc + restart banshee

Bug #488799 reported by sdowney717 on 2009-11-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
banshee (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: banshee

i have 100% utilization cpu bug. I loaded up 20 podcast web sites into banshee.
used them everything was working fine. videos play, navigate menus ok
I then exited/rebooted and when banshee starts, slam cpu 100%, turns grey, totally useless and have to kill the process.
you can try it yourself, import these feeds watch a few videos, reboot then see what happens

PBS FRONTLINE/World
http://feeds.pbs.org/pbs/frontlineworld/

PBS Nova WGBH
http://feeds.pbs.org/pbs/wgbh/nova-video/

ABC News Extreme Video
http://feeds.abcnews.com/abcnews/extremevideo/

ABC News Top Videos
http://feeds.abcnews.com/abcnews/topvideos/

recent posts - blip.tv (beta)
http://blip.tv/rss/?s=feed

CBC radio tv itunes
http://www.cbcradio3.com/podcast/video/iTunes/

CBS Evening News

http://feeds.cbsnews.com/podcast_eveningnews_video_1/?tag=contentMain%3bcontentBody/

CNET Loaded

http://feeds2.feedburner.com/cnet/loaded/?tag=contentMain%3bcontentBody/

CNN Amanpour

http://rss.cnn.com/services/podcasting/amanpour_video/rss/?format=xml

CNN Daily News Room

rss.cnn.com/services/podcasting/cnnnewsroom/rss.xml/

CNN Daily News Cast

http://rss.cnn.com/services/podcasting/newscast/rss.xml/

CNN Student News

http://rss.cnn.com/services/podcasting/studentnews/rss.xml/

FOX News Flash
http://feeds.foxnews.com/podcasts/FoxNewsFlash/

Cranky Geeks ZiffDavis
http://feeds2.feedburner.com/ziffdavis/cgh264video/

Democracy Now!
http://www.democracynow.org/podcast-video.xml/

Discovery Channel

http://www.discovery.com/radio/xml/discovery_video.xml/

Disney Shorty McShorts

http://a.media.global.go.com/abccable/disneychannel/podcasts/shortymcshorts/rss-podcast.xml/

LifeScape TV
http://feeds.feedburner.com/lifescapetv/

NASA JPL

http://www.jpl.nasa.gov/multimedia/rss/podfeed-hd.xml/

Rocket Boom
http://www.rocketboom.com/rss/hd.xml/

Revision3 Scam School

http://revision3.com/scamschool/feed/quicktime-high-definition/

Science Friday
http://www.sciencefriday.com/video/scifrivideo.xml/

Discovery News
http://www.discovery.com/radio/xml/news_video.xml/

VisionOn TV Global Views
http://feeds.visionontv.net/GlobalViews/

VisionOn TV Plug and Play
http://feeds.visionontv.net/plugandplay/

VisionOn TV Beyond TV Festival

http://feeds.visionontv.net/Beyondtvfestival/?format=xml/

VisionOn TV GrassRoots

http://feeds.visionontv.net/undercurrents/grassroots/?format=xml/

VisionOn TV Corporate Watch

http://feeds.visionontv.net/Corporatewatch/?format=xml/

VisionOn TV Friendly Fire

http://feeds.visionontv.net/FrendlyFire/?format=xml/

VisionOn TV Police Watch

http://feeds.visionontv.net/policewatchHD/?format=xml/

VisionOn TV Climate Camp

http://feeds.visionontv.net/climatecamp/?format=xml/

VisionOn TV Living in the Future

http://feeds.visionontv.net/Livinginthefuture/?format=xml/

VisionOn TV Bik OZ
http://feeds.visionontv.net/Bike2Oz/?format=xml/

VisionOn TV Balkan Babylon Rebels
http://feeds.visionontv.net/BalkanBabylonRebels/

VisionOn TV Schmovies
http://feeds.visionontv.net/Schmovies/?format=xml/

VisionOn TV Bush Craft

http://feeds.visionontv.net/A-zOfBushcraft/?format=xml/

ProblemType: Bug
Architecture: i386
Date: Thu Nov 26 10:07:25 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: banshee 1.5.1-1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic
SourcePackage: banshee
Uname: Linux 2.6.31-15-generic i686

sdowney717 (sdowney717) wrote :
sdowney717 (sdowney717) wrote :

I was able to reproduce this 3 times in a row.. uninstal, reinstall, redo all the feeds, etc...

 banshee also gave me SIGSEGV error
any ideas. the program was running great. I went away for an hour, then its acting horribly. turns grey, plays videos in a separate window. crashing, running super slow. my pc is core 2 duo 3,5 ghz

Quote:
#93 0x00436ba2 in ?? ()
#94 0x00436b53 in ?? ()
#95 0x004360b2 in ?? ()
#96 0x00e1c3f9 in ?? ()
#97 0x00e1c1fa in ?? ()
#98 0x081112ae in mono_runtime_exec_main ()
#99 0x081134da in mono_runtime_run_main ()
#100 0x080b19bd in mono_main ()
#101 0x0805aba5 in ?? ()
#102 0x001b0b56 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#103 0x0805aae1 in ?? ()

================================================== ===============
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
================================================== ===============

Aborted

sdowney717 (sdowney717) wrote :
Download full text (3.6 KiB)

also if i delete home/scott/.config/banshee-1 and let it recreate the database on startup, cpu utilization is normal.

add in the frontline rss feed and tried to watch an episode while it was beginning the automatic download of the latest item it crashed

scott@scott-desktop:~/intltool-0.40.6$ banshee
[Info 11:04:19.482] Running Banshee 1.5.1: [Ubuntu karmic (development branch) (linux-gnu, i486) @ 2009-10-19 14:46:07 UTC]
[Info 11:04:21.042] All services are started 0.836755s
[Warn 11:04:22.159] Migrating Internet Radio Stations - Directory '/home/scott/.config/banshee/plugins/stations/user' not found. (in `mscorlib')
  at System.IO.Directory.GetFileSystemEntries (System.String path, System.String searchPattern, FileAttributes mask, FileAttributes attrs) [0x00000]
  at System.IO.Directory.GetFiles (System.String path, System.String searchPattern) [0x00000]
  at Banshee.InternetRadio.XspfMigrator.Migrate () [0x00000]
[Info 11:04:22.367] nereid Client Started
[Warn 11:04:22.614] Caught an exception - org.freedesktop.Hal.NoSuchProperty: No property volume.is_mounted on device with id /org/freedesktop/Hal/devices/platform_floppy_0_storage_platform_floppy (in `NDesk.DBus.Proxies')
  at Hal.IDeviceProxy.GetPropertyBoolean (System.String ) [0x00000]
  at Hal.Device.GetPropertyBoolean (System.String key) [0x00000]
  at Banshee.HalBackend.Volume.get_IsMounted () [0x00000]
  at Banshee.HalBackend.Volume.CheckVolumeMounted (Banshee.HalBackend.Volume volume) [0x00000]
  at Banshee.HalBackend.Volume.Resolve (Banshee.HalBackend.BlockDevice parent, Hal.Manager manager, Hal.Device device) [0x00000]
[Warn 11:04:22.729] Caught an exception - org.freedesktop.Hal.NoSuchProperty: No property volume.is_mounted on device with id /org/freedesktop/Hal/devices/platform_floppy_0_storage_platform_floppy (in `NDesk.DBus.Proxies')
  at Hal.IDeviceProxy.GetPropertyBoolean (System.String ) [0x00000]
  at Hal.Device.GetPropertyBoolean (System.String key) [0x00000]
  at Banshee.HalBackend.Volume.get_IsMounted () [0x00000]
  at Banshee.HalBackend.Volume.CheckVolumeMounted (Banshee.HalBackend.Volume volume) [0x00000]
  at Banshee.HalBackend.Volume.Resolve (Banshee.HalBackend.BlockDevice parent, Hal.Manager manager, Hal.Device device) [0x00000]
[Warn 11:04:22.823] Caught an exception - org.freedesktop.Hal.NoSuchProperty: No property volume.is_mounted on device with id /org/freedesktop/Hal/devices/platform_floppy_0_storage_platform_floppy (in `NDesk.DBus.Proxies')
  at Hal.IDeviceProxy.GetPropertyBoolean (System.String ) [0x00000]
  at Hal.Device.GetPropertyBoolean (System.String key) [0x00000]
  at Banshee.HalBackend.Volume.get_IsMounted () [0x00000]
  at Banshee.HalBackend.Volume.CheckVolumeMounted (Banshee.HalBackend.Volume volume) [0x00000]
  at Banshee.HalBackend.Volume.Resolve (Banshee.HalBackend.BlockDevice parent, Hal.Manager manager, Hal.Device device) [0x00000]
[Warn 11:04:22.922] Caught an exception - org.freedesktop.Hal.NoSuchProperty: No property volume.is_mounted on device with id /org/freedesktop/Hal/devices/platform_floppy_0_storage_platform_floppy (in `NDesk.DBus.Proxies')
  at Hal.IDeviceProxy.GetPropertyBoolean (System.String ) [0x00...

Read more...

Vish (vish) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in banshee (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Victor Vargas (kamus) wrote :

sdowney717, any news about this issue? Have you tried to reproduce this issue with Banshee 1.8.0 release?

Victor Vargas (kamus) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in banshee (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers