Banshee (sometimes) freezes on start playing

Bug #448533 reported by vinlos on 2009-10-11
122
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Banshee
Fix Released
High
banshee (Ubuntu)
Medium
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: banshee

When I try to listen the first song, sometimes Banshee freezes. I can hear the song till the end, but I can't interact with Banshee window. So I have to kill Banshee and reboot it, and the second time I start it, it usually work normally.

This bug affected me also in 9.04 even if I reported it only now in 9.10 Beta.
All the packages have been updated.

ProblemType: Bug
Architecture: amd64
Date: Sun Oct 11 10:19:10 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: banshee 1.5.1~git2260a87-0ubuntu1
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.43-generic
SourcePackage: banshee
Uname: Linux 2.6.31-13-generic x86_64

TEST CASE:
1. Start Banshee
2. The moment it launches, immediately start playing a song with the player window open.
3. Verify that you can still interact with Banshee's player window.

vinlos (vincenzo-losito) wrote :

Thanks for reporting this bug. I've noticed this behaviour from time to time,
though I can't reproduce it reliably. Have you managed to find a way to?

  affects ubuntu/banshee
  status confirmed
--
Kind regards,
Chow Loong Jin (GPG: 0x8F02A411)
Ubuntu Contributing Developer

Changed in banshee (Ubuntu):
status: New → Confirmed
Hamish Downer (mishd) wrote :

Could you check if the cpu usage is very high when this happens?

One easy way to do this is to use the System Monitor. This is under the System menu (System -> Administration -> System Monitor). The processes tab will show how much CPU each application is using. If you start this before banshee and see if banshee is using all the CPU then I think this is a duplicate of bug #396268.

Rob van der Linde (robvdl) wrote :

I think it has to do with the size of your library. I have a large media library of 6000+ and Banshee 1.5 freezes really bad when you start playing, add items to the play list, and other such actions introduces the freezing. The music will keep playing, but the GUI freezes, it is actually really really annoying. This bug was introduced in Banshee 1.5

Tom Wright (twright-tdw) wrote :

Same here: Large library (30gb, 4500+ songs), Eeepc 1000h and frequent freezes

Eric Julien (eric-julien) wrote :

For me, it happens most of the time when I first time I start banshee-1 after a reboot. Once I kill and restart it, it works fine. I also have a large library (+10K songs). CPU usage is 0% on a Core i7 920 once it froze.

Eric Julien (eric-julien) wrote :

I have attached debug output with full thread dump from banshee (using banshee --debug and killing with SIGQUIT)

Screatch (screatch) wrote :

Same problem here.. sometime during start, banshee freezes and i have to force kill it. Once restarted, works fine.

Jaypeagi (jaypeagi) wrote :

I have a similar problem, though my library is only around 3500.
Banshee window freezes for short periods of time (window unresponsive then greys out).
Music continues to play.
Freezing seems to occur as one (of two) CPUs approaches 100% usage, then drops closer to zero once frozen.

This is also on a 64bit install though of 10.04.

Pedro Villavicencio (pedro) wrote :

Thanks for the report, could somebody please try with Maverick version of Banshee and comment back? If you manage to reproduce the bug could you also get a banshee debug log? thanks in advance!.

Changed in banshee (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete

I use maverick and the bug is still here. I can't reproduce it, but next time it happens i'll send the debug log. Also, sometimes instead of freezing it crashes. My library is not that big (+1000 tracks)

T Kortehisto (kortehisto) wrote :

I use 10.10 beta (64bit) and I run into this bug every time I try to play a song on Banshee. It makes the program unusable for me. I will add the banshee debug log for this. Just tell me if you want/need more than one log.

Other symptoms are CPU usage which climbs up to 120-175% after starting Banshee (60-120% even when program is sleeping) and ever increasing RAM usage by Banshee until no more RAM is available (I have 6GB).

T Kortehisto (kortehisto) wrote :

Memory and CPU usage problems were solved by removing all attached external hard drives before starting Banshee, but program still hangs after playing the first song. For the first 10-20 seconds or so after starting playback the program remains responsive (sometimes), but after, say a minute, the window always grays out.

When the program hangs CPU usage is not particularly high on either processor and my collection isn't that big, so I don't think that's the problem. However, I have to say that when playing songs from a short playlist (10-20 tracks) the window seems to stay responsive longer (10-20 seconds) than when playing music from the entire collection.

T Kortehisto (kortehisto) wrote :

Here's a crash report from Maverick made by bug-buddy.

T Kortehisto (kortehisto) wrote :

And also the corresponding log file from Banshee

T Kortehisto (kortehisto) wrote :

Another nice hang/crash. Here are the reports from bug-buggy

T Kortehisto (kortehisto) wrote :

And Banshee's own log

T Kortehisto (kortehisto) wrote :

Here's a more detailed Banshee log of the hang attained with 'banshee-1 --debug --redirect-log' and after the hang 'kill -s QUIT $(pidof banshee-1); cp ~/.config/banshee-1/log ~/Desktop/banshee.log'.

Jeff (jdorenbush) wrote :

Here is "banshee --debug" + "Full thread dump".

Jeff (jdorenbush) wrote :

And here is the log file Banshee created inside of my .config/banshee-1/ directory.

T Kortehisto (kortehisto) wrote :

After the latest Ubuntu updates for 10.10 beta today Banshee no longer (always) freezes after the first song, but instead it hangs after few tracks. Since the updates Banshee has frozen 3 times after 3-5 tracks and once the window has grayed out a few seconds after the playback for the first song began. I haven't been able to listen to music for half an hour without it freezing on Maverick.

T Kortehisto (kortehisto) wrote :

Another hang after playback for the first song started. Attaching bug-buddy's report

T Kortehisto (kortehisto) wrote :

And here's the log attained with 'banshee-1 --debug' in my .config/banshee-1 folder.

Vasilis Mavroudis (vmavroudis) wrote :

Same here...

Frequently, the GUI hangs on start playing but the song-playing does not stop.
After forced reboot works fine.

I got a huge library (200gb) and ubuntu karmic with banshee version 1.6

i thinks it has to do with the database-program interaction.

T Kortehisto (kortehisto) wrote :

This is still a problem with Banshee 1.7.6. Banshee's GUI hangs after playback for the first track begins, but song is played to the end.

i also observe freezes more often since about 2 weeks - can't listen to more than about 2-3 songs before banshee. current song also finishes playing.
what i curiously have observed is that "kill -s QUIT $(pidof banshee-1)" unfreezes banshee again! can others confirm this?
it's quite annoying, to the point where i'm forced to look for alternatives. lately i can only listen to internet radio streams, they don't care if the banshee GUI is frozen. :D :-(

Changed in banshee (Ubuntu):
status: Incomplete → Fix Committed
Changed in banshee:
importance: Unknown → High
status: Unknown → Fix Released
Dylan McCall (dylanmccall) wrote :

I'm able to reproduce this consistently. If I play a track, (whether I skip to the next or let that one finish), Banshee crashes a few seconds into playing the _next_ track. In my case, that is almost always 2 seconds.

Bug #637347 mentions running “banshee --disable-dbus”. That seems to be working for me. Can anyone else reproduce that? I would like to know if these various bug reports can be consolidated, and if my own issue is the same.

I checked, and it doesn't seem to be the sound indicator extension causing this.

nebcanuck (nebcanuck) wrote :

This behaviour is definitely not a result of the sound indicator extension, because I didn't even have it installed when I first moved over to Maverick, and I have been experiencing this issue since.

I also don't know that the behaviour of my banshee is really a duplicate of the original poster, or the behaviour mentioned throughout this bug report, because I am unable to play any song. When I start banshee, the entire interface is unresponsive, and then compiz turns it dark to due unresponsiveness. Running banshee without dbus successfully solves the problem. There is no opportunity to play one or two songs, and it does not work if I start it a second time during a session. Banshee simply does not work for me unless I run --disable-dbus.

I think this bug and #637347 are in fact _not_ dupes, but different bugs, and you seem to be bitten by the other one. Chow Loong Jin, can you comment on that, as you duped #637347?

Phil Krämer (man0riax) wrote :

I agree with Christoph Buchner at this point. Those seem to be two different bugs.

On Thursday 30,September,2010 03:06 PM, Phil wrote:
> I agree with Christoph Buchner at this point. Those seem to be two
> different bugs.
>

I think this bug has really been hijacked, and is really too confusing to be of
use any further at this point. If the people affected by the original bug are
still being affected by it with 1.8.0 (entering PPAs soon, and
maverick-updates), then please file a new bug, and provide backtraces from
"banshee --debug" and "killall -SIGQUIT banshee-1" during the hang.

Thanks and sorry for the inconvenience.

--
Kind regards,
Chow Loong Jin

M.T.D.P.A. (confoxer) wrote :

I found out that if the lyrics plugin is installed and active banshee freezes. I tested this by disabling all the plugins then enabling them one at a time (on their own) and trying to play a song. Banshee consistantally froze when the lyrics plugin was enabled.

M.T.D.P.A. (confoxer) wrote :

nevermind it seems that it was the application indicator, I didn't notice i left it on.

M.T.D.P.A. (confoxer) wrote :

Ok NOW it is happening randomly!

Changed in banshee (Ubuntu):
status: Fix Committed → Fix Released
Changed in banshee (Ubuntu Maverick):
status: New → Fix Committed
description: updated

Accepted banshee into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
T Kortehisto (kortehisto) wrote :

The new banshee 1.8.0 in the maverick-proposed solved my problem of banshee hanging after the first song plays. After upgrading to 1.8.0 from 1.7.6 banshee hasn't hanged once.

Martin Pitt (pitti) on 2010-11-01
tags: added: verification-done
removed: verification-needed
T Kortehisto (kortehisto) wrote :

Also the oga files which I had problems before are playing nicely on 1.8.0. So that's fixed too (Bug #646121).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package banshee - 1.8.0-2ubuntu1~maverick1

---------------
banshee (1.8.0-2ubuntu1~maverick1) maverick-proposed; urgency=low

  * Upload to Maverick

banshee (1.8.0-2ubuntu1) natty; urgency=low

  * Merge from Debian experimental, remaining changes:
    + debian/banshee-meego.install: Install netbook banshee.desktop to UNE
      location
    + Disable boo support
    + Recommend soundmenu extension

banshee (1.8.0-2) experimental; urgency=low

  * Fix duplicates on import (BGO #623441)

banshee (1.8.0-1) experimental; urgency=low

  * New upstream release
    + Adds playlist support to libgpod backend
    + Fixes hanging issue during beginning of playback (LP: #448533)
    + Fixes an issue where mass storage devices were not detected (LP: #646482)
    + Fixes an issue where iPods are not updated with the gpod backend
      (LP: #640090)
  * Bump libgpod-cil-dev dependency to 0.7.95
  * Import Ubuntu's upstreamable patches
  * Run intltool and mangle desktop file for Ubuntu
    upstream"
 -- Chow Loong Jin <email address hidden> Fri, 22 Oct 2010 17:45:59 +0800

Changed in banshee (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.