cannot play any video files

Bug #437479 reported by linusr on 2009-09-27
58
This bug affects 11 people
Affects Status Importance Assigned to Milestone
banshee (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: banshee

Cannot play any video files in banshee. Can play mp3 files without any issue.

Ubuntu 9.10

ProblemType: Bug
Architecture: i386
Date: Sat Sep 26 23:30:20 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: banshee 1.4.3-6
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
SourcePackage: banshee
Uname: Linux 2.6.31-11-generic i686

linusr (linusr) wrote :
linusr (linusr) wrote :

This is the error message I get,
[Info 23:34:58.137] Running Banshee 1.4.3: [Ubuntu karmic (development branch) (linux-gnu, i486) @ 2009-08-11 08:00:02 UTC]
0:00:00.237518747 16706 0x8c95d40 ERROR GST_PIPELINE ./grammar.y:604:_gst_parse_yyparse: no element "xingenc"
0:00:00.290172996 16706 0x8c95d40 ERROR GST_PIPELINE ./grammar.y:604:_gst_parse_yyparse: no element "fluwmaenc"
0:00:00.290276222 16706 0x8c95d40 ERROR GST_PIPELINE ./grammar.y:604:_gst_parse_yyparse: no element "fluasfmux"
[Info 23:35:00.254] All services are started 1.938986s
[Info 23:35:01.125] nereid Client Started
0:00:08.310270449 16706 0xb271acd8 ERROR ffmpeg :0:: looks like this file was encoded with (divx4/(old)xvid/opendivx) -> forcing low_delay flag
Banshee: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.

Dominik Boehi (dboehi) wrote :

I can confirm this bug.

I also noticed that sometimes the video plays without problems, but usually it crashes.

Changed in banshee (Ubuntu):
status: New → Confirmed
Michael.S.G (ozfalcon) wrote :

I can also confirm this bug.

Using xubuntu 9.10.
[Info 17:54:51.016] Running Banshee 1.5.1: [Ubuntu karmic (development branch)

I found that deleting ~/.gstreamer-0.10/registry.i486.bin
got it working again...... But I suspect this is only a temp fix.

I might just delete that file on every login..... Not sure what it does. But it gets re-created.

Michael.S.G (ozfalcon) wrote :

Well deleting ~/.gstreamer-0.10/registry.i486.bin do NOT fix it.

Problem has returned, And again can not play any videos in banshee.
(at all)

Michael.S.G (ozfalcon) wrote :

Small update to the situation.

I am also having xine crash when switching between fullscreen and window modes.
For me, 9.10 (xubuntu and ubuntu same) there is something wrong with the video system.

After four days trying to get 9.10 to work. I have given up and moved back to 9.04.
(9.04 (xubuntu and ubuntu) work flawlessly on this machine - Setup as a Jukebox)
(Also Grub2 was a disaster on this machine. And required non trivial fixes or workarounds)

Notes:
Machine is old 933mhz with 640mb ram. Hence the use of xubuntu.
It is running GeForce2 video with 32mb of ram. (Uses the legacy 96 NVidia drivers)

Other notes: (On the 9.10 system)
I tried Compiling Banshee from source. Still same problem. (Infact same version)
I tried Compiling GStreamer-Ugly. As there was a newer revision. Still same problem.
I tried Compiling GStreamer-Bad. But gave up at that point and went back to 9.04.

Other comments:
9.10 DOES boot faster. And the xfce desktop loads quicker (Even seems a bit snappier).
But as mentioned - Currently has issues - Big enough to warrant NOT upgrading (yet).

futwick (futwick) wrote :

Crashes for me playing any video when Compiz is running. Turning off desktop effects stops Banshee crashing.

Banshee 1.5.1 / Ubuntu 9.10

Alex (alex112283) wrote :

I can confirm that Banshee plays video fine without compiz running.

Banshee 1.5.2 / Ubuntu 9.10 x86_64

Michael.S.G (ozfalcon) wrote :

I can confirm Banshee crashes playing video WITHOUT compiz installed at all.

XUbuntu 9.10 i386

Michael.S.G (ozfalcon) wrote :

Update to this bug as of 19/12/2009. After a few system updates (gstreamer, kernel and some others) and also an update of Banshee (1.5.4~really1.5.2-0ubuntu1~hyper1~karmic).

Going on a post re: "Select Now playing".

As of this update, the ability to show the cover art in the side pane has disappeared (Can we have it back!)
Also the allow internet access option seems to disappear after changing config options in these latest releases.

100% reproduce on PC running Ubuntu 9.10.
Next post will be results for XUbuntu 9.10.

Make Fail #1
----------------
1) Start Banshee
2) Go to videos
3) Select video and press play button
4) Move mouse

Make Fail #2
----------------
1) Start Banshee
2) Go to videos
3) Select video
4) Go to Now Playing
5) Press play button
4) Move mouse

Success
-----------
1) Start Banshee
2) Go to Now Playing
3) Go to videos
4) Select video and press play button

Synopsis:
You seem to have to Visit (ie. select it then select something else) "Now Playing" at least once before playing any video. After Visiting "Now Playing" you can play anything willy nilly :-) Perhaps some sort of init problem...?

futwick (futwick) wrote :

I've tried Michael.S.G.'s suggestion and can confirm that clicking on Now Playing *before* playing a video stops Banshee from crashing.

Banshee 1.6 Beta 3 (1.5.2) / Ubuntu 9.10 (32-bit with Compiz enabled)

Michael.S.G (ozfalcon) wrote :

The previous Ubuntu 9.10 test has an nVidia 5200 video card. (Different PC)

With a fresh install of XUbuntu 9.10 on PC with old onboard Intel video chipset.
Video still crashed. Unable to workaround.
Extra note: Though banshee crashed playing video, Totem played fine.

I installed an old 32mb tnt2 video card. (Not even supported by the legacy drivers!)

And video playback worked. (Using the the "Now Playing" workaround fix)

Michael.S.G (ozfalcon) wrote :

Update to last post:

The Intel integrated graphics controller 82865G (Rev 02) Fails to play video in Banshee.
(As mentioned an old tnt2 card plugged in works ok on the same machine)

Victor Vargas (kamus) wrote :

@linuxr, please could you check if this issue is still affecting you in latest release of banshee (1.6.1.1) included in Ubuntu Lucid? Thanks.

Changed in banshee (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Victor Vargas (kamus) wrote :

linuxr, any news about this issue?

Launchpad Janitor (janitor) wrote :

[Expired for banshee (Ubuntu) because there has been no activity for 60 days.]

Changed in banshee (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers