Banshee refuses to play internet radio stream

Bug #423481 reported by Edward Lee on 2009-09-03
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Banshee
Fix Released
Medium
banshee (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: banshee

Banshee refuses to play a internet radio stream, popping up a dialog box that says "Error opening stream - could not open stream or playlist", and throws this exception in the debug log.

[Warn 21:27:11.308] - (on ) <00:00:00> [<unknown>] - An application exception has occurred. (in `Banshee.Services')
  at Banshee.Playlists.Formats.PlaylistParser.Parse (Banshee.Base.SafeUri uri) [0x00000]
  at Banshee.Streaming.RadioTrackInfo.LoadStreamUri (System.String uri) [0x00000]

Edward Lee (tigerfishdaisy) wrote :

Further investigation indicates that it faults here

[PlaylistParser.cs] (function Parse( ))

                        // If more than 4KB of data exists on an HTTP playlist,
                        // it's probably not a playlist. This kind of sucks,
                        // but it should work until someone can prove otherwise

                        read = web_stream.Read (buffer, 0, buffer.Length);
                        if (read >= buffer.Length - 1) {
                            throw new InvalidPlaylistException ();
                        }

Edward Lee (tigerfishdaisy) wrote :

Also, moc(p) is able to play the internet stream I'm having trouble playing with in Banshee, as does using gst-launch-0.10 to directly play the stream.

LiraNuna (liranuna) wrote :
Fabio Marconi (fabiomarconi) wrote :

Hello

Is this issue present with the latest updated karmic or lucid packages ?
Thanks
Fabio

Changed in banshee (Ubuntu):
status: New → Incomplete
Changed in banshee:
importance: Unknown → Medium
status: Unknown → New
Victor Vargas (kamus) wrote :

Edward, any news about this issue?

Changed in banshee (Ubuntu):
importance: Undecided → Medium
Edward Lee (tigerfishdaisy) wrote :

I cannot say, as I do not have access to the internet stream I did two years ago to reproduce this issue.

Fabio Marconi (fabiomarconi) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Victor Vargas (kamus) wrote :

if you encounter that this issue reappears in latest release please reopened again, Thanks.

Changed in banshee (Ubuntu):
status: Incomplete → Invalid
Matt Paddock (mapdock) wrote :

Currently experiencing this with Banshee 1.8.0 on 10.10, and Movie Player pulls the stream with no issues. Here's the feed: http://radiokstreams.cce.umn.edu:8256/listen.pls

Colin Keenan (colinkeenan) wrote :

http://radiokstreams.cce.umn.edu:8256/listen.pls

Works with Banshee 2.0 on 11.04.

David Hollander (dhllndr) wrote :

> Colin Keenan wrote on 2011-04-08: #10
> http://radiokstreams.cce.umn.edu:8256/listen.pls
>
> Works with Banshee 2.0 on 11.04.

This does not work for me. Banshee 2.0.0 on Ubuntu 11.04 64bit.
Additionally, all radio stations at http://www.di.fm/ do not work.
Example: http://listen.di.fm/public3/minimal.pls

Chromium downloads the file. Totem movie player can open and start the stream fine. However, Banshee cannot. So if you want to stream internet radio in Banshee either to A) have it play all your music or B) listen to internet radio while something is simultaneously playing in Movie Player, this is not possible.

On 10/05/2011 17:26, David Hollander wrote:
>> Colin Keenan wrote on 2011-04-08: #10
>> http://radiokstreams.cce.umn.edu:8256/listen.pls
>>
>> Works with Banshee 2.0 on 11.04.
>
> This does not work for me. Banshee 2.0.0 on Ubuntu 11.04 64bit.
> Additionally, all radio stations at http://www.di.fm/ do not work.
> Example: http://listen.di.fm/public3/minimal.pls
>
> Chromium downloads the file. Totem movie player can open and start the
> stream fine. However, Banshee cannot. So if you want to stream internet
> radio in Banshee either to A) have it play all your music or B) listen
> to internet radio while something is simultaneously playing in Movie
> Player, this is not possible.
>

Interestingly, this works when adding it as a radio station under the "Radio"
source, but does not work when trying to use "Open location".

--
Kind regards,
Loong Jin

Changed in banshee:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.