[karmic] Banshee freeze after some song playback

Bug #410763 reported by Alex Ivasyuv on 2009-08-08
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Banshee
Expired
Medium
banshee (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: banshee

Banshee freeze, after some songs playback. It's not reproducible.
Similar problem with Rhythmbox.

ProblemType: Bug
Architecture: i386
Date: Sat Aug 8 19:52:31 2009
DistroRelease: Ubuntu 9.10
Package: banshee 1.4.3-5
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic-pae
SourcePackage: banshee
Uname: Linux 2.6.31-5-generic-pae i686

Alex Ivasyuv (industral) wrote :
Sense Egbert Hofstede (sense) wrote :

Thank you for helping with making Ubuntu better. You said the bug isn't reproducible, but also said that it occurs in Rhythmbox as well. Do you mean that it can't be reproduced on command, but that it does still happen? Or did it just happen once?

I'm not sure if this is a bug in Banshee, or a bug in Gstreamer. More information would be helpful. Do you recall any upgrades just before the problem started to appear? If so, do you also remember the packages that were updated?

Changed in banshee (Ubuntu):
status: New → Incomplete
description: updated
summary: - Banshee freeze after some song playback
+ [karmic] Banshee freeze after some song playback
Sense Egbert Hofstede (sense) wrote :

I've put the GDB backtrace in an attachment to increase the readability of the bug.

Alex Ivasyuv (industral) wrote :

In Banshee in occur only once, but in Rhythmbox is occur very often.
As you can see from backtrace, issue in deadlock? in threads. Same issue in rhythmbox.

> Do you recall any upgrades just before the problem started to appear
I don't remember, but system is always up-to date. Syncing at least one time a day.

Sense Egbert Hofstede (sense) wrote :

It could be a deadlock.
I suspect it's a bug in GStreamer, so I asked at their IRC channel to have a look at the trace. They said the trace isn't complete yet, they need more threads.

Could you please post another GDB trace, but this time use the command 'thread apply all bt', rather than 'bt full'? Please make sure all necessary debugging symbols are installed!
Generating the trace by using Rhythmbox this time is OK too, maybe it will even be more helpful than another Banshee trace.

I want to ask you to have a look at this bug reported upstream: http://bugzilla.gnome.org/show_bug.cgi?id=548256 It describes a problem very similar to yours. Do you agree with the symptoms?

Thanks in advance.

Alex Ivasyuv (industral) wrote :

I sure that it's GStreamer problem.
Yes, the bug that described by link that you posted very similar to my issue behavior.

Here, new backtrace make with "thread apply all bt".
The behavior this bug:

1. I open banshee, resize application. It freeze, and hang up my X
2. In console, I find banshee PID, make backtrace
3. After process killing, X released

Sense Egbert Hofstede (sense) wrote :

Was this the first time X froze as well?

Alex Ivasyuv (industral) wrote :

X not always froze. First report was just banshee froze, second - banshee & X.

Now, there new backtrace. Just start banshee, and it froze.

Sense Egbert Hofstede (sense) wrote :

Unfortunately the backtraces you've provided aren't suitable for analysis, since you don't have all debugging symbols installed.
I've asked for assistance on the #ubuntu-bugs IRC channel and Hggdh came up with a solution. Rather than asking you to install all needed debugging symbols by hand I'm going to ask you to do the following.

Reproduce the crash, but don't kill the process right away. Instead kill Banshee with the command 'kill -11 banshee'. This should trigger Apport. Report the bug and notify me, either by mail or via this bug report. I'll then mark this bug as a duplicate of the new one and the triaging can continue in the Apport bug. Since the traces are reported online there is no need to install debugging symbols.

If you'd agree on doing so I'd be very grateful.

Josh Hamil (josh-hamil) wrote :

Hi, I believe I have exactly the same bug. I called apport-bug banshee(pid) and submitted a new bug here: https://bugs.launchpad.net/ubuntu/+source/banshee/+bug/477962 . For some reason, I couldnt get kill -11 banshee(pid) to invoke apport.

Sense Egbert Hofstede (sense) wrote :

Thank you for trying to help us! I'm afraid using killl -11 to trigger Apport isn't working anymore now automatic Apport warnings have been disabled for the final release of Ubuntu 9.10.
However, there is a chance that after you've done the kill -11 trick there is a .crash file in the directory /var/crash with banshee in its name. This is the crash report that otherwise would ask you automatically if you'd want to report it. Now you can start Apport by double-clicking the right .crash file.

Chow Loong Jin (hyperair) wrote :

During the freeze, could you try opening pavucontrol (PulseAudio Volume Control) or paman (PulseAudio Manager) and seeing if they work? The new GNOME volume control applet in Karmic which appears when you right click on the sound icon and click sound preferences would also do fine.

If they hang as well during those times, then PulseAudio is pretty much at fault, so please reassign this bug to that package in that case.

Josh Hamil (josh-hamil) wrote :

Both pavuccontrol and paman work fine through the crash of banshee.

two .crash files appeared in /var/crash after i did the kill -11 trick: one for npviewer.bin and one for banshee. when i submitted the npviewer crash report, i was led here: https://bugs.launchpad.net/ubuntu/+source/nspluginwrapper/+bug/178038 .

when i tried to run apport on the banshee .crash file, i got this pop up:

The problem cannot be reported:

The program crashed on an assertion failure, but the message could not be retrieved. Apport does not support reporting these crashes.

i couldn't upload the .crash file because it is 16Mb, but i saw this line about a hundred times toward the bottom:

(npviewer.bin:18445): Gdk-WARNING **: XID collision, trouble ahead

Is this still a problem, on either Karmic, Lucid, or Maverick? Please respond if yes.

Changed in banshee (Ubuntu):
status: Incomplete → New
status: New → Incomplete

Marking as confirmed after IRC discussion.

Changed in banshee (Ubuntu):
status: Incomplete → Confirmed
Changed in banshee:
status: Unknown → New
Changed in banshee:
status: New → Invalid
Jeff (jdorenbush) wrote :

I have the same problem. Banshee freezes during song playback, but debug mode doesn't produce any errors. The last operation Banshee tries to perform is switching the song and then the application window grays out and I have to force quit.

Changed in banshee:
importance: Unknown → Medium
status: Invalid → Expired
Jeff (jdorenbush) wrote :

Now Banshee is getting locked up from all sorts of things. On startup all of the following would cause a lock up:
/usr/lib/banshee-1/Extensions/Banshee.Daap.dll
/usr/lib/banshee-1/Extensions/Banshee.Dap.dll
/usr/lib/banshee-1/Extensions/Banshee.Podcasting.dll

The watch for files extension causes a lock up when Banshee recognizes a new file and tries to add it... Upon adding it, it'll lock up.

I haven't experienced the random lock ups during song play lately, however.

Victor Vargas (kamus) wrote :

Please could somebody check if this behaviour is still occurring with latest release of banshee 1.9.2 from daily ppa repository? Thanks.

Changed in banshee (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Victor Vargas (kamus) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in banshee (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.