No radio stations provided by default

Bug #394812 reported by Vonschutter on 2009-07-02
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Banshee
Fix Released
Wishlist
banshee (Ubuntu)
Wishlist
Chow Loong Jin
Declined for Natty by Brian Murray

Bug Description

Binary package hint: banshee

I installed banshee from the repositories and the radio station list is empty. Besides not being a very useful feature without anything to listen to, is contradicts the set expectation from other popular media players like iTunes, WinAmp, Windows Media Player, Amarok, etc. All in all, this issue deprecates the perception of Banshee as a media player.

This must be a bug because in an earlier version (LTS distro) there was a radio station list that was usable.

If I'm not mistaken, the LTS included a pre-1.0 version of Banshee. While it was inferior in many, many ways, it's true that it included radio stations by default. This bug exists upstream (https://bugzilla.gnome.org/show_bug.cgi?id=548197), but I'm not sure much is currently being done to fix this.

Changed in banshee:
status: Unknown → Confirmed
summary: - Radio station list is empty
+ No radio stations provided by default
Changed in banshee (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Changed in banshee:
importance: Unknown → Wishlist
Josh (majik) wrote :

Why is this wishlist?

This is a bug.

The feature was there, then the product was upgraded, now it's not there.

Changing status back to Confirmed.

Changed in banshee (Ubuntu):
status: Triaged → Confirmed

On 29/04/2011 12:24, Josh wrote:
> Why is this wishlist?
>
> This is a bug.
>
> The feature was there, then the product was upgraded, now it's not
> there.
>
> Changing status back to Confirmed.
>
> ** Changed in: banshee (Ubuntu)
> Status: Triaged => Confirmed
>

Please don't change bug statuses unnecessarily. The Banshee task under Ubuntu is
set to triaged because it has been forwarded upstream and is handled there --
see the gnome-bugs link at the top of the page.

The importance is set to wishlist because it is a relatively minor bug, and can
be easily worked around by adding your own radio stations, or installing
banshee-extension-radiostationfetcher and banshee-extension-liveradio to
retrieve stations from some third party providers.

  status triaged

--
Kind regards,
Loong Jin

Changed in banshee:
status: Confirmed → Triaged
Shane H (shane.h) wrote :

I would like the list of radio stations provided to be geographically determined. See my Ubuntu Brainstorm idea: http://brainstorm.ubuntu.com/idea/25364

Thank-you.

Changed in banshee:
status: Triaged → Confirmed
komputes (komputes) wrote :

Charles Profitt put together a list of radio stations.

"One of the minor nuisances of 11.04 is the lack of pre-set radio stations in Banshee. I made a list of the radio station URLs that were included with Rhythmbox and have listed them below:"

http://ftbeowulf.wordpress.com/2011/05/03/unity-banshee-radio-stations/

Changed in banshee:
status: Confirmed → Fix Released

Martin Pitt provided a patch to Banshee to allow distributions to include a file (/usr/share/banshee/stations/default.xsps) that will be loaded on start. This way, the onus is now on distros (like Ubuntu) to create that file.

Can someone propose a default list of stations and attach the xsps file to this bug? When it looks good, we should propose it in both Debian and Ubuntu (to get improvements everywhere, and minimize the diff we carry).

Chow Loong Jin (hyperair) wrote :

For the time being, I'm going to look into converting the list found at http://ftbeowulf.wordpress.com/2011/05/03/unity-banshee-radio-stations/ to xspf format. Is the extension really xsps? Everywhere I look, I see xspf.

Chow Loong Jin (hyperair) wrote :

For the record, the specification seems to be here: http://www.xspf.org/xspf-v1.html

Changed in banshee (Ubuntu):
assignee: nobody → Chow Loong Jin (hyperair)
status: Confirmed → In Progress
Chow Loong Jin (hyperair) wrote :

Alright, here's a tarball of xspf files, one for each genre. Judging by XspfMigrator.cs, it looks like the radio stations' genres are taken from the playlist title, and each xspf file only has one <playlist> element, so it has to be this way.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.