Podcasts downloading can't be finished

Bug #326827 reported by klerewklr
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fix Released
banshee (Ubuntu)
Fix Released

Bug Description

Binary package hint: banshee

If Banshee begins downloading a podcast, the area "Downloading podcast(s)" in left-bottom corner appears and downloading goes on until at some point before "100%" this area disappears and downloading stops without any message. Banshee returns to state as before downloading and continues to work. This applies both to if downloading was started automatically or manually.

While downloading Banshee creates temporary directory in ~/.config/banshee-1/downloads in which it places a temporary file. When downloading stops this directory is deleted.

It seems that it is the same bug as the reported one at http://www.nabble.com/Podcasts-start-downloading-then-stop-at-random---td20493650.html. mattman writes there that navigating to ~/.config/banshee-1/downloads and selecting a temporary file prevents Banshee from stopping. I've tried so and got my first downloaded podcast in Banshee which appeared in ~/Music/Podcasts. However it is not a solution because it doesn't solve the problem with automatic downloading of podcasts when updating.

Playing (streaming) a podcast without downloading by double-clicking it or pressing the play button works alright.

Software versions:
Ubuntu version is 8.10 (Intrepid).
Banshee version is 1.2.1 (1.2.1-3ubuntu1) which is the version shipped with Ubuntu 8.10 (Intrepid). However I've also tried the latest Banshee 1.4.2 (1.4.2-1~intrepid1) installed from the source "http://ppa.launchpad.net/banshee-team/ppa/ubuntu intrepid main" and there was the same bug.
Mono libraries (dpkg -l | grep mono):
ii libmono-addins-gui0.2-cil 0.3.1-5 GTK# frontend library for Mono.Addins
ii libmono-addins0.2-cil 0.3.1-5 addin framework for extensible CLI applications/librari
ii libmono-cairo1.0-cil 1.9.1+dfsg-4ubuntu2 Mono Cairo library
ii libmono-cairo2.0-cil 1.9.1+dfsg-4ubuntu2 Mono Cairo library
ii libmono-corlib1.0-cil 1.9.1+dfsg-4ubuntu2 Mono core library (1.0)
ii libmono-corlib2.0-cil 1.9.1+dfsg-4ubuntu2 Mono core library (2.0)
ii libmono-data-tds1.0-cil 1.9.1+dfsg-4ubuntu2 Mono Data library
ii libmono-data-tds2.0-cil 1.9.1+dfsg-4ubuntu2 Mono Data Library
ii libmono-i18n1.0-cil 1.9.1+dfsg-4ubuntu2 Mono I18N libraries (1.0)
ii libmono-i18n2.0-cil 1.9.1+dfsg-4ubuntu2 Mono I18N libraries (2.0)
ii libmono-security1.0-cil 1.9.1+dfsg-4ubuntu2 Mono Security library
ii libmono-security2.0-cil 1.9.1+dfsg-4ubuntu2 Mono Security library
ii libmono-sharpzip0.84-cil 1.9.1+dfsg-4ubuntu2 Mono SharpZipLib library
ii libmono-sharpzip2.84-cil 1.9.1+dfsg-4ubuntu2 Mono SharpZipLib library
ii libmono-sqlite2.0-cil 1.9.1+dfsg-4ubuntu2 Mono Sqlite library
ii libmono-system-data1.0-cil 1.9.1+dfsg-4ubuntu2 Mono System.Data library
ii libmono-system-data2.0-cil 1.9.1+dfsg-4ubuntu2 Mono System.Data Library
ii libmono-system-web1.0-cil 1.9.1+dfsg-4ubuntu2 Mono System.Web library
ii libmono-system-web2.0-cil 1.9.1+dfsg-4ubuntu2 Mono System.Web Library
ii libmono-system1.0-cil 1.9.1+dfsg-4ubuntu2 Mono System libraries (1.0)
ii libmono-system2.0-cil 1.9.1+dfsg-4ubuntu2 Mono System libraries (2.0)
ii libmono-zeroconf1.0-cil 0.7.6-1 CLI library for multicast DNS service discovery
ii libmono0 1.9.1+dfsg-4ubuntu2 libraries for the Mono JIT
ii libmono1.0-cil 1.9.1+dfsg-4ubuntu2 Mono libraries (1.0)
ii libmono2.0-cil 1.9.1+dfsg-4ubuntu2 Mono libraries (2.0)
ii mono-common 1.9.1+dfsg-4ubuntu2 common files for Mono
ii mono-gac 1.9.1+dfsg-4ubuntu2 Mono GAC tool
ii mono-jit 1.9.1+dfsg-4ubuntu2 fast CLI JIT/AOT compiler for Mono
ii mono-runtime 1.9.1+dfsg-4ubuntu2 Mono runtime
When using the above source "http://ppa.launchpad.net/banshee-team/ppa/ubuntu intrepid main" a package libmono-zeroconf1.0-cil was upgraded from "0.7.6-1" to "0.8.0-1~intrepid1".

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
Package: banshee 1.2.1-3ubuntu1
SourcePackage: banshee
Uname: Linux 2.6.27-11-generic i686

Tags: apport-bug

Related branches

Revision history for this message
klerewklr (ya-ya-ya-ya-ya) wrote :
Changed in banshee:
status: Unknown → New
Rami Al-Rfou' (rmyeid)
Changed in banshee:
status: New → Unknown
Changed in banshee:
status: Unknown → Fix Released
Changed in banshee (Ubuntu):
status: New → Confirmed
Revision history for this message
Neil Munro (neilmunro-deactivatedaccount) wrote :

This bug appears to have been fixed upstream, I do not know which version it was fixed in however I am running 1.5 and this bug is not present for me using 1.5. This suggests the bug may be fixed in the latest version of Ubuntu if not it should be fixed in the next version of Ubuntu.

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Changed in banshee (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Micah Gersten (micahg) wrote :

Fix is in Banshee 1.5 changelog.

Changed in banshee (Ubuntu):
importance: Undecided → Medium
status: Fix Released → Triaged
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (7.4 KiB)

This bug was fixed in the package banshee - 1.5.1~git2260a87-0ubuntu1

banshee (1.5.1~git2260a87-0ubuntu1) karmic; urgency=low

  [ Chow Loong Jin ]
  * debian/control, debian/changelog:
    + Use mono-csc instead of csc for MCS.
    + Bump mono-devel version to 2.4.2 for mono-csc

  [ Iain Lane ]
  * Upload upstream snapshot from revision 2260a87. FFe granted on IRC by
    ScottK and sistpoty. Uploading a snapshot as 1.5.1 is almost released,
    which has a lot of improvements over 1.5.0. We have preliminary SRU
    approval to update to 1.5.1 final if it is released after Karmic, subject
    to the usual criteria:

    New Features:

    - Play Queue Auto DJ keeps the tunes coming
    - Shuffle by album and artist
    - Shuffle by weighted rating and score mode
    - Add tooltips for ellipsized ListView text
    - Keep the playing song visible in the track list
    - Add support for WebOS devices
    - Add support for the Samsung Galaxy Android Phone


    - When user picks new sort column, default to sort ascending
    - Drop the " Library" suffix on the Music and Video sources
    - Add thin highlight to ListView selection for 3D effect
    - Keyboard shortcut (ESC) to clear the search box
    - Expose LAME's "preset" option
    - Added a --gconf-base-key for running sandboxed
    - Trim URL pasted from clipboard to podcast dialog
    - Allow selection of multiple folders on import
    - Support playlists on Android G1 devices
    - Better support for devices running Rockbox
    - Set video sync folder for Android and WebOS devices
    - Made the error message label selectable
    - Save and load the Gtk.AccelMap
    - Added taglib/oga mimetype to the vorbis audio profile
    - Auto-completion for composer, conductor, grouping and copyright
    - Added the 'comment' search filter
    - Selectable song properties
    - Show a tooltip in track editor when the property is truncated

    Notable bug fixes:

    - Fix blank MimeTypes for tracks ripped before 1.4
    - Fix a Bit Rate column sizing glitch
    - Fix browser positioning when Banshee is maximised
    - Fix compilation metadata reading and writing
    - Work with new notification-daemon
    - Avoid needlessly syncing iPods twice
    - Deterministically sort sources to avoid fluttering
    - Look for Rhythmbox db at both new and old paths
    - Fix bug with scrobbling after skipping a track
    - Fix crash in equalizer
    - Fix an exception on startup when DBus is disabled
    - Fix off-by-one-day date querying bug
    - Fix a UI/spacing glitch in the Smart Playlist Editor
    - Don't hide the track info popup while it has focus
    - Prevent endless "Searching for CD metadata..."
    - Fix Last.fm now-playing for non-decimal track lengths
    - Dispose the SqliteCommand after it's executed
    - Fix notification area popup positioning on multi-monitor systems
    - Fix the playing indicator when song in list more than once
    - Fix crash when opening the profile conf dialog
    - Fix crash stopping jobs on shutdown
    - Fix notification area popup flashing
    - Trim filename dots and spaces to be NTFS compliant
    - Stop playing from audio CD ...


Changed in banshee (Ubuntu):
status: Triaged → Fix Released
Changed in banshee:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.