Do not scrobble (add to last.fm library) radio songs

Bug #290030 reported by Alex Karpenko on 2008-10-27
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Banshee
New
Wishlist
banshee (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: banshee

Some recommended songs from the last.fm radio are good and some are not. I do not want my last.fm library to be cluttered with songs I don't like just because I decided to listen to last.fm's recommendations. The iPhone last.fm application allows disabling of radio scrobbling (adding to library). In a similar vein banshee should offer an option to not scrobble recommended songs by last.fm. This could also apply to internet radio stations (since you probably don't want to add most songs on the radio to your library).

This option can be added under:
Tools > Last.fm > Enable Radio Scrobbling (Reporting)

Andrew Conkling (andrewski) wrote :

Thanks for your bug report. This feature is actually already implemented: Tools > Last.fm > Enable Song Reporting (Ctrl+U by default) will do exactly what you want. You'll need to have the "Last.fm Radio and Scrobbling" extension enabled.

Please reply if you have any other questions.

Changed in banshee:
status: New → Invalid
Alex Karpenko (alexkarpenko) wrote :

Hello Andrew,

I wasn't very clear. What I meant was that song reporting should only be enabled for local tracks but not tracks from the radio. Currently enabling song reporting also scrobbles the radio. This is undesired as most radio tracks (from last.fm and from internet radio stations) I do not want to be scrobbled, while I *do* want local tracks (part of *my* library) to be scrobbled.

So what I propose is to have two options in Tools > Last.fm:
1. Enable Local Song Reporting
2. Enable Radio Song Reporting

Changed in banshee:
status: Invalid → New
Alex Karpenko (alexkarpenko) wrote :

I've reopened with the above clarification. I hope that's ok.

Andrew Conkling (andrewski) wrote :

Yes Alex, that was fine. Thanks for taking care of that and sorry I didn't do it sooner.

This would be a good idea in general, and I've filed it upstream so that Banshee developers and maintainers will be notified. This would be a good candidate for an addition to the Last.fm extension, I believe.

Changed in banshee:
status: New → Confirmed
Alex Karpenko (alexkarpenko) wrote :

In an effort to move this along, I've patched banshee myself. I've attached a screenshot of what my change looks like. I am not fully satisfied with this solution, because as it turns out the original song reporting GUI option performed two tasks:
1. It reports a song as "Now Playing" to last.fm
2. It scrobbles the song when the song has finished playing

It's probably sensible to decouple the two to allow the user to report all songs "now playing", but to scrobble only local tracks or only radio tracks or both. So I propose to change the Last.fm menu to contain the following options:

   Report Tracks as "Now Playing"
   Scrobble Local Tracks
   Scrobble Radio Tracks

instead of the current "Enable Song Reporting" option which toggles all of the above at once.

I'd like to get some input from banshee developers before I proceed with creating a patch.

On Sun, 2008-11-09 at 06:48 +0000, Alex Karpenko wrote:
> In an effort to move this along, I've patched banshee myself. I've attached a screenshot of what my change looks like. I am not fully satisfied with this solution, because as it turns out the original song reporting GUI option performed two tasks:
> 1. It reports a song as "Now Playing" to last.fm
> 2. It scrobbles the song when the song has finished playing
>
> It's probably sensible to decouple the two to allow the user to report
> all songs "now playing", but to scrobble only local tracks or only radio
> tracks or both. So I propose to change the Last.fm menu to contain the
> following options:
>
> Report Tracks as "Now Playing"
> Scrobble Local Tracks
> Scrobble Radio Tracks
>
> instead of the current "Enable Song Reporting" option which toggles all
> of the above at once.
>
> I'd like to get some input from banshee developers before I proceed with
> creating a patch.
>
> ** Attachment added: "screenshot.png"
> http://launchpadlibrarian.net/19504653/screenshot.png
>
It's awesome that you've created a patch for this. The developers
generally don't look in launchpad.net though. Could you post this in the
upstream bug tracker (bugzilla.gnome.org)? It's linked to this bug
already, at the top of this bug page.
--
Chow Loong Jin

Changed in banshee:
status: Unknown → New
Changed in banshee (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in banshee:
importance: Unknown → Wishlist
José Lou Chang (obake) on 2011-03-19
tags: added: banshee last.fm radio scrobble
w-sky (w-sky) wrote :

Is there a way to bouce this topic? Actually I do really want Banshee to also scrobble songs I listen to on internet radio!
Currently only local tracks are being scrobbled.

So I favour the solution Alex Karpenko presented very much. Is there any way to get it?

Francisco Leite (xxleite) wrote :

i luv banshee, please consider this feature as icing on the cake ... well at least for me

Adolfo Jayme (fitojb) on 2013-05-19
Changed in banshee (Ubuntu):
importance: Low → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.