Unable to play radio station stream

Bug #250247 reported by João Pinto on 2008-07-20
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Banshee
Invalid
Undecided
Unassigned
banshee (Ubuntu)
Undecided
Unassigned
rhythmbox (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Package: rhythmbox
Version: 0.11.6-0ubuntu1 (Intrepid)

How to reproduce it:
Launch the application, hit CTRL-I to add a new internet radio station.

Add the following url:
mms://espalhabrasas.sapo.pt/RFM

Play it.

The application will hang.

This specific radio stream plays with mplayer so it should not be a server side issue.

Related branches

João Pinto (joaopinto) on 2008-07-20
description: updated
Jon Packard (jonpackard) wrote :

I am running Hardy and could not play this stream in Totem, Rhythmbox, Mplayer or VLC. Versions and error messages below:

totem:
Installed: 2.22.1-0ubuntu2
Error: Could not open location; you might not have permission to open the file.

rhythmbox:
Installed: 0.11.5-0ubuntu8
Error: Unknown playback error

mplayer:
Installed: 2:1.0~rc2-0ubuntu13
Error: Couldn't resolve name for AF_INET6: espalhabrasas.sapo.pt

vlc:
Installed: 0.8.6.release.e+x264svn20071224+faad2.6.1-0ubuntu3
Error: Unable to open 'mms://espalhabrasas.sapo.pt/RFM'

Also, see bug #250251, filed against Totem.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, is the issue specific to this url? does gst-launch-0.10 playbin uri=URL works correctly?

Changed in rhythmbox:
importance: Undecided → Low
status: New → Incomplete
João Pinto (joaopinto) wrote :

I forgot to mention that I am using a 64 bits system.

$ gst-launch-0.10 playbin uri=mms://espalhabrasas.sapo.pt/RFM
Setting pipeline to PAUSED ...

And it just keeps there with this message...

$ apt-cache policy amarok
amarok:
  Installed: 2:1.4.9.1-2ubuntu3

Amarok hangs for 2/3 seconds when starting to play but then plays the stream just fine.

I have tested with another mainstream portuguese radio station and got the same problem (mms://195.245.168.21/antena3).

Jon Packard (jonpackard) wrote :

After automatically prompting me to install some codecs, Rhythmbox was able to play mms://195.245.168.21/antena3 but not mms://espalhabrasas.sapo.pt/RFM. I have tested this in Hardy and Intrepid (both 32-bit). See my previous comment for error messages trying to play mms://espalhabrasas.sapo.pt/RFM.

Sebastien Bacher (seb128) wrote :

the errors indicate that the issue is not specific to rhythmbox and rather a server or network configuration one

Changed in rhythmbox:
status: Incomplete → Invalid
João Pinto (joaopinto) wrote :

Sebastien,
would you care to explain me why is there a network problem and I am able to play the stream with Amarok ?

The stream also plains just fine from windows media players.

Thanks

Changed in rhythmbox:
status: Invalid → Confirmed
Sebastien Bacher (seb128) wrote :

the comment 1 indicates no software can read it correctly, does it work correctly using other softwares for you?

Changed in rhythmbox:
status: Confirmed → Incomplete
João Pinto (joaopinto) wrote :

It does play using Amarok, it will hang on startup for something like 10 seconds but will play the stream after that.

Thanks

Changed in rhythmbox:
assignee: nobody → desktop-bugs
status: Incomplete → New
João Pinto (joaopinto) wrote :

VLC does play the stream after several minutes attempting to retrieve the data from the server.

João Pinto (joaopinto) wrote :

Banshee does not hang but it does not play the stream.

summary: - hangs playing radio station
+ unable to playing radio station stream
summary: - unable to playing radio station stream
+ Unable to play radio station stream
Gareth Hart (tghe-retford) wrote :

The problems with Banshee not playing internet streams (in particular Windows Media ones) is covered in bug #545646 on Gnome's Bugzilla, ironically finding an answer as to why WMA streams wouldn't play in Banshee.

Changed in banshee:
status: Unknown → Fix Released
Pedro Villavicencio (pedro) wrote :

I'm still unable to play the stream with any other program as well, could somebody send this to bugzilla.gnome.org where the software authors can read about it? thanks.

Changed in banshee (Ubuntu):
status: New → Triaged
zertz (zertz) wrote :

i thought this bug might be resolved when i bougt a last.fm subscription. tried that. nothing was resolved. maybe that will resovle when the code in Banshee goes do the new 2.0 API. anyone any idea how long that might take ? i hear its very evil and all this transistion. i went ahead and gave them $3 becaues i like that feature, when it works, i'm obviously going to be using the learned behavior patterns of multi many of thousands if not more of people using their service for free. there is of course, a less evil .fm alterntative i heard of, though i'm not sure if it can keep up with the masses.

zertz (zertz) wrote :

i thought this bug might be resolved when i bougt a last.fm subscription. tried that. nothing was resolved. maybe that will resovle when the code in Banshee goes do the new 2.0 API. anyone any idea how long that might take ? i hear its very evil and all this transistion. i went ahead and gave them $3 becaues i like that feature, when it works, i'm obviously going to be using the learned behavior patterns of multi many of thousands if not more of people using their service for free. there is of course, a less evil .fm alterntative i heard of, though i'm not sure if it can keep up with the masses.

zertz (zertz) wrote :

btw, this is broken in Koala too, needless to say.

any ideas how long it takes to implemtment the new 2.0 API code ?

zertz (zertz) wrote :

i speak of the banshee recommended radio being brown and not progressing giving a orange icon to the first two songs it selects and stalls. made me believe that i needed an account. realize, i didn't have the 2.0 API thought maybe i could get it elsehere. :/ well, running banshee from command line doesn't dump anything at all when i get the two orange icons so i'm not sure if this is much help. 1.4.3 banshee. navigating to any non-organge icon gives it a orange icon.

Launchpad Janitor (janitor) wrote :
Download full text (7.4 KiB)

This bug was fixed in the package banshee - 1.5.1~git2260a87-0ubuntu1

---------------
banshee (1.5.1~git2260a87-0ubuntu1) karmic; urgency=low

  [ Chow Loong Jin ]
  * debian/control, debian/changelog:
    + Use mono-csc instead of csc for MCS.
    + Bump mono-devel version to 2.4.2 for mono-csc

  [ Iain Lane ]
  * Upload upstream snapshot from revision 2260a87. FFe granted on IRC by
    ScottK and sistpoty. Uploading a snapshot as 1.5.1 is almost released,
    which has a lot of improvements over 1.5.0. We have preliminary SRU
    approval to update to 1.5.1 final if it is released after Karmic, subject
    to the usual criteria:

    New Features:

    - Play Queue Auto DJ keeps the tunes coming
    - Shuffle by album and artist
    - Shuffle by weighted rating and score mode
    - Add tooltips for ellipsized ListView text
    - Keep the playing song visible in the track list
    - Add support for WebOS devices
    - Add support for the Samsung Galaxy Android Phone

    Enhancements:

    - When user picks new sort column, default to sort ascending
    - Drop the " Library" suffix on the Music and Video sources
    - Add thin highlight to ListView selection for 3D effect
    - Keyboard shortcut (ESC) to clear the search box
    - Expose LAME's "preset" option
    - Added a --gconf-base-key for running sandboxed
    - Trim URL pasted from clipboard to podcast dialog
    - Allow selection of multiple folders on import
    - Support playlists on Android G1 devices
    - Better support for devices running Rockbox
    - Set video sync folder for Android and WebOS devices
    - Made the error message label selectable
    - Save and load the Gtk.AccelMap
    - Added taglib/oga mimetype to the vorbis audio profile
    - Auto-completion for composer, conductor, grouping and copyright
    - Added the 'comment' search filter
    - Selectable song properties
    - Show a tooltip in track editor when the property is truncated

    Notable bug fixes:

    - Fix blank MimeTypes for tracks ripped before 1.4
    - Fix a Bit Rate column sizing glitch
    - Fix browser positioning when Banshee is maximised
    - Fix compilation metadata reading and writing
    - Work with new notification-daemon
    - Avoid needlessly syncing iPods twice
    - Deterministically sort sources to avoid fluttering
    - Look for Rhythmbox db at both new and old paths
    - Fix bug with scrobbling after skipping a track
    - Fix crash in equalizer
    - Fix an exception on startup when DBus is disabled
    - Fix off-by-one-day date querying bug
    - Fix a UI/spacing glitch in the Smart Playlist Editor
    - Don't hide the track info popup while it has focus
    - Prevent endless "Searching for CD metadata..."
    - Fix Last.fm now-playing for non-decimal track lengths
    - Dispose the SqliteCommand after it's executed
    - Fix notification area popup positioning on multi-monitor systems
    - Fix the playing indicator when song in list more than once
    - Fix crash when opening the profile conf dialog
    - Fix crash stopping jobs on shutdown
    - Fix notification area popup flashing
    - Trim filename dots and spaces to be NTFS compliant
    - Stop playing from audio CD ...

Read more...

Changed in banshee (Ubuntu):
status: Triaged → Fix Released
João Pinto (joaopinto) on 2009-10-11
Changed in banshee (Ubuntu):
status: Fix Released → Confirmed
Changed in banshee:
importance: Unknown → Undecided
status: Fix Released → New
status: New → Confirmed

On Sunday 11,October,2009 04:35 PM, João Pinto wrote:
> ** Changed in: banshee (Ubuntu)
> Status: Fix Released => Confirmed
>
> ** Changed in: banshee
> Importance: Unknown => Undecided
>
> ** Changed in: banshee
> Status: Fix Released => New
>
> ** Changed in: banshee
> Remote watch: GNOME Bug Tracker #545646 => None
>
> ** Changed in: banshee
> Status: New => Confirmed
>
I am unable to play the stream with both mplayer and banshee. Do you have a
stream which works in mplayer but does not in Banshee?

  affects ubuntu/banshee
  status incomplete

Also, why did you unlink this bug from the upstream bug? Are you sure it is
different?

--
Kind regards,
Chow Loong Jin (GPG: 0x8F02A411)
Ubuntu Contributing Developer

Changed in banshee (Ubuntu):
status: Confirmed → Incomplete
João Pinto (joaopinto) wrote :

Updarting the issue:
I am unable to play the stream with the amarok version from Karmic. amarok was the only app able to stream in the past.
mms://espalhabrasas.sapo.pt/RFM

I can play the stream using Windows (Windows media player) from the same PC, so it's not a physical network issue.

Output from vlc:
LANG=C cvlc mms://espalhabrasas.sapo.pt/RFM
VLC media player 1.0.2 Goldeneye
[0xf774e8] main interface error: no interface module matched "screensaver,none"
[0xf774e8] main interface error: no suitable interface module
[0xe8f0c8] main libvlc error: interface "screensaver,none" initialization failed
[0xe8f0c8] main libvlc error: option drawable-xid does not exist
[0xf8b768] main interface error: no interface module matched "globalhotkeys,none"
[0xf8b768] main interface error: no suitable interface module
[0xe8f0c8] main libvlc error: interface "globalhotkeys,none" initialization failed
[0xf8b448] dummy interface: using the dummy interface module...
[0xf90308] access_mms access error: no data received
[0xf90308] access_mms access error: no data received
....
it keeps looping on the "no data received" error, sometimes with "[0xf90308] access_mms access error: unknown answer (0x1 instead of 0x06)"

Changed in banshee (Ubuntu):
status: Incomplete → Confirmed
João Pinto (joaopinto) wrote :

Mplayer does partially play the strem until it ends with an end of file error:

LANG=C mplayer mms://espalhabrasas.sapo.pt/RFM
MPlayer UNKNOWN-4.4.1 (C) 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing mms://espalhabrasas.sapo.pt/RFM.
STREAM_ASF, URL: mms://espalhabrasas.sapo.pt/RFM
Resolving espalhabrasas.sapo.pt for AF_INET6...
Couldn't resolve name for AF_INET6: espalhabrasas.sapo.pt
Resolving espalhabrasas.sapo.pt for AF_INET...
Connecting to server espalhabrasas.sapo.pt[213.13.154.194]: 1755...
Connected
MPlayer from karmic does partially play the sream, until it finished with an end of stream error.

read error:: Resource temporarily unavailable
pre-header read failed
Resolving espalhabrasas.sapo.pt for AF_INET6...
Couldn't resolve name for AF_INET6: espalhabrasas.sapo.pt
Resolving espalhabrasas.sapo.pt for AF_INET...
Connecting to server espalhabrasas.sapo.pt[213.13.154.194]: 80...
Resolving espalhabrasas.sapo.pt for AF_INET6...
Couldn't resolve name for AF_INET6: espalhabrasas.sapo.pt
Resolving espalhabrasas.sapo.pt for AF_INET...
Connecting to server espalhabrasas.sapo.pt[213.13.154.194]: 80...
Cache size set to 64 KBytes
Cache fill: 12.50% (8192 bytes)
ASF file format detected.
[asfheader] Audio stream found, -aid 1
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 32000 Hz, 2 ch, s16le, 32.0 kbit/3.12% (ratio: 4000->128000)
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
==========================================================================
[pulse] working around probably broken pause functionality,
        see http://www.pulseaudio.org/ticket/440
AO: [pulse] 32000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
nop_streaming_read error : Resource temporarily unavailable 0.5% 0%
Error while reading network stream.
A:1950672.9 (541:51:12.8) of 2133437440.0 (592621:30:40.0) 23.1% 0%

Exiting... (End of file)

Chow Loong Jin (hyperair) wrote :

hyperair@ipwn:~$ mplayer mms://espalhabrasas.sapo.pt/RFM
MPlayer UNKNOWN-4.4.1 (C) 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing mms://espalhabrasas.sapo.pt/RFM.
STREAM_ASF, URL: mms://espalhabrasas.sapo.pt/RFM
Resolving espalhabrasas.sapo.pt for AF_INET6...
Couldn't resolve name for AF_INET6: espalhabrasas.sapo.pt
Resolving espalhabrasas.sapo.pt for AF_INET...
Connecting to server espalhabrasas.sapo.pt[213.13.154.194]: 1755...
Connected
read error:: Operation now in progress
pre-header read failed
Resolving espalhabrasas.sapo.pt for AF_INET6...
Couldn't resolve name for AF_INET6: espalhabrasas.sapo.pt
Resolving espalhabrasas.sapo.pt for AF_INET...
Connecting to server espalhabrasas.sapo.pt[213.13.154.194]: 80...
unknown ASF streaming type
Failed, exiting.
Resolving espalhabrasas.sapo.pt for AF_INET6...
Couldn't resolve name for AF_INET6: espalhabrasas.sapo.pt
Resolving espalhabrasas.sapo.pt for AF_INET...
Connecting to server espalhabrasas.sapo.pt[213.13.154.194]: 80...
Cache size set to 320 KBytes
Cache fill: 0.03% (113 bytes)

Exiting... (End of file)

That's mplayer's output for me. Do you have another radio stream that is
affected by this issue?

--
Kind regards,
Chow Loong Jin (GPG: 0x8F02A411)
Ubuntu Contributing Developer

João Pinto (joaopinto) wrote :

I can reproduce the problem with other MMS streams.

This problem affects every player, the problem must be on a lower layer, also I found a much severe problem in which trying to play one of the streams will reset my ethrnet connection (I am still researching if it's a linux driver issue, or the router dropping the connection for some reason.)

I am going to set the bug as invalid until I can do a better analysis.

Changed in banshee:
status: Confirmed → Invalid
Changed in banshee (Ubuntu):
status: Confirmed → Invalid
Changed in rhythmbox (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.