banshee does not recognize ipod

Bug #217489 reported by Anthony Squire on 2008-04-14
6
Affects Status Importance Assigned to Milestone
banshee (Ubuntu)
Low
Unassigned

Bug Description

I have an older 30 GB hfplus formatted ipod. It's mount shows up on the desktop, however in banshee it doesn't show up like it did in Gutsy. Also when I attempt to eject it from the desktop, it complains, saying it cannot unmout. The ipod icon disappears, but the ipod still reads that it's connected. This occurs on both of my machines, my machines being i386 and amd64.

Description: Ubuntu hardy (development branch)
Release: 8.04

banshee:
  Installed: 0.13.2+dfsg-9
  Candidate: 0.13.2+dfsg-9
  Version table:
 *** 0.13.2+dfsg-9 0
        500 http://us.archive.ubuntu.com hardy/universe Packages
        100 /var/lib/dpkg/status

Caroline Ford (secretlondon) wrote :

Have you tried to reproduce this in other media players such as rhythmbox?

I suspect this may not be a problem in Banshee itself.

Caroline Ford (secretlondon) wrote :

After you've tried in other music players could you look at https://wiki.ubuntu.com/DebuggingRemovableDevices and get some info for us?

Caroline Ford (secretlondon) wrote :

Ubuntu ->hal

Anthony Squire (tony11235) wrote :

As of now, there seems to be no trouble unmounting my ipod. But it is still going unrecognized in Banshee. Rhythmbox recognizes it however.

Anthony Squire (tony11235) wrote :

I uninstalled banshee and it's dependencies. And when I reinstalled it, it downloaded a fresh version apparently, as apposed to the binary that was already in the cache. And my ipod was recognized. But I cannot sync it, "your ipod is mounted read only". And it's the stupid firmware version, 1.3. I guess I'll just have to wait until firmware version 1.3 is supported by banshee. This sucks.

Caroline Ford (secretlondon) wrote :

Moving bug to banshee.

Caroline Ford (secretlondon) wrote :

It looks like the new Banshee release 0.98.3 has support for ipods.

http://www.banshee-project.org/Releases/0.98.3

That's currently in Debian experiemental, so hopefully will end up in intrepid.

Sebastian Dröge (slomo) wrote :

0.13.2 has support for ipods too, you only need to install podsleuth for this to work. Unfortunately Ubuntu doesn't install recommends by default in hardy so this doesn't happen magically.

Anthony Squire (tony11235) wrote :

Okay problem solved. I originally didn't had podsleuth installed. So that was installed, but the iPod couldn't be written to and was mounted read only. HFS+ formatted iPods seem to have this problem. I disabled journaling and now the iPod can be written to. Banshee can sync it now. No problem on Banshee's part.

Anthony Squire (tony11235) wrote :

Actually I wrote too soon. Banshee syncs the ipod with the library, however it messages "Failed to synchronise iPod: Failed to save database", even though the songs get synced. But this is probably not the place to report this.

Pedro Villavicencio (pedro) wrote :

this is working now with hardy, can you test again?

Changed in banshee:
importance: Undecided → Low
status: New → Incomplete
Anthony Squire (tony11235) wrote :

It's fine now. As long as an HFS+ formatted ipod has journaling disabled.

Jayson Rowe (jayson.rowe) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in banshee:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers