banshee freezes on start

Bug #1534971 reported by Andrea Amoroso
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
banshee (Ubuntu)
Medium
Unassigned

Bug Description

Banshee is not working on Ubuntu 16.04. With old config folder, it freezes on startup. If I remove the old config folder, Banshee starts correctly, but freezes everytime I launch the action to scan the music on my computer.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: banshee 2.9.0+really2.6.2-3ubuntu1
ProcVersionSignature: Ubuntu 4.3.0-5.16-generic 4.3.3
Uname: Linux 4.3.0-5-generic x86_64
ApportVersion: 2.19.3-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Jan 16 18:58:23 2016
InstallationDate: Installed on 2015-01-16 (365 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
SourcePackage: banshee
UpgradeStatus: Upgraded to xenial on 2016-01-16 (0 days ago)

Revision history for this message
Andrea Amoroso (heiko81) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in banshee (Ubuntu):
status: New → Confirmed
Revision history for this message
Chow Loong Jin (hyperair) wrote : Re: [Bug 1534971] [NEW] banshee freezes on start

Debug output please. http://banshee.fm/contribute/file-bugs

  status incomplete

--
Kind regards,
Loong Jin

Changed in banshee (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Francois Noel (kranky-franky) wrote :

At first glance, it looks related to this https://bugzilla.gnome.org/show_bug.cgi?id=740879

Revision history for this message
Chow Loong Jin (hyperair) wrote :

Hmm, that new patch does look correct.

Revision history for this message
Francois Noel (kranky-franky) wrote :

It doesn't seem it's been applied to the source yet though.

I'm thinking about testing the patch. If Banshee is not working in 16.04, it's a show stoppper for me. I'll report back if I'm successful.

Revision history for this message
Francois Noel (kranky-franky) wrote :

Well, following this guide https://help.ubuntu.com/community/UpdatingADeb I get stuck on the first command.

laelia:/var/log$ sudo apt-get build-dep banshee
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 builddeps:banshee : Depends: libgnome-desktop-dev but it is not installable
E: Unable to correct problems, you have held broken packages.

libgnome-desktop-dev does not exist in repository. Don't know what to do from here. Will keep searching for solution.

Revision history for this message
Francois Noel (kranky-franky) wrote :

Using aptitude instead of apt-get works.

sudo aptitude build-dep banshee

Revision history for this message
Francois Noel (kranky-franky) wrote :

I tested the patch and it fixes the problem on Wily (up to date as of April 3rd).

I was able to rescan the library completely. Exit Banshee. Restart Banshee without a long freeze.

@Chow Loong Jin, are you able to push this fix uptream? Should it go to Debian or to Gnome/Banshee?

Revision history for this message
Chow Loong Jin (hyperair) wrote : Re: [Bug 1534971] Re: banshee freezes on start

On Sun, Apr 03, 2016 at 07:11:20PM -0000, Francois Noel wrote:
> I tested the patch and it fixes the problem on Wily (up to date as of
> April 3rd).
>
> I was able to rescan the library completely. Exit Banshee. Restart
> Banshee without a long freeze.
>
> @Chow Loong Jin, are you able to push this fix uptream? Should it go to
> Debian or to Gnome/Banshee?

It should go into Banshee upstream. For the time being, I'll upload this patch
into our releases in Debian and Ubuntu. Thanks for testing.

  affects ubuntu/banshee
  status inprogress

--
Kind regards,
Loong Jin

Changed in banshee (Ubuntu):
status: Incomplete → In Progress
Revision history for this message
Chow Loong Jin (hyperair) wrote :

On Tue, Apr 05, 2016 at 09:24:55AM +0800, Chow Loon
g Jin wrote:
> On Sun, Apr 03, 2016 at 07:11:20PM -0000, Francois Noel wrote:
> > I tested the patch and it fixes the problem on Wily (up to date as of
> > April 3rd).
> >
> > I was able to rescan the library completely. Exit Banshee. Restart
> > Banshee without a long freeze.
> >
> > @Chow Loong Jin, are you able to push this fix uptream? Should it go to
> > Debian or to Gnome/Banshee?
>
> It should go into Banshee upstream. For the time being, I'll upload this patch
> into our releases in Debian and Ubuntu. Thanks for testing.
>
> affects ubuntu/banshee
> status inprogress

By the way, wily is supposed to have sqlite 3.8.x. Are you running a newer
sqlite?

--
Kind regards,
Loong Jin

Changed in banshee (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package banshee - 2.9.0+really2.6.2-7ubuntu1

---------------
banshee (2.9.0+really2.6.2-7ubuntu1) xenial; urgency=medium

  * Merge from Debian, remaining changes:
    - Enable and recommend SoundMenu and Disable NotificationArea by default
    - Disable boo and karma extensions
    - Move desktop file for Meego UI to /usr/share/une/applications
    - [ccbcbbd] Make Banshee translatable in Launchpad
    - [2094ee5] Bump libgpod build-dep version to 0.8.2-7~
    - [a7156c0] Filter out libgpod-cil-dev versions built against gtk#3
    - [e7c634d] Update dversionmangle for extracting +really version out
    - [b5f10d6] Go back to dbus# 1.0 ABI.
  * Also brings in updated SQLite regression fix from Debian (LP: #1534971)

 -- Chow Loong Jin <email address hidden> Tue, 05 Apr 2016 09:43:17 +0800

Changed in banshee (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Francois Noel (kranky-franky) wrote :

In response to #11, as far as I know I have the default sqlite3 version. 3.11

$ dpkg -l | grep sqlite
ii libmono-sqlite4.0-cil 4.2.1.102+dfsg2-5ubuntu1 all Mono Sqlite library (for CLI 4.0)
ii libqt5sql5-sqlite:amd64 5.5.1+dfsg-16ubuntu1 amd64 Qt 5 SQLite 3 database driver
ii libsqlite3-0:amd64 3.11.0-1ubuntu1 amd64 SQLite 3 shared library
ii libsqlite3-dev:amd64 3.11.0-1ubuntu1 amd64 SQLite 3 development files

The CLI is package sqlite3 and also 3.11 but it's not installed on my system.

Revision history for this message
Francois Noel (kranky-franky) wrote :

I tested the release and it's fixes the reported problem. No more freezes on start.

Revision history for this message
Chow Loong Jin (hyperair) wrote :

Looks like you're on Xenial, not Wily.

Revision history for this message
Chow Loong Jin (hyperair) wrote :

Thanks for testing.

Revision history for this message
Andrea Amoroso (heiko81) wrote :

I can confirm that on 16.04 the problem is fixed. Banshee opens and works correctly.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.