banshee stops respondiing during media import

Bug #1533480 reported by krishnan sampath on 2016-01-13
218
This bug affects 49 people
Affects Status Importance Assigned to Milestone
banshee (Ubuntu)
Medium
Unassigned

Bug Description

Trying to import media to banshee in ubuntu 16.04 freezes banshee. Import works fine in rhythmbox. Problem only with banshee

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.3.0-5-generic 4.3.0-5.16
ProcVersionSignature: Ubuntu 4.3.0-5.16-generic 4.3.3
Uname: Linux 4.3.0-5-generic x86_64
ApportVersion: 2.19.3-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: krishnan 1972 F.... pulseaudio
 /dev/snd/controlC0: krishnan 1972 F.... pulseaudio
Date: Wed Jan 13 10:20:16 2016
HibernationDevice: RESUME=UUID=1f4f89ff-6e3c-4610-8450-a25509f5b5c5
InstallationDate: Installed on 2015-12-26 (17 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151209)
MachineType: LENOVO INVALID
ProcFB:
 0 radeondrmfb
 1 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.3.0-5-generic.efi.signed root=UUID=0bf37a84-dc7d-4bd4-999a-f8df2baffc39 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.3.0-5-generic N/A
 linux-backports-modules-4.3.0-5-generic N/A
 linux-firmware 1.155
SourcePackage: linux
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/23/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: 83CN12WW(V1.01)
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Lenovo G505s
dmi.board.vendor: LENOVO
dmi.board.version: 00000000Not Defined
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo G505s
dmi.modalias: dmi:bvnLENOVO:bvr83CN12WW(V1.01):bd04/23/2013:svnLENOVO:pnINVALID:pvrLenovoG505s:rvnLENOVO:rnLenovoG505s:rvr00000000NotDefined:cvnLENOVO:ct10:cvrLenovoG505s:
dmi.product.name: INVALID
dmi.product.version: Lenovo G505s
dmi.sys.vendor: LENOVO

krishnan sampath (tskrishnan) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in banshee (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
no longer affects: linux (Ubuntu)
Jacob (dead-feminine) wrote :

Confirmed. Ubuntu 16.04 Beta 2. Banshee freezes and hangs when trying to import a folder from any given drive.

Chow Loong Jin (hyperair) wrote :

Could you upload the log directly after reproducing this bug please? Here are instructions: http://banshee.fm/contribute/file-bugs/

Changed in banshee (Ubuntu):
status: Confirmed → Incomplete
krishnan sampath (tskrishnan) wrote :

https://bugzilla.gnome.org/show_bug.cgi?id=764854

Bug report filed with bugzilla and log attached alongwith that bug report.
Sorry for the delay. Had problem with my broadband connection.

ThePierrasse (thepierrasse) wrote :

Bug still present on final Ubuntu 16.04 release

Kirill Kabardin (kkabardin) wrote :

I think that "eMusic Import" extension is main suspect for this bug. I disabled it and the bug was gone.

dirkd (dirk-dierickx) wrote :

disabling eMusic plugin did nothing for me, import still not working.
even the library update is broken, so you can't put music in your library manually and then rescan.

EdwardClay (eclay) wrote :

disabling the eMusic plugin didn't fix this issue for me either.

EdwardClay (eclay) wrote :

But disabling all extensions/plugins except for those for apple, mass storage and MTP devices did fix this problem for me. Not sure which plugin fixed it for me but I don't need any other enabled at this moment.

krishnan sampath (tskrishnan) wrote :

Enabling the library watcher extension makes for a temporary workaround. The problem exists only on manual import. Hope this helps. :)

ThePierrasse (thepierrasse) wrote :

Found the trick! Just disable the "Podcasts" plugin and everything will be good ;)

Joe Carey (joecarey) wrote :

Disabled eMusic plugin... well, it doesn't freeze outright anymore but it scans and comes up with nothing. Also, disabling the podcasts plugin is no good, I need my podcasts :)

Joe Carey (joecarey) wrote :

Re-enabled the eMusic bit, disabled podcasts... scan successful.
So, that seems to have been the problem. After it's all imported, I'm going to re-enable podcasts and see how goes.

Joe Carey (joecarey) wrote :

Works fine with podcasts either enabled or disabled, but with podcasts enabled, can't subscribe to any podcasts. And naturally you can't even try to subscribe if it's disabled.

Luis (soyluisgallego) wrote :

Was having this issue, disabled podcasts and was able to import perfectly fine. Enabled it again and can still import correctly.

Heimekin (heime) wrote :

Disabling the podcast plugin also worked for me.

jimm (jimm1442) wrote :

Disabling the podcast plugin got me past the 'Import Media' file browser dialog, but then from the main window, Banshee was just "Scanning for media" indefinitely. Tried importing by files, folders, and m3u. Disabling all the extensions finally allowed me to import.

MINAS LAMPROU (mlamprou) wrote :

Disabling the "eMusic Import" worked for me also.

jasonubuntu (jasonts2000) wrote :

Disabling "Podcast" extension worked well! Thanks guys.

Cornelia Xaos (cornelia-xaos) wrote :

I should note disabling the extensions / activating Library Watcher failed for me... however, I noticed a quirk with importing that might be linked to the problem. The first time I tried to import I was attempting to import the `~/Music` directory directly. This caused a crash. The second time, after restarting banshee, I attempted to import the `~/Music` directory implicitly (as in, it was displaying the contents of the directory in the import window, but no folder was selected when I pressed Import). This would produce the infinite scanning directories bug.

When I selected all my folders within the `~/Music` directory and pressed Import the import was performed successfully.

pawug2007 (pawug2007) on 2016-05-25
Changed in banshee (Ubuntu):
status: Incomplete → Confirmed
Fixerdave (fixerdave) wrote :

probably related to Bug #1489419

crash due to too many open files.

Can you tell me how to disable the podcast plugin? I'm new to Ubuntu and my searches don't reveal any procedure!!

Kumaran A (lijikumaran) wrote :

This is still happening now. The app simply freezes and refuses to respond after clicking on "Import" button.

Kumaran A (lijikumaran) wrote :

Tested the same app on a different flavor of Ubuntu (Linux Mint 14); the banshee version that was included with Linux Mint works like charm. It seems that the latest version has this issue.

ThePierrasse (thepierrasse) wrote :

To disable the podcast plugin you have to go to Edit>Preferences>Extensions and then in the top section named "Core" . There, you just have to uncheck the line which says "Podcasts".

When I enabled the Library Watcher, Banshee hung. After that, every time I opened Banshee, it hung. I used the nuclear option to recover:

sudo apt-get purge banshee
rm -rf ~/.config/banshee-1/
sudo apt-get install banshee

Disabling the "Podcast" extension worked for me. Yay!

gwarah (lhmp1967) wrote :

I've followed TrombaMarina and also works fine

adavanzo (adavanzo) wrote :

For me worked just unchecking "eMusic Import"

Frann (francois-collette) wrote :

Also affected (Ubuntu MATE 16.04 - Banshee 2.9.0+really2.6.2-7ubuntu2) and unchecking the Podcast plugin is not an option since I need Banshee to import podcasts on an iPod (worked fine in Ubuntu 14.04).

Banshee freezes upon trying to:
- scan music library
- import music by another mean (right-click > import, drag & drop from window manager)
- check the automatic library scan plugin

Aside from that, Banshee fails to:
- subscribe to any podcast (nothing happens when submitting a podcast feed url)
- find any content on my iPod (the iPod shows up, displays correct amount of used/free space, but the library appears empty)

Adam (ateator) wrote :

I do not have any super valuable input but FYI I'm on a fresh install of Ubuntu MATE 16.04 and downloaded Banshee from App-Grid. I had the problem described, and could not add music files or folders to my library. After reading this forum, I went through the extensions settings and disabled everything I thought I wouldn't need (I'm only using Banshee to play files that are saved on my hard drive), including eMusic and the Apple device support. I did not disable USB Storage Media Player Support or MTP Media Player Support. These changes corrected the problem, without a restart of Banshee. Hope this helps someone.

I can confirm that disabling the plugins solves the problem, but I don't know which one is causing the problem.

Workaround that worked for me is to download banshee from here http://packages.linuxmint.com/list.php?release=Sarah and install with gdebi, then set package on hold "sudo apt-mark hold banshee".

That prevents banshee from updating when using apt upgrade or apt dist-upgrade and then I get no problems with banshee.

Johannes Konow (itix) wrote :

I have tried various scenarios... First I tried with eMusic only disabled and that didn't work for me. Then I tried disabling all the suggested extensions and that made the import seamless. Then I tried to purge the settings folder for banshee and reinstalled it and tried again with only podcast disabled and it does work... kinda. It crashed on the first import halfway through and the second one worked but no progress bar.

Something very fishy is going on here.

Agreed with Comment #12, disabling pod-casts on Edit > Preferences > Extensions > Pod-casts (disable) fixes the bug.

draxbear (drax) wrote :

Another vote for disabling pod-casts fixing this issue. Ubuntu 16.04.1 & Banshee 2.6.2

Steven Goodgrove (j-steven) wrote :

+1 disabling podcast plugin.

Disabling podcast plugin worked for me too.

acp (caput-acp) wrote :

+1 for podcast solution. Great work.

Steve S (spamsteve04) wrote :

+1 disable podcast Extension worked in my case

Noah Swartz (swartzcr-b) wrote :

Admittedly I'm on Debian, but no amount of turning off plugins mitigated this for me

schuko24 (gerd-saenger) wrote :

Banshee running on zesty, 22k tracks, disabled all extensions, still crashing on importing files or folders. Problem was not present under yakkety.

FoGia (fogiafour) wrote :

Same problem on zesty, disabling plugins does not solve it.

Toon (toon-weyens) wrote :

+1 disabling podcast plugin on Ubuntu 16.04 LTS, Dell xps 13 9360 (Banshee 2.6.2).

Misur Braford (misurbraford) wrote :

I also had this problem running banshee 2.6.2 on Kubuntu 17.04, as I wanted to clean out my system (fresh install of Kubuntu). Disabling plugins, importing single files at a time, or any other solution mentioned here did not solve the problem. How I imported my cleaned-out library was by doing the following:

1) Preferences -> Source Specific: set Music Folder to my actual music folder (which is on another partition)
2) Preferences -> Extensions: disable Library Watcher and enable it again. It started scanning the library and crashed banshee after a couple of seconds.
3) Close banshee and re-open it. Now it showed a couple of albums (those which it was able to scan before crashing, I assume)
4) Tools -> rescan Music Library

Now it cleanly scanned all files in my library!

I had 'Copy files to media folder when importing' and 'Update file and folder names' disabled.
Library Watcher and BPM Detection are the only extensions I have enabled.

Note: I am not at all capable of finding out how or why it crashed, or why this worked.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.