Banshee interface unresponsive after upgrade to 15.04

Bug #1447956 reported by John Aivalis on 2015-04-24
134
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Banshee
Fix Released
High
banshee (Debian)
Fix Released
Unknown
banshee (Ubuntu)
High
Unassigned
Vivid
Undecided
Unassigned

Bug Description

I upgraded to the newest version yesterday. Some times it ran yesterday but i had some issues too. Today I cannot run it at all. When I start it from terminal I get amongst others:

[Info 10:07:03.122] All services are started 0.997291

But all I get is an unresponsive white window. I will attach the entire terminal output bellow.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: banshee 2.9.0+really2.6.2-2ubuntu4
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic x86_64
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Apr 24 10:10:53 2015
ExecutablePath: /usr/lib/banshee/Banshee.exe
InstallationDate: Installed on 2013-12-29 (480 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
InterpreterPath: /usr/bin/mono-sgen
SourcePackage: banshee
UpgradeStatus: Upgraded to vivid on 2015-04-23 (0 days ago)

[Impact]
The SQLite performance regression has caused Banshee to hang on startup and become completely unusable.

[Test Case]
Launch banshee. See if it starts up correctly.

[Regression Potential]
Negligible -- it's hard to get any worse than completely unusable.

[Other info]
The fix has been in Debian unstable for a couple of months now with no new related bugs.

John Aivalis (johnaivalis) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in banshee (Ubuntu):
status: New → Confirmed
Chow Loong Jin (hyperair) wrote :

Could you try running with "banshee --debug" instead?

Changed in banshee (Ubuntu):
importance: Undecided → High
John Doyle (jdubhghaill) wrote :

I appear to be having the same problem after the upgrade I think, the unresponsive white window, though banshee does start eventually after about 15 minutes or so. I'll attach the debug output, it appears that banshee is taking an awful long time to run some queries against it's database.

John Doyle (jdubhghaill) wrote :

Might be worth mentioning that banshee runs at 100% cpu for the entire time it is starting up and afterwards.

Mondane (mondane-woodworker) wrote :

Searching for a bug report, I came across this discussion: http://comments.gmane.org/gmane.comp.gnome.mono.banshee/14236 in which an sqllite3 bug is mentioned: https://bugs.launchpad.net/ubuntu/+source/banshee/+bug/612370

Banshee and/or sqllite should be updated.

vs49688 (vs49688) wrote :

I tried to compile 2.9.1 yesterday, and the bug was still there, but it seems to be fixed in the latest git (7ea21d7 at time of compilation). Banshee loads and plays music, but then there's a whole slew of other issues (a story for another bug report).

Chow Loong Jin (hyperair) wrote :

Could you try bisecting the fix out?

schuko24 (gerd-saenger) wrote :

my workaround on vivid:

download 2.6.2-3

https://packages.debian.org/sid/amd64/banshee/download

completely deinstall 2.9.*** banshee via synaptic.
Doubleclick downloaded 2.6.2-3 and install with Softwarecenter.

Everything works as it should. Hope it works for you too.

Heineken (lars-heineken) wrote :

Downgrading to 2.6.2-3 according to above instruction works fine.
Thank you very much for the information.

On Sat, May 23, 2015 at 09:55:42AM -0000, Heineken wrote:
> Downgrading to 2.6.2-3 according to above instruction works fine.
> Thank you very much for the information.

Oh right, I forgot to merge a patch for an sqlite regression that happened in
Debian. Whoopsie.

--
Kind regards,
Loong Jin

Changed in banshee (Debian):
status: Unknown → Fix Released
Chow Loong Jin (hyperair) wrote :

The fix has been uploaded to wily-proposed. Please test if you're on that release.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package banshee - 2.9.0+really2.6.2-3ubuntu1

---------------
banshee (2.9.0+really2.6.2-3ubuntu1) wily; urgency=low

  * Merge from Debian, remaining changes:
    - Enable and recommend SoundMenu and Disable NotificationArea by default
    - Disable boo and karma extensions
    - Move desktop file for Meego UI to /usr/share/une/applications
    - [ccbcbbd] Make Banshee translatable in Launchpad
    - [2094ee5] Bump libgpod build-dep version to 0.8.2-7~
    - [a7156c0] Filter out libgpod-cil-dev versions built against gtk#3
    - [e7c634d] Update dversionmangle for extracting +really version out
    - [b5f10d6] Go back to dbus# 1.0 ABI.
  * Also brings in SQLite regression fix from Debian (LP: #1447956)

 -- Chow Loong Jin <email address hidden> Mon, 25 May 2015 11:20:26 +0800

Changed in banshee (Ubuntu):
status: Confirmed → Fix Released

Will this fix be available for the current release of Ubuntu, Vivid Vervet (15.04)? I see it has been released for Wily which I guess is 15.10, not yet released.

Alternatively, is there a way of downloading the fixed package 2.9.0+really2.6.2-3ubuntu1 into Vivid/15.04? Otherwise, it can't be said to be fixed in the currently available Ubuntu...

Chow Loong Jin (hyperair) wrote :

On Wed, May 27, 2015 at 06:03:45PM -0000, Simon Lambourn wrote:
> Will this fix be available for the current release of Ubuntu, Vivid
> Vervet (15.04)? I see it has been released for Wily which I guess is
> 15.10, not yet released.
>
> Alternatively, is there a way of downloading the fixed package
> 2.9.0+really2.6.2-3ubuntu1 into Vivid/15.04? Otherwise, it can't be
> said to be fixed in the currently available Ubuntu...

Yes, I'll upload it to Vivid as well. It just needs to enter Wily first, because
Stable Release Updates cannot be uploaded before the fix is confirmed to work on
the current development release.

--
Kind regards,
Loong Jin

Thank you! (I won't put this on Launchpad...)
Simon

On 27/05/15 20:13, Chow Loong Jin wrote:
> On Wed, May 27, 2015 at 06:03:45PM -0000, Simon Lambourn wrote:
>> Will this fix be available for the current release of Ubuntu, Vivid
>> Vervet (15.04)? I see it has been released for Wily which I guess is
>> 15.10, not yet released.
>>
>> Alternatively, is there a way of downloading the fixed package
>> 2.9.0+really2.6.2-3ubuntu1 into Vivid/15.04? Otherwise, it can't be
>> said to be fixed in the currently available Ubuntu...
> Yes, I'll upload it to Vivid as well. It just needs to enter Wily first, because
> Stable Release Updates cannot be uploaded before the fix is confirmed to work on
> the current development release.
>

Chow Loong Jin (hyperair) wrote :

On Wed, May 27, 2015 at 07:24:15PM -0000, Simon Lambourn wrote:
> Thank you! (I won't put this on Launchpad...)
> Simon

You're welcome. Turns out I didn't realize that the package had already been
accepted into wily. I've made an upload to vivid, which should show up in
vivid-proposed soon. Please test it when it shows up.

--
Kind regards,
Loong Jin

description: updated
description: updated
Nico (nico-rdo) wrote :

Any ETA for vivid-proposed or vivid-updates? Thanks!

Chow Loong Jin (hyperair) wrote :

No idea. Just wait for it.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in banshee (Ubuntu Vivid):
status: New → Confirmed

Hello John, or anyone else affected,

Accepted banshee into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/banshee/2.9.0+really2.6.2-2ubuntu5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in banshee (Ubuntu Vivid):
status: Confirmed → Fix Committed
tags: added: verification-needed

I tried to install the updated package from vivid-proposed but apt-get was going to remove loads of important packages as part of the upgrade, so I didn't go ahead with the installation. Is there something wrong with the package dependencies, or is it me??

I followed the instructions in https://wiki.ubuntu.com/Testing/EnableProposed to add vivid-proposed and allow selective installation from it. trying apt-get upgrade -s found no packages for upgrade

But when I did apt-get install banshee/vivid-proposed, I got the following output:

$ sudo apt-get install banshee/vivid-proposed
Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version '2.9.0+really2.6.2-2ubuntu5' (Ubuntu:15.04/vivid-proposed [amd64]) for 'banshee'
Selected version '2.44.1-1ubuntu1' (Ubuntu:15.04/vivid-proposed [amd64]) for 'libglib2.0-0' because of 'banshee'
Selected version '2.9.0+really2.6.2-2ubuntu5' (Ubuntu:15.04/vivid-proposed [amd64]) for 'banshee-extension-soundmenu' because of 'banshee'
The following packages were automatically installed and are no longer required:
  app-install-data apt-xapian-index gir1.2-gmenu-3.0 laptop-detect
  oneconf-common python-characteristic python-cups python-debtagshw
  python-dirspec python-httplib2 python-idna python-oneconf python-openssl
  python-pam python-piston-mini-client python-pyasn1 python-pyasn1-modules
  python-serial python-service-identity python-twisted-bin python-twisted-core
  python-twisted-web python-zope.interface python3-oneconf
  python3-piston-mini-client software-center-aptdaemon-plugins
  ubuntuone-client-data
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  banshee-extension-soundmenu libglib2.0-0
Suggested packages:
  gstreamer1.0-ffmpeg banshee-dbg
The following packages will be REMOVED
  libatk-bridge2.0-dev libatk1.0-dev libatspi2.0-dev libcairo2-dev
  libdbus-glib-1-dev libgdk-pixbuf2.0-dev libglade2-dev libglib2.0-bin
  libglib2.0-dev libgtk-3-dev libgtk2.0-dev libpango1.0-dev lightdm oneconf
  python-gobject-2-dev python-gtk2-dev python-ubuntu-sso-client
  software-center ubuntu-desktop ubuntu-settings ubuntu-sso-client
  ubuntu-sso-client-qt unity unity-tweak-tool
The following packages will be upgraded:
  banshee banshee-extension-soundmenu libglib2.0-0
3 to upgrade, 0 to newly install, 24 to remove and 0 not to upgrade.
Need to get 3,849 kB of archives.
After this operation, 70.7 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.

Without the reference to vivid-proposed, apt-get autoremove shows 0 to remove.

Forage (forage) wrote :

Updating Banshee from vivid-proposed fixed the issue for me.

It still takes Banshee a bit to load the GUI, leaving you with a blank windows for a few (+/-5) seconds when launching the application, but there is no high CPU load during boot nor when running any longer.

Heineken (lars-heineken) on 2015-06-04
tags: added: verification-done
removed: verification-needed

New version in vivid-proposed (2.9.0+really2.6.2-2ubuntu5) fixed the issue for me too on Ubuntu 15.04.

I have been using it for 4 hours now, I have around 25000 songs, 15 smart playlists, 10 playlists. Everything i tried work well, especially the SQLite performance regression is fixed (Using SQLite 3.8.7.4). I didn't notice any slow startup. I recently cleaned my database, making sure that there were no duplicates in playlists and no circular reference between smart playlists.

Many thanks!

Help please! I'm still trying to install the proposed fix from vivid-proposed. It has clearly worked for others so I must be getting the command wrong. My 15.04 system is a clean install of 14.10 & then recently updated, so it should be straightforward.

When I try apt-get install banshee/vivid-proposed, it proposes to remove loads of packages including unity and software-center (see above). I didn't continue with this.

When I try apt-get install banshee=2.9.0+really2.6.2-2ubuntu5 I get:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 banshee : Depends: libglib2.0-0 (>= 2.44.1) but 2.44.0-1ubuntu3 is to be installed
           Recommends: banshee-extension-soundmenu (= 2.9.0+really2.6.2-2ubuntu5) but 2.9.0+really2.6.2-2ubuntu4 is to be installed
E: Unable to correct problems, you have held broken packages.

It seems you can't combine package=version and package/target-release, as apt-get install banshee=2.9.0+really2.6.2-2ubuntu5/vivid-proposed doesn't find the package. I can see the package is available using apt-cache policy banshee.

Clearly I'm doing it wrong, but I can't work out what is wrong .. .sorry - can anyone advise what the correct command to install the fix should be please?

Chow Loong Jin (hyperair) wrote :

There are two approaches you can take for this:

1. Wait for it to enter vivd-updates. Now that it's been confirmed, this should happen soon.
2. Forcibly install it from vivid-proposed together with the libglib2.0-0 updates that it wants.

For #2, the command in question should be something along the lines of "sudo apt-get install banshee/vivid-proposed libglib2.0-0/vivid-proposed libglib2.0-bin/vivid-proposed". I haven't tested this command, but I think it should work.

Otherwise, you could try to disable the pin that causes vivid-proposed to get a lower pin-priority in apt. This will cause a flood of -proposed changes (which may or may not introduce regressions), so I advise against this approach.

Sebastian Gebhard (sege) wrote :

Installing the package from vivid-proposed fixed the problem for me as well!

Michael (zweetsmoel) wrote :

Installed the update from vivid-proposed and it seems to work well. I'm listening to banshee for several hours now and the terrible GUI delays & unresponsiveness seem to have been fixed on ubuntu 15.04. Thank you very much for taking care of this!
Regards

Changed in banshee:
importance: Undecided → Unknown
status: New → Unknown
Changed in banshee:
importance: Unknown → High
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package banshee - 2.9.0+really2.6.2-2ubuntu5

---------------
banshee (2.9.0+really2.6.2-2ubuntu5) vivid; urgency=medium

  * [bb4745b] Import upstream patch to fix SQLite performance regression.
    (LP: #1447956, Closes: #766560)

 -- Chow Loong Jin <email address hidden> Thu, 28 May 2015 03:22:45 +0800

Changed in banshee (Ubuntu Vivid):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for banshee has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in banshee:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.