Locked smuxi launcher icon does not indicate smuxi running status

Bug #999820 reported by Stuart Langridge on 2012-05-15
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BAMF
High
Marco Trevisan (Treviño)
Unity
Fix Released
High
Marco Trevisan (Treviño)
5.0
Fix Released
High
Marco Trevisan (Treviño)
bamf (Ubuntu)
High
Marco Trevisan (Treviño)
Precise
High
Unassigned
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Precise
High
Unassigned

Bug Description

[Test Case]
1. Install smuxi from Software Centre.
   -> Verify that it has added a launcher icon.
2. Start smuxi from the launcher icon.
   -> Verify the launcher icon shows the left and right side triangles.
3. Switch to another application.
4. Switch back to smuxi by clicking its launcher icon.
   -> Verify that the original smuxi instance is refocused (a new instance should not be created).

[Regression Potential]
No regression potential.

Original description:
1. Install smuxi from Software Centre
2. Observe that it has added a launcher icon
3. Click the launcher icon to start smuxi
4. Switch to another application
5. Switch back to smuxi by clicking its launcher icon
6. Quit smuxi (with its File > Quit menu item; closing the window does not quit the app)
7. Unlock the smuxi icon from the launcher
8. Launch smuxi from the Dash
9. Switch to another application
10. Switch back to smuxi by clicking its launcher icon
11. Lock the smuxi icon to the launcher
12. Quit smuxi
13. Click the locked launcher icon to start smuxi
14. Switch to another application
15. Switch back to smuxi by clicking its launcher icon

What happens:

3. The smuxi launcher icon does not have the triangle next to it to indicate that it is running
5. We do not switch to an existing smuxi; instead, a new one is launched!
8. The launcher icon *does* get the triangle when smuxi is launched from the dash
10. Works fine
13. The smuxi launcher icon does not have the triangle next to it to indicate that it is running
15. We do not switch to an existing smuxi; instead, a new one is launched!

What should happen:

3, 13: as 8
5, 15: as 10

So, the launcher icon does not seem to correctly detect that smuxi is launched, if it is launched *from* a launcher icon. It does work fine if smuxi is launched from the dash.

Note also that if the launcher does not detect that smuxi is running (and so it does not show the triangle), then Smuxi also does not show up in the Alt-Tab switcher. This makes it almost impossible to switch back to Smuxi.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: bamfdaemon 0.2.114-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-u300acpifix1-generic 3.2.14
Uname: Linux 3.2.0-24.37-u300acpifix1-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
CheckboxSubmission: 4d186c1dd89d3ba4cb89f5ee55713686
CheckboxSystem: bb422ca46d02494cdbc459927a98bc2f
Date: Tue May 15 18:01:51 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111211)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: bamf
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Stuart Langridge (sil) wrote :
Changed in bamf (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in bamf (Ubuntu):
status: New → Confirmed
Changed in bamf:
status: New → Confirmed
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in bamf:
status: Confirmed → Invalid
Changed in bamf (Ubuntu):
status: Confirmed → Invalid
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
milestone: none → 5.14.0
status: New → In Progress
Changed in unity (Ubuntu):
status: New → In Progress
Changed in unity:
importance: Undecided → High
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in bamf:
status: Invalid → In Progress
importance: Undecided → High
Changed in bamf (Ubuntu):
status: Invalid → Fix Committed
Changed in bamf (Ubuntu):
importance: Undecided → High
Changed in unity (Ubuntu Precise):
importance: Undecided → High
Changed in bamf (Ubuntu Precise):
importance: Undecided → High
status: New → In Progress
Changed in unity (Ubuntu Precise):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.12-0ubuntu2

---------------
unity (5.12-0ubuntu2) quantal; urgency=low

  * Cherry pick upstream fixes.
    - Fix UnityViewWindow background when blur is disabled (LP: #989291)
    - App icon on the Unity Launcher lost track of running
      instance (LP: #772063)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running
      status (LP: #999820)
    - Fix dash search field hidden by tooltips (LP: #978030)
    - Launcher is silent to screen reader users (LP: #949448)
    - Fix 3D apps running much slower under Unity (LP: #987304)
    - Reduced number of calls to ResultViewGrid::QueueDraw
    - Reduced number of calls to BGHash::RefreshColor
 -- Alan Pope <email address hidden> Wed, 23 May 2012 18:10:49 +0100

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.118-0ubuntu1

---------------
bamf (0.2.118-0ubuntu1) quantal; urgency=low

  [ Didier Roche ]
  * New upstream release. (0.2.116)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - unity confused with chrome/chromium web apps (LP: #692462)
    - BamfView's dispose() method doesn't invoke the superclass' dispose()
      (LP: #986888)
  * debian/control:
    - remove Multi-Arch: same for the -dbg package
      (Closes: #669980, #658057)

  [ Alan Pope ]
  * New upstream release.
    - Unity crashed in bamf_application_on_window_removed (LP: #1000577)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - the RunningApplicationsChanged signal is no longer emitted when an
      application is closed since r460 (LP: #989551)
 -- Alan Pope <email address hidden> Wed, 23 May 2012 09:10:08 +0100

Changed in bamf (Ubuntu):
status: Fix Committed → Fix Released
Changed in bamf (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in bamf:
status: In Progress → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed

Hello Stuart, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Steve Langasek (vorlon) wrote :

Hello Stuart, or anyone else affected,

Accepted bamf into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Sebastien Bacher (seb128) wrote :

Could you test the candidate update, it will not be deployed as a stable update until the fixes are confirmed to work and that's one of the bugs that's remaining as verification-needed

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.12-0ubuntu1.1

---------------
unity (5.12-0ubuntu1.1) precise-proposed; urgency=low

  * Cherry pick upstream fixes.
    - Fix UnityViewWindow background when blur is disabled (LP: #989291)
    - App icon on the Unity Launcher lost track of running
      instance (LP: #772063)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running
      status (LP: #999820)
    - Fix dash search field hidden by tooltips (LP: #978030)
    - Launcher is silent to screen reader users (LP: #949448)
    - Fix 3D apps running much slower under Unity (LP: #987304)
    - Reduced number of calls to ResultViewGrid::QueueDraw
    - Reduced number of calls to BGHash::RefreshColor
 -- Alan Pope <email address hidden> Wed, 23 May 2012 18:10:49 +0100

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.118-0ubuntu0.1

---------------
bamf (0.2.118-0ubuntu0.1) precise-proposed; urgency=low

  [ Didier Roche ]
  * New upstream release. (0.2.116)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - unity confused with chrome/chromium web apps (LP: #692462)
    - BamfView's dispose() method doesn't invoke the superclass' dispose()
      (LP: #986888)
  * debian/control:
    - remove Multi-Arch: same for the -dbg package
      (Closes: #669980, #658057)

  [ Alan Pope ]
  * New upstream release.
    - Unity crashed in bamf_application_on_window_removed (LP: #1000577)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - the RunningApplicationsChanged signal is no longer emitted when an
      application is closed since r460 (LP: #989551)
 -- Alan Pope <email address hidden> Wed, 23 May 2012 09:10:08 +0100

Changed in bamf (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
milestone: 5.14.0 → 6.0
Didier Roche (didrocks) on 2012-07-10
Changed in unity:
status: Fix Committed → Fix Released
description: updated
Adolfo Jayme (fitojb) on 2014-01-11
no longer affects: bamf (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers