the RunningApplicationsChanged signal is no longer emitted when an application is closed since r460

Bug #989551 reported by Sebastien Bacher on 2012-04-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BAMF
High
Marco Trevisan (Treviño)
bamf (Ubuntu)
High
Marco Trevisan (Treviño)
Precise
High
Marco Trevisan (Treviño)

Bug Description

With the SRU candidate the unity "recently used" don't update in real time as they should, we tracked it down to the bamf udpate which stopped sending closed signals

Related branches

Changed in bamf:
importance: Undecided → High
Changed in bamf (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in bamf:
status: New → Confirmed
Changed in bamf (Ubuntu Precise):
importance: Undecided → High
status: New → Triaged
Changed in bamf:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Michal Hruby (mhr3) wrote :

To be more specific - the RunningApplicationsChanged signal is no longer emitted when an application is closed. Reverting r460 from lp:bamf fixes it.

summary: - stopped sending closed signals
+ the RunningApplicationsChanged signal is no longer emitted when an
+ application is closed since r460
Changed in bamf (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in bamf (Ubuntu Precise):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in bamf:
milestone: none → 0.2.118
status: Confirmed → In Progress
Changed in bamf:
status: In Progress → Fix Committed
Changed in bamf (Ubuntu):
status: Triaged → In Progress
Changed in bamf (Ubuntu Precise):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.118-0ubuntu1

---------------
bamf (0.2.118-0ubuntu1) quantal; urgency=low

  [ Didier Roche ]
  * New upstream release. (0.2.116)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - unity confused with chrome/chromium web apps (LP: #692462)
    - BamfView's dispose() method doesn't invoke the superclass' dispose()
      (LP: #986888)
  * debian/control:
    - remove Multi-Arch: same for the -dbg package
      (Closes: #669980, #658057)

  [ Alan Pope ]
  * New upstream release.
    - Unity crashed in bamf_application_on_window_removed (LP: #1000577)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - the RunningApplicationsChanged signal is no longer emitted when an
      application is closed since r460 (LP: #989551)
 -- Alan Pope <email address hidden> Wed, 23 May 2012 09:10:08 +0100

Changed in bamf (Ubuntu):
status: In Progress → Fix Released
Changed in bamf (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in bamf:
status: Fix Committed → Fix Released

Hello Sebastien, or anyone else affected,

Accepted bamf into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

The recently used is correctly updated with the SRU candidate indeed!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.118-0ubuntu0.1

---------------
bamf (0.2.118-0ubuntu0.1) precise-proposed; urgency=low

  [ Didier Roche ]
  * New upstream release. (0.2.116)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - unity confused with chrome/chromium web apps (LP: #692462)
    - BamfView's dispose() method doesn't invoke the superclass' dispose()
      (LP: #986888)
  * debian/control:
    - remove Multi-Arch: same for the -dbg package
      (Closes: #669980, #658057)

  [ Alan Pope ]
  * New upstream release.
    - Unity crashed in bamf_application_on_window_removed (LP: #1000577)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - the RunningApplicationsChanged signal is no longer emitted when an
      application is closed since r460 (LP: #989551)
 -- Alan Pope <email address hidden> Wed, 23 May 2012 09:10:08 +0100

Changed in bamf (Ubuntu Precise):
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2014-01-11
no longer affects: bamf (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers