Spotify instance is not detected properly in the launcher

Bug #970796 reported by Marius B. Kotsbak on 2012-04-01
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Confirmed
Low
Unassigned
bamf (Ubuntu)
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

Closing the Sptify window, either from the X button or by right clicking in unity task bar at the left, leaves Spotify in the system tray (and below the sound indicator menu), and it seems like not running in the launcher. It tries to launch again if the launcher icon is pressed (but it now refuses to make two instances).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic-pae 3.2.13
Uname: Linux 3.2.0-21-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 2.0-0ubuntu2
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Sun Apr 1 14:29:37 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DpkgLog:

EcryptfsInUse: Yes
MachineType: GIGABYTE T1005
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-21-generic-pae root=UUID=f1d0446d-3ea3-46a7-9842-8773acca78e6 ro quiet splash i8042.noloop=1 vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/30/2010
dmi.bios.vendor: GIGABYTE
dmi.bios.version: GSBF05
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: T1005
dmi.board.vendor: GIGABYTE
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnGIGABYTE:bvrGSBF05:bd08/30/2010:svnGIGABYTE:pnT1005:pvrGSBF05:rvnGIGABYTE:rnT1005:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: T1005
dmi.product.version: GSBF05
dmi.sys.vendor: GIGABYTE
version.compiz: compiz 1:0.9.7.2-0ubuntu4
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu8
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Marius B. Kotsbak (mariusko) wrote :
Marius B. Kotsbak (mariusko) wrote :

Probably the same issue as bug #667050.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, that seems a spotify and not an unity issue though

Changed in unity (Ubuntu):
status: New → Invalid
importance: Undecided → Low
Changed in bamf (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Marius B. Kotsbak (mariusko) wrote :

Well, I think it is the exact same issue as with the Skype client. The only difference is that Sporify does not allow multiple instances to run.

Sebastien Bacher (seb128) wrote :

not sure what is the skype issue, but if spotify keeps playing when you close it it's a bug in spotify that it doesn't exit when being closed

Marius B. Kotsbak (mariusko) wrote :

Look at bug #970796. It continues to play since it has an icon in the systray, but disappears from the launcher when the window is closed.

Marius B. Kotsbak (mariusko) wrote :

Sorry, the bug referred to in comment #3.

Sebastien Bacher (seb128) wrote :

oh ok, yeah, the systray is not available under unity and applications should be fixed to handle that correctly rather than assuming there is one they can use

summary: - Spotify continues playing after window closed
+ Spotify instance is not detected properly in the launcher
Changed in bamf (Ubuntu):
status: Invalid → New
Changed in unity (Ubuntu):
status: Invalid → New
Marius B. Kotsbak (mariusko) wrote :

The Spotify icon is in the systray, so there must be one...

description: updated
Marius B. Kotsbak (mariusko) wrote :

See bug #967063 (not a duplicate). Maybe the current behavior is correct. But for new users that does not know Spotify is in the sound menu, it is probably confusing that the icon disappears in the launcher when the main window is closed.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Low
status: New → Confirmed
To post a comment you must log in.