LibreOfficeBase icon is blank

Bug #952129 reported by Sandra Farnedi on 2012-03-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bamf (Ubuntu)
Undecided
Unassigned
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using LibreOfficeBase but the laucher doesn't display the proper icon, just a generic blank one as shown in the attached screen-shot.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.4.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic-pae 3.2.9
Uname: Linux 3.2.0-18-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
CasperVersion: 1.307
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Sun Mar 11 11:25:20 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI Radeon Mobility X1400 [1002:7145] (prog-if 00 [VGA controller])
   Subsystem: Fujitsu Technology Solutions Device [1734:10b0]
LiveMediaBuild: Edubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120311)
MachineType: FUJITSU SIEMENS AMILO Pi 1556
ProcEnviron:
 TERM=xterm
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- debian-installer/language=it keyboard-configuration/layoutcode?=it
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/19/2007
dmi.bios.vendor: FUJITSU SIEMENS
dmi.bios.version: 1.25
dmi.board.name: AMILO Pi 1556
dmi.board.vendor: FUJITSU SIEMENS
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: FUJITSU SIEMENS
dmi.chassis.version: AMILO Pi 1556
dmi.modalias: dmi:bvnFUJITSUSIEMENS:bvr1.25:bd07/19/2007:svnFUJITSUSIEMENS:pnAMILOPi1556:pvrNotApplicable:rvnFUJITSUSIEMENS:rnAMILOPi1556:rvrNotApplicable:cvnFUJITSUSIEMENS:ct10:cvrAMILOPi1556:
dmi.product.name: AMILO Pi 1556
dmi.product.version: Not Applicable
dmi.sys.vendor: FUJITSU SIEMENS
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu5
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/952129

tags: added: iso-testing
Download full text (4.2 KiB)

I do not think it's the correct behaviour: I expect to have the
specific LibreOfficeBase icon when opening a data base, not the
generic one.
bye
sandra

2012/3/11 Fabio Marconi <email address hidden>:
> Hello sandra,
> That is the Libreoffice base icon.
> http://www.google.com/imgres?imgurl=http://wiki.documentfoundation.org/images/thumb/6/65/LibreOffice_icons_256.png/400px-LibreOffice_icons_256.png&imgrefurl=http://wiki.documentfoundation.org/Design/Whiteboards/LibreOffice_Initial_Icons&h=489&w=400&sz=68&tbnid=54hn6084TCeCfM:&tbnh=83&tbnw=68&prev=/search%3Fq%3Dlibreoffice%2Bicons%26tbm%3Disch%26tbo%3Du&zoom=1&q=libreoffice+icons&docid=cSTMFEDszUQxmM&sa=X&ei=uoBcT_maEJGUOoLe3YUN&ved=0CCoQ9QEwAA&dur=420
>
> The general icon is gray with a question mark inside
> Thanks
> Fabio
>
> ---
> Ubuntu Bug Squad volunteer triager
> http://wiki.ubuntu.com/BugSquad
>
> ** Package changed: unity (Ubuntu) => libreoffice (Ubuntu)
>
> ** Changed in: libreoffice (Ubuntu)
>       Status: New => Invalid
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/952129
>
> Title:
>  LibreOfficeBase icon is blank
>
> Status in “libreoffice” package in Ubuntu:
>  Invalid
>
> Bug description:
>  I'm using LibreOfficeBase but the laucher doesn't display the proper
>  icon, just a generic blank one as shown in the attached screen-shot.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 12.04
>  Package: unity 5.4.0-0ubuntu2
>  ProcVersionSignature: Ubuntu 3.2.0-18.28-generic-pae 3.2.9
>  Uname: Linux 3.2.0-18-generic-pae i686
>  .tmp.unity.support.test.0:
>
>  ApportVersion: 1.94.1-0ubuntu2
>  Architecture: i386
>  CasperVersion: 1.307
>  CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
>  CompositorRunning: compiz
>  Date: Sun Mar 11 11:25:20 2012
>  DistUpgraded: Fresh install
>  DistroCodename: precise
>  DistroVariant: ubuntu
>  GraphicsCard:
>   Advanced Micro Devices [AMD] nee ATI Radeon Mobility X1400 [1002:7145] (prog-if 00 [VGA controller])
>     Subsystem: Fujitsu Technology Solutions Device [1734:10b0]
>  LiveMediaBuild: Edubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120311)
>  MachineType: FUJITSU SIEMENS AMILO Pi 1556
>  ProcEnviron:
>   TERM=xterm
>   LANG=it_IT.UTF-8
>   SHELL=/bin/bash
>  ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- debian-installer/language=it keyboard-configuration/layoutcode?=it
>  SourcePackage: unity
>  UpgradeStatus: No upgrade log present (probably fresh install)
>  dmi.bios.date: 07/19/2007
>  dmi.bios.vendor: FUJITSU SIEMENS
>  dmi.bios.version: 1.25
>  dmi.board.name: AMILO Pi 1556
>  dmi.board.vendor: FUJITSU SIEMENS
>  dmi.board.version: Not Applicable
>  dmi.chassis.asset.tag: Not Applicable
>  dmi.chassis.type: 10
>  dmi.chassis.vendor: FUJITSU SIEMENS
>  dmi.chassis.version: AMILO Pi 1556
>  dmi.modalias: dmi:bvnFUJITSUSIEMENS:bvr1.25:bd07/19/2007:svnFUJITSUSIEMENS:pnAMILOPi1556...

Read more...

I attach a screen shot of the same situation in 11.10 environment

Changed in libreoffice (Ubuntu):
status: Invalid → Confirmed

Sandra Farnedi, please do not mark your own bugs Confirmed. For more on this please see: https://wiki.ubuntu.com/Bugs/Status

Changed in libreoffice (Ubuntu):
status: Confirmed → New
Fabio Marconi (fabiomarconi) wrote :

oops, sorry sandra
I misunderstood.
Bug reproduced and confirmed in Precise fully upgraded with libreoffice-base installed.
Thanks
Fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Paolo Rotolo (paolorotolo) wrote :

Hi,
I can confirm this bug on Ubuntu Precise with libreoffice 3.5.0 and Unity 5.4.0.

Regards,
Paolo

Confirmed in 20120327.1 beta2 version.

Adding bamf for app mapping

confirmed in edubuntu 20120410 build - italian language
LibreOfficeBase icon is displayed but the blank LibreOffice icon is displayed too.
See the attached screen shot.

Changed in bamf (Ubuntu):
status: New → Confirmed

Seems to work in general on wily and later. Anyway, if this is still an issue, it would need fixing in bamf anyway.

Changed in libreoffice (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.