Libreoffice's Icons is missing from launcher

Bug #950655 reported by JrZabott on 2012-03-09
54
This bug affects 12 people
Affects Status Importance Assigned to Milestone
bamf (Ubuntu)
Undecided
Unassigned
libreoffice (Ubuntu)
Undecided
Unassigned

Bug Description

Hey Guys, i'm here again, because my icons from libreffice are gone from the launcher after an update sometime ago, and by this I wanna meant hat: Not the accelerators are missing, but any icons, even when the program is opened, is show nothing, but a blank space, when I press Alt+Tab is show nothing but a blank space, when I right click on the 'blank space' in launcher, it show me only options to quit, or lock in launcher, with the 'name' field blank. I've tried the basic:

apt-get remove
apt-get remove --purge
apt-get install

aptitude purge
aptitude install
aptitude reinstall

Manually create on my launcher folder accelerators, it creates accelerators, but when the softare was open, it open in the 'black space' cited before.

Any extra information just ask, and plz say how to obtain.

Thanks all of you.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libreoffice 1:3.5.0-2ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic i686
ApportVersion: 1.94.1-0ubuntu1
Architecture: i386
Date: Fri Mar 9 05:58:02 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
SourcePackage: libreoffice
UpgradeStatus: Upgraded to precise on 2012-02-12 (25 days ago)

JrZabott (jrzabott) wrote :

@bamf: Please take over.

Changed in bamf (Ubuntu):
status: New → Won't Fix
Changed in bamf (Ubuntu):
status: Won't Fix → New
Changed in libreoffice (Ubuntu):
status: New → Won't Fix
JrZabott (jrzabott) wrote :

Something funny abou this bug, ni google, you can find, looking hard, a good number of example unsolved, but when joining the bug here in launchpad, clearly, the number is zero or very low.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu):
status: New → Confirmed

Have you installed libreoffice-filter-binfilter ?

  apt-cache policy libreoffice-filter-binfilter

JrZabott (jrzabott) wrote :

No...

I've removed, purged, done everything possible in my profile, nothing seems change, I even done the icons 'manually' (copying the code from /usr/share/applications, and paste in gedit, and then save like LibreOffice *****.desktop) again... And when I did this, the icons are not more showed in launcher, when application is started with a bank new file, or activate by opening an already existent file.

It's a complete mess... I don't know what to do anymore, I've searched in any bug related, in google, in forums, no one seem to have a solution to my problem.

Hope you can help me.

Sandwalker (sandwalker) wrote :

For quite a while now I've been having this issue with LibreOffice icons. Usually when I start Writer the generic LO icon appears (a white one with a grey corner) and stays even when opening a document. If I quit Writer then start it again with a document I get the correct type icon (e.g. the Writer icon for a .doc/.odt file) PLUS a blank space above it where an icon should be. RIght-clicking the space gives me <nothing>, Lock to Launcher or Quit. Locking then unlocking removes the blank space.

This issue has been driving me nuts for some time. libreoffice-filter-binfilter isn't installed either.

Simplehuman (simplehuman) wrote :

Unity 6.2, Ubuntu 12.10 x64.

Now instead of blank space it sometimes shows 2 icons - an unknown icon and Calc icon under it . See attachment.

Pablo (ceascolombia) wrote :

Just to add my experience:
When I open a LibreOffice document, I get the the generic LO icon appears (a white one with a grey corner). But the LIbreOffice Icons are not active. And if I click on the generic icon, nothing happens-- it will not open the active LibreOffice document If I click on the LibreOffice Icons then a new untitled document opens, but the LIbreOffice icon still doesn't show itself active (the little white arrow to the left). If I click on Alt-Tab, the LibreOffice documents do not appear although they are open. HOwever, if I click Super+W, then the documents appear and I can access them. IN fact, that is the only way to access open LO document if I have shifted to a different window.

Simplehuman (simplehuman) wrote :

To my last comment:

Unity 6.4, Ubuntu 12.10 x64.

The problem is still there.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers