tvtime launcher does not work correctly when pinned to the launcher bar

Bug #937218 reported by Nicolás Abel Carbone on 2012-02-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
BAMF
Undecided
Unassigned
Unity
Confirmed
Undecided
Unassigned
bamf (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

The bug is easily reproducible:

Scenario one:

1. Search for tvtime in the dash and open it.
2. Right-click on the launcher icon for tvtime and select "Pin to the launcher" (or similar, I have the Spanish locale of Ubuntu) in the quicklist.
3. Close tvtime.
4. Try to open tvtime from the launcher. It will not open.

Scenario two:

1. Search for tvtime in tha dash, and drag its icon to the launcher bar.
2. Try to open tvtime from the launcher. It will open, but it will create a new icon in the launcher instead of marking the previous one as running.

I mark the bug as related to unity, but maybe it is related to tvtime too.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Es un directorio: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 295.20 Mon Feb 6 21:07:30 PST 2012
 GCC version: gcc versión 4.6.2 (Ubuntu/Linaro 4.6.2-14ubuntu2)
.tmp.unity.support.test.0:

ApportVersion: 1.92-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,vpswitch,mousepoll,regex,move,resize,compiztoolbox,wall,animation,place,grid,imgpng,gnomecompat,snap,fade,session,workarounds,expo,scale,ezoom,unityshell]
CompositorRunning: compiz
Date: Mon Feb 20 17:05:53 2012
DistUpgraded: Log time: 2012-02-13 17:00:10.336708
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 295.20, 3.2.0-16-generic, x86_64: installed
 nvidia-current, 295.20, 3.2.0-17-generic, x86_64: installed
 nvidia-current-updates, 295.20, 3.2.0-16-generic, x86_64: installed
 nvidia-current-updates, 295.20, 3.2.0-17-generic, x86_64: installed
GraphicsCard:
 NVIDIA Corporation GF116 [GeForce GTX 550 Ti] [10de:1244] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Giga-byte Technology Device [1458:351a]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120211)
JockeyStatus:
 xorg:nvidia_current - Controlador para tarjetas gráficas NVIDIA (Privativo, Desactivado, No está en uso)
 xorg:nvidia_current_updates - Controlador de gráficos acelerados de NVIDIA (actualizaciones post-lanzamiento) (Privativo, Activado, En uso)
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcEnviron:
 LANGUAGE=es_AR:es:en
 PATH=(custom, no user)
 LANG=es_AR.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-17-generic root=UUID=c00ec9f3-2df1-47a1-bcea-979cd2de71e1 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-02-16 (3 days ago)
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 05/07/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.40
dmi.board.name: ALiveNF5-eSATA2+
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.40:bd05/07/2007:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvn:rnALiveNF5-eSATA2+:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu4
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0~rc2-0ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0~rc2-0ubuntu5
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Omer Akram (om26er) on 2012-02-21
no longer affects: unity (Ubuntu)
Omer Akram (om26er) on 2012-02-21
Changed in bamf:
status: New → Confirmed
Changed in bamf (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Omer Akram (om26er) wrote :

Just installed tvtime and seems I can reproduce the issue easily.

Omer Akram (om26er) wrote :

subscribed 3v1n0 to the report so he may have a look

Changed in unity (Ubuntu):
status: New → Confirmed
To post a comment you must log in.