failed to upgrade to oneiric: /usr/bin/perl: symbol lookup error: /usr/lib/gio/modules/libgiobamf.so: undefined symbol: g_desktop_app_info_launch_handler_get_type

Bug #828922 reported by michael kieda on 2011-08-18
76
This bug affects 3 people
Affects Status Importance Assigned to Milestone
BAMF
Undecided
Unassigned
Unity
Invalid
Undecided
Unassigned
unity-2d
Undecided
Unassigned
bamf (Ubuntu)
Undecided
Unassigned

Bug Description

11.04 to 11.10

ProblemType: Package
DistroRelease: Ubuntu 11.10
Package: hostname 3.05ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic i686
Architecture: i386
Date: Thu Aug 18 12:30:23 2011
ErrorMessage: ErrorMessage: package hostname is already installed and configured
InstallationMedia: Zorin OS 4 - Release i386
SourcePackage: dpkg
Title: package hostname 3.05ubuntu1 failed to install/upgrade: ErrorMessage: package hostname is already installed and configured
UpgradeStatus: Upgraded to oneiric on 2011-08-18 (0 days ago)

michael kieda (michaelkieda) wrote :
Raphaël Hertzog (hertzog) wrote :

The problem comes from bamf. If the simple unpack of a newer version can break all perl scripts, it might be wise to pre-depend on the needed libraries...

Preparing to replace libc6 2.13-0ubuntu13 (using .../libc6_2.13-16ubuntu4_i386.deb) ...

/usr/bin/perl: symbol lookup error: /usr/lib/gio/modules/libgiobamf.so: undefined symbol: g_desktop_app_info_launch_handler_get_type

dpkg: error processing /var/cache/apt/archives/libc6_2.13-16ubuntu4_i386.deb (--unpack):

 subprocess new pre-installation script returned error exit status 127

affects: dpkg (Ubuntu) → bamf (Ubuntu)
Changed in bamf (Ubuntu):
status: New → Confirmed
summary: - package hostname 3.05ubuntu1 failed to install/upgrade: ErrorMessage:
- package hostname is already installed and configured
+ failed to upgrade to oneiric: /usr/bin/perl: symbol lookup error:
+ /usr/lib/gio/modules/libgiobamf.so: undefined symbol:
+ g_desktop_app_info_launch_handler_get_type
Didier Roche (didrocks) on 2011-10-03
Changed in unity:
status: New → Confirmed
Changed in bamf:
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d:
status: New → Confirmed
Omer Akram (om26er) on 2011-10-15
Changed in bamf:
status: Confirmed → Invalid
Changed in unity-2d:
status: Confirmed → Invalid
Changed in unity:
status: Confirmed → Invalid
Didier Roche (didrocks) on 2011-10-25
Changed in unity:
status: Invalid → Confirmed
Changed in bamf:
status: Invalid → Confirmed
Stephen M. Webb (bregma) wrote :

Oneiric reached support end of life 2013-05-09. This bug is unlikely to get fixed now.

Changed in unity:
status: Confirmed → Invalid
Changed in bamf:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers