bamfdaemon crashed with SIGABRT in dbus_g_connection_register_g_object()

Bug #758154 reported by chuda on 2011-04-11
396
This bug affects 54 people
Affects Status Importance Assigned to Milestone
BAMF
Critical
Unassigned
Unity
Fix Released
Critical
Unassigned
bamf (Ubuntu)
Critical
Jason Smith
Natty
Critical
Jason Smith
Oneiric
Critical
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

kk

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: bamfdaemon 0.2.86-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Mon Apr 11 17:55:19 2011
ExecutablePath: /usr/lib/bamf/bamfdaemon
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcCmdline: /usr/lib/bamf/bamfdaemon
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=es_VE:en
 LANG=es_VE.UTF-8
Signal: 6
SourcePackage: bamf
StacktraceTop:
 dbus_g_connection_register_g_object () from /usr/lib/libdbus-glib-1.so.2
 bamf_view_export_on_bus ()
 ?? ()
 ?? ()
 g_cclosure_marshal_VOID__OBJECT () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
Title: bamfdaemon crashed with SIGABRT in dbus_g_connection_register_g_object()
UpgradeStatus: Upgraded to natty on 2011-04-08 (3 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

chuda (jcontreras) wrote :

This crash has the same stack trace characteristics as bug #754225. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: added: regression-retracer
tags: removed: need-i386-retrace
visibility: private → public
tags: added: bugpattern-needed
Alex Launi (alexlauni) wrote :

this is a dupe of lp:754225, but due to a lp bug- i can't mark it as such.

Changed in bamf:
importance: Undecided → Critical
status: New → Triaged
Changed in unity:
status: New → Triaged
importance: Undecided → Critical
Changed in bamf (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
Barry Drake (b-drake) wrote :

Was inserting a picture into a document when crash occurred. Last updates were yesterday. Natty 11.04

Kate Stewart (kate.stewart) wrote :

Adding task to track in Oneric, incase it doesn't get fixed in Natty.

Changed in bamf (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → Critical
Changed in bamf (Ubuntu Natty):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
milestone: none → ubuntu-11.04
Martin Pitt (pitti) wrote :

This is a duplicate of bug 754225, but as both that and this report have tons of duplicates, I just close this.

bamf (0.2.86-0ubuntu2) natty; urgency=low

  * Trunk commit r358, really fixes the crash bug listed before (lp: #754225)

 -- Sebastien Bacher <email address hidden> Tue, 12 Apr 2011 22:19:24 +0200

Changed in bamf (Ubuntu Natty):
assignee: Canonical Desktop Team (canonical-desktop-team) → Jason Smith (jassmith)
status: Triaged → Fix Released
Changed in bamf:
status: Triaged → Fix Released
Changed in unity:
status: Triaged → Fix Released
Changed in bamf (Ubuntu Oneiric):
status: Triaged → Fix Released
Rolf Leggewie (r0lf) wrote :

natty has seen the end of its life and is no longer receiving any updates. Marking the natty task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Natty):
status: New → Won't Fix
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Oneiric):
status: New → Won't Fix
To post a comment you must log in.