Libreoffice is not marked as opened in the Unity Launcher

Bug #751025 reported by Walter Garcia-Fontes on 2011-04-05
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Invalid
Low
Unassigned
bamf (Ubuntu)
High
Steve Langasek

Bug Description

Binary package hint: unity

1. Open LibreOffice Writer from the Unity Launcher

What should happen? The LibreOffice Writer in the launcher should get the mark that running applications get.

What happenes? The icon does not get any marker

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: libreoffice 1:3.3.2-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
Date: Tue Apr 5 07:28:15 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427.1)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/tcsh
SourcePackage: libreoffice
UpgradeStatus: Upgraded to natty on 2011-04-01 (3 days ago)

Checking further, I see that a grey icon is added to the launcher with a question mark, which shows as "LibreOffic Small Device Format Importer" when hovered with the mouse. The main LibreOffice Writer Icon is not marked as running.

Bilal Akhtar (bilalakhtar) wrote :

I am unable to reproduce this bug. Bamf handles libreoffice windows matching stuff properly. Can you ensure whether your system is updated to the latest?

affects: unity (Ubuntu) → bamf (Ubuntu)
Changed in bamf (Ubuntu):
status: New → Incomplete

Thanks Bilal. Yes, I'm fully updated in Natty and getting this in two different systems.

I should add that I have the Unity launcher to "Dodge active window", I don't know if this matters.

I attach a screenshot just in case it helps. As you can see the LibreOffice normal icon does not get marked despite it is running, and I get the extra icon that I mention further down.

Changed in bamf (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

seems like that's due to the bamf gio integration being broken with the recent multiarch changes

affects: bamf (Ubuntu) → glib2.0 (Ubuntu)
Changed in glib2.0 (Ubuntu):
assignee: nobody → Steve Langasek (vorlon)
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

so from IRC discussion the libgiobamf.so from the multiarch dir is not being used correctly for things not in the cache lists

Today I got another bug in the launcher that seems related to this same problem. Check the screenshot, whenever I wanted to click on the launcher to get back to an emacs windows or to another application that I had opened (the commercial application stata) another icon was created in the launcher but the corresponding window would not open.

Steve Langasek (vorlon) wrote :

Analysis so far:
 - bamf does not provide the g_io_module_query hook; therefore gio-querymodules does not add it to giomodule.cache.
 - g_io_modules_scan_all_in_directory(), which is called from _g_io_modules_ensure_loaded() against both the multiarch and pre-multiarch directories, falls back to scanning the directory and loading any additional modules with this code:

              /* Try to load and init types */
              if (g_type_module_use (G_TYPE_MODULE (module)))
                g_type_module_unuse (G_TYPE_MODULE (module)); /* Unload */
              else
                { /* Failure to load */
                  g_printerr ("Failed to load module: %s\n", path);
                  g_object_unref (module);
                  g_free (path);
                  continue;
                }

 - the other gio interface that probes directories, g_io_modules_load_all_in_directory(), takes a directory name so something calling this could fail to know about the multiarch directories; but so far I don't see where this code would be called from to cause this problem (it's not called in bamf itself).
 - manually adding libgiobamf.so to giomodule.cache is reported to correct the problem.
 - moving libgiobamf.so back to /usr/lib/gio/modules is *also* reported to correct the problem.

So I don't think we have a good understanding of why this doesn't work as-is. For the time being, the simplest solution is to adjust bamf to move the library back to /usr/lib/gio/modules as a workaround.

Changed in bamf (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Steve Langasek (vorlon)
milestone: none → ubuntu-11.04-beta-2
Changed in glib2.0 (Ubuntu):
assignee: Steve Langasek (vorlon) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.84-0ubuntu2

---------------
bamf (0.2.84-0ubuntu2) natty; urgency=low

  * Move the giomodule DSO back to /usr/lib/gio/modules, because something
    we haven't identified yet refuses to see it when it's installed to the
    multiarch path. LP: #751025
 -- Steve Langasek <email address hidden> Thu, 07 Apr 2011 23:54:53 +0000

Changed in bamf (Ubuntu):
status: Triaged → Fix Released
Rafy (rafy) wrote :

I still experience the same issue even after installing the latest updates.

Martin Meredith (mez) wrote :

I can confirm that I am also seeing this issue. It only seems to be for Writer though, not any of the other LO apps.

It has been only for Writer for me, for all the other applications the Unity launcher works OK. But it also happens with another commercial application that I use (Stata).

I confirm that the but is still here after being fully update now (April 12)

Sebastien Bacher (seb128) wrote :

let's close this bug the specific issue was sorted, there is bug #732412 describing the remaining bug

affects: glib2.0 (Ubuntu) → unity (Ubuntu)
Changed in unity:
importance: Undecided → Low
status: New → Invalid
Changed in unity (Ubuntu):
importance: High → Low
status: New → Invalid
Adolfo Jayme (fitojb) on 2014-01-11
no longer affects: unity (Ubuntu)
no longer affects: bamf (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers