bamfdaemon crashed with SIGABRT in dbus_g_connection_register_g_object()

Bug #739218 reported by Alex Warren on 2011-03-21
768
This bug affects 180 people
Affects Status Importance Assigned to Milestone
BAMF
Critical
Jason Smith
Unity
Fix Released
Critical
Jason Smith
bamf (Ubuntu)
Medium
Jason Smith
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I was just trying to alt-tab between Libreoffice Calc and Libreoffice Writer and not only was response time really slow, but it would tab to a document that wasn't the previous one I had used and after just a few uses of the alt-tab command something crashed.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: bamfdaemon 0.2.80-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.36-generic-pae 2.6.38
Uname: Linux 2.6.38-7-generic-pae i686
Architecture: i386
Date: Mon Mar 21 04:23:19 2011
ExecutablePath: /usr/lib/bamf/bamfdaemon
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcCmdline: /usr/lib/bamf/bamfdaemon
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
Signal: 6
SourcePackage: bamf
StacktraceTop:
 dbus_g_connection_register_g_object () from /usr/lib/libdbus-glib-1.so.2
 bamf_view_export_on_bus ()
 ?? ()
 ?? ()
 ?? ()
Title: bamfdaemon crashed with SIGABRT in dbus_g_connection_register_g_object()
UpgradeStatus: Upgraded to natty on 2011-03-20 (1 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (nautilus:1546): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
 (<unknown>:1544): libindicator-WARNING **: Shortcut Group does not have key 'TargetEnvironment' falling back to deprecated use of 'OnlyShowIn' and 'NotShowIn'.
 (<unknown>:1544): dee-WARNING **: Transaction from com.canonical.Unity.ApplicationsPlace.SectionsModel is in the past. Ignoring transaction.

Alex Warren (alexanderjwarren) wrote :

StacktraceTop:
 dbus_g_connection_register_g_object (connection=0x98e9aac, at_path=0x9965880 "/org/ayatana/bamf/window69222029", object=0x98f7460) at dbus-gobject.c:2590
 bamf_view_export_on_bus (view=0x98f7460) at bamf-view.c:475
 bamf_matcher_register_view (self=0x98b2c40, view=0x98f7460) at bamf-matcher.c:147
 handle_raw_window (self=0x98b2c40, window=0x99424a0) at bamf-matcher.c:1198
 open_office_window_setup_timer (args=0x9956ef0) at bamf-matcher.c:1210

Changed in bamf (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Alex Launi (alexlauni) on 2011-03-25
Changed in bamf:
assignee: nobody → Jason Smith (jassmith)
status: New → Confirmed
Changed in bamf (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Alan Musnikow (am) wrote :

I was opening a new document in LibreOffice Writer when the message reporting that "bamfdaemon crashed ..." popped up. Nothing seemed slow.

This "Alt-Tab" bug also affects 64-bit version.

Luiz Augusto (luizaugustopc) wrote :

This error have occured while I gone to 'full screen' in Youtube.

Jared (jared-vanvolkenburg) wrote :

This error occurred when I went to open a file with VLC.

JeSTeR7 (cblocker) wrote :

This happened to me when going full screen on both a youtube and a vimeo video. AMD64.

32 version here; like with Luiz, it occured when I went fullscreen on youtube and saw it when I got out of fullscreen.

cheers!

Alex Hortopan (alex-hortopan) wrote :

Full screen gimp, I believe.

by virtualbox happened when I tried to select a shared folder.
In particular, when starting nautilus. natty beta1 x64

Andreas Grois (soulsource) wrote :

In my case it crashed when I switched to gedit and started pdflatex from there - don't know if it is in any way related to these two things or just caused by something running in the background.

Gvozdik Artem (gvozdik) wrote :

Get it while compiling 2.6.39-rc2 for no reason.

Neil J. Patel (njpatel) on 2011-04-06
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → Critical
milestone: none → 3.8.4
Andreas Grois (soulsource) wrote :

Crashed again, this time I opened the "Save as JPEG"-Dialog of Gimp. Also last time Gimp was running in the background, or to be more precise, it was closing. Maybe something to do with multiple windows of one application opening and closing?

zeruke (oninekoze) wrote :

iv gotten this problem multiple times while bringing up the open dialog in VLC

Jason Smith (jassmith) on 2011-04-07
Changed in bamf:
status: Confirmed → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
Changed in bamf (Ubuntu):
assignee: nobody → Jason Smith (jassmith)
status: Confirmed → Fix Committed
Changed in bamf:
importance: Undecided → Critical

I can confirm this bug on my system as well.
Bug occurred while scrolling in Libreoffice Writer.
I am running Natty Beta 1 on an EEEpc 1005HA with all current updates.

Alex Bell (ubuntu-upb) wrote :

I've got this bug today to. I was closing gimp, it closed but "bug report" window appeared and gimp is still in my unity board (not actually running). I'm adding screenshot of my situation.
P.S.: after I closed console window same "bug report" window appeared and unity is showing it running whet it is not.

quent57 (quent57) wrote :

I've got this bug right now, with my up to date natty.
On a eeepc 1005HAG.
I used several applications : libreoffice, firefox, gnome-terminal, nautilus, Liferea.

Didier Roche (didrocks) on 2011-04-07
Changed in bamf:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.84-0ubuntu1

---------------
bamf (0.2.84-0ubuntu1) natty; urgency=low

  * New upstream release.
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #717684)
    - bamfdaemon crashed with SIGABRT in dbus_g_connection_register_g_object()
      (LP: #739218)
    - compiz crashed with SIGSEGV in g_utf8_validate() (LP: #736792)
 -- Didier Roche <email address hidden> Thu, 07 Apr 2011 17:17:54 +0200

Changed in bamf (Ubuntu):
status: Fix Committed → Fix Released
tekstr1der (tekstr1der) wrote :

Still seeing this crash:

bamfdaemon crashed with SIGABRT in dbus_g_connection_register_g_object()

with latest bamf package:

bamf (0.2.84-0ubuntu1)

Clicked on the file menu in virtualbox.

Narcissus (narcissus) wrote :

I just got this crash when about to print an image in GIMP with an updated bamf (0.2.84-0ubuntu1).
Aport started gathering info, but I didn't report because it was the same report title than this one.
The launcher subsequently filed with an infinite number of Aport icons and everything froze for a while. Gimp and the print dialog just disappeared.

cgarre (cgarre) wrote :

i think i am still having this .. i am on amd64 , and it is updated to the latest.

cgarre (cgarre) wrote :

Just so that there is more data for research, i added a new bug with the logs ... 755890

Adolfo Jayme (fitojb) on 2014-01-11
no longer affects: bamf (Ubuntu Quantal)
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers