[launcher] Codeblocks doesn't appear in the list of applications

Bug #716524 reported by mmjack on 2011-02-10
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
BAMF
Undecided
Unassigned
Unity
Triaged
Undecided
Unassigned
unity-2d
High
Florian Boucault
bamf (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

The applications Code::Blocks does not show up in the launcher panel on the left hand side of unity

Related branches

Eclipse works fine here.

Changed in unity-2d:
status: New → Confirmed
summary: - Codeblocks and Eclipse doesn't work with the open applications bar in
- the launcher
+ Codeblocks doesn't work with the open applications bar in the launcher
description: updated
summary: - Codeblocks doesn't work with the open applications bar in the launcher
+ [launcher] Codeblocks doesn't appear in the list of applications
Changed in unity-2d:
importance: Undecided → High
Changed in unity-2d:
milestone: none → 3.10
Olivier Tilloy (osomon) wrote :

The issue is with the Code::Blocks view in Bamf returning false when asked whether it is 'user_visible' in LauncherApplicationsList::insertBamfApplication(…). Later on, it seems the value changes to true, but the application has already been discarded.

This is due to the splash screen shown at startup. If I uncheck the "show splash screen on start-up" option in Code::Blocks’ settings, after restarting it I get an icon in the launcher (note that it cannot be favourited because there is no associated desktop file, but this is a separate issue).

I’m attaching the output of xprop for the splash screen.
Note how _NET_WM_WINDOW_TYPE_SPLASH is set to _NET_WM_WINDOW_TYPE_SPLASH, whereas it should probably be set to _NET_WM_WINDOW_TYPE_SPLASH.
Also note how _NET_WM_STATE is set to _NET_WM_STATE_SKIP_TASKBAR. This is probably what makes bamf consider the application is not "user visible".

Olivier Tilloy (osomon) wrote :

Wow, copy-paste insanity happened in my previous comment… The third sentence from the end should read:

« Note how _NET_WM_WINDOW_TYPE is set to _NET_WM_WINDOW_TYPE_NORMAL, whereas it should probably be set to _NET_WM_WINDOW_TYPE_SPLASH. »

Changed in unity-2d:
milestone: 3.10 → none
Didier Roche (didrocks) on 2011-05-31
Changed in bamf:
status: New → Confirmed
Changed in bamf (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-06-01
Changed in unity:
status: New → Confirmed
Florian Boucault (fboucault) wrote :

This bug has the same cause as bug #719983 for which a fix has been found.

Changed in unity-2d:
milestone: none → 3.8.12
assignee: nobody → Florian Boucault (fboucault)
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-07-22
Changed in bamf:
status: Confirmed → Fix Committed
Changed in bamf (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-07-28
Changed in bamf:
status: Fix Committed → Fix Released
Changed in unity-2d:
status: Fix Committed → Fix Released
Didier Roche (didrocks) wrote :

unity-2d has workarounded the issue, but there is still an issue in bamf

Changed in bamf:
status: Fix Released → Triaged
Changed in bamf (Ubuntu):
status: Fix Committed → Triaged
Changed in unity-2d (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity-2d - 3.8.12-0ubuntu1

---------------
unity-2d (3.8.12-0ubuntu1) oneiric; urgency=low

  [ Florian Boucault ]
  * Upstreamed patch 01_build_with_new_indicator.patch
  * do not run pkgbinarymangler to convert images to 8bit since this breaks
    the launcher icon background handling. (LP: #809205)
    (QT upstream bug: http://bugreports.qt.nokia.com/browse/QTBUG-4459)
  * debian/unity-2d.install:
    - install GSettings schemas into usr/share/glib-2.0/schemas
    - install GConf to GSettings conversion into usr/share/GConf/gsettings
  * debian/gconf/schemas/unity-2d.schemas:
    - remove GConf schema for /desktop/unity-2d/launcher/super_key_enable
    - remove GConf schema for /desktop/unity-2d/launcher/favorites
  * debian/20_unity-2d-gconf-default:
    - remove default value for /desktop/unity-2d/launcher/super_key_enable
    - remove default value for /desktop/unity-2d/launcher/favorites
  * debian/control:
    - add dependency on libdconf-qt-dev
    - add dependency on libnux-1.0-dev

  [ Didier Roche ]
  * New upstream release:
    - [dash] preferred applications are not stored in GConf anylonger
      (LP: #805063)
    - [launcher] Tiles background is white/grey instead of the color of the
      icon (oneiric only) (LP: #809205)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - Unity 2D should use dconf instead of gconf (LP: #692965)
    - [launcher] KDE3 Applications do not appear in launcher (LP: #719983)
    - ubuntu-bug showing that I am running unity-2D, when reporting from
      Compiz Unity interface (LP: #712343)
    - Apps pinned in launcher not retained between 2D and 3D Unity versions
      (LP: #746823)
    - [dash] Cannot have KDE4 applications as shortcuts on home screen
      (LP: #750081)
    - [panel] F10 shortcut does not navigate from application menu to
      indicators (LP: #772061)
    - [panel] F10 shortcut does not show application menu (LP: #777993)
    - [dash] Wine applications are not launched (LP: #794471)
    - [spread] GnomeBackground needs to use dconf to retrieve image path
      (LP: #805393)
    - [dash] transparency broken and graphical artifacts when using opengl
      backend (LP: #806019)
    - [dash] Enter no longer launches first item (LP: #811673)
    - [panel] navigation between application menus temporarily gives focus
      back to the application (LP: #717682)
    - [panel] Empathy's emotes not visible in panel menus (LP: #742822)
    - pgadmin3 not handled by unity-2d (LP: #800710)
    - [dash] slow rendering of background with opengl engine (LP: #806122)
    - [spread] Wallpaper is shifted by the width of the launcher (LP: #808712)
    - [launcher] Migrate gconf key /desktop/unity-2d/launcher/super_key_enable
      to dconf (LP: #810509)
    - [panel] application name cut when menu bar visible should use a fade
      (LP: #704615)
    - [panel] Window title could use a little fade (LP: #694924)
    - [launcher] Codeblocks doesn't appear in the list of applications
      (LP: #716524)
  * Fix typo in trigger (debian/unity-2d.triggers): (LP: #807358)
  * Install the apport hook in the right directory so that it's not laun...

Read more...

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-07-29
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers