System freeze up, likely because of bamfdaemon

Bug #1677706 reported by Max Rumpf on 2017-03-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bamf (Ubuntu)
Undecided
Unassigned

Bug Description

Since yesterday, system completely freezes up (mouse, keyboard, open terminal etc freezing, Unity panel clock and ssh still running) shortly after login, with fwupd using 100% CPU. Killing it doesn't do anything, but "sudo pkill bamfdaemon" resolves the freeze-up.
Interestingly, when I tried the first few times to reboot through ssh, it did, but then got hanging at the shutdown screen, only with a hard-reset left as option.
I also tried to boot an older kernel, same issue. Seems another update broke the system.
I will attach my dmesg and syslog, maybe they're useful.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: bamfdaemon 0.5.3+16.10.20160929-0ubuntu1
ProcVersionSignature: Ubuntu 4.8.0-39.42-generic 4.8.17
Uname: Linux 4.8.0-39-generic x86_64
ApportVersion: 2.20.3-0ubuntu8.2
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Mar 30 20:08:11 2017
InstallationDate: Installed on 2013-12-24 (1192 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
SourcePackage: bamf
UpgradeStatus: Upgraded to yakkety on 2017-01-14 (74 days ago)

Max Rumpf (maxr1998) wrote :
Max Rumpf (maxr1998) wrote :

Since the launchpad attachments didn't want to open any selector window when clicked, I posted my logs to pastebin, will be available there for one month.

dmesg: https://pastebin.com/yjxzhjFi
/var/log/syslog:
https://pastebin.com/NJGNN337 (1/2)
https://pastebin.com/UuJ40RKM (2/2)

dino99 (9d9) wrote :

This is an unsupported release now. Please think to install the next LTS 'Bionic 18.04'

http://cdimage.ubuntu.com/ubuntu-next/daily-live/current/
https://www.omgubuntu.co.uk/2018/02/ubuntu-18-04-minimal-install-option

Changed in bamf (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers