spinning wheel when opening Rhythmbox from Dash/Launcher WHEN it is already playing music

Bug #1582430 reported by nebrisi on 2016-05-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bamf (Ubuntu)
Medium
Andrea Azzarone
Xenial
Undecided
Unassigned

Bug Description

[Impact]
spinning wheel when opening Rhythmbox from Dash/Launcher WHEN it is already playing music

[Test Case]

1. Start Rhythmbox.
2. Play some music.
3. Close the Rhythmbox window.
4. Open Rhythmbox from Dash or Launcher (if Rhythmbox is locked to it).
5. Admire annoying spinning wheel for about 13 seconds.

If Rhythmbox is reopened from the sound tray menu it is ok, no spinning wheel.

[Possible Regresssions]
Unity fails to notify the application startup or the startup notification process finishes too soon.

Related branches

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1582430/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → rhythmbox (Ubuntu)
affects: rhythmbox (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Andrea Azzarone (azzar1) on 2016-06-02
Changed in unity (Ubuntu):
importance: Low → Medium
assignee: nobody → Andrea Azzarone (azzar1)
status: Confirmed → In Progress
tags: added: desktop-trello-import
Andrea Azzarone (azzar1) on 2016-06-13
no longer affects: rhythmbox (Ubuntu)
affects: unity (Ubuntu) → bamf (Ubuntu)
Andrea Azzarone (azzar1) on 2016-07-08
description: updated

Hello nebrisi, or anyone else affected,

Accepted bamf into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bamf/0.5.3~bzr0+16.04.20160701-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bamf (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
nebrisi (ichbinich2) wrote :

Hello!

I installed the "bamf 0.5.3~bzr0+16.04.20160701" package and the problem goes away for me!

Rhythmbox back to the Launcher! :)

Thanks, great work!

description: updated
tags: added: verification-done
removed: bot-comment verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.5.3~bzr0+16.04.20160701-0ubuntu1

---------------
bamf (0.5.3~bzr0+16.04.20160701-0ubuntu1) xenial; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * BamfMatcher: allow overriding desktop with the environment var
    BAMF_DESKTOP_FILE_HINT

  [ Andrea Azzarone ]
  * Daemon: manually set to complete the startup notification on view
    state change (LP: #1582430)

  [ Marco Trevisan (Treviño) ]
  * debian/bamfdaemon.triggers: use interest-noawait (LP: #1589097)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 01 Jul 2016 10:44:07 +0000

Changed in bamf (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for bamf has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Andrea Azzarone (azzar1) on 2016-11-04
Changed in bamf (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers