Unity confuses Eclipse icons

Bug #1525007 reported by Vadim Peretokin on 2015-12-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BAMF
Undecided
Unassigned
bamf (Ubuntu)
Undecided
Unassigned

Bug Description

Whenever I launch Eclipse Kepler, Unity disassociates the Kepler icon when the application loads and shows a Mars icon instead. It also doesn't realise that Eclipse is running and always tries to launch Eclipse, even if it is already open. Using unity --reset-icons didn't help.

Attached is a screencast demonstrating the problem.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: unity 7.3.2+15.10.20151016-0ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-19.23-generic 4.2.6
Uname: Linux 4.2.0-19-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Fri Dec 11 08:41:10 2015
DistUpgraded: 2015-10-27 08:48:20,176 DEBUG enabling apt cron job
DistroCodename: wily
DistroVariant: ubuntu
DkmsStatus:
 vboxhost, 5.0.8, 4.2.0-18-generic, x86_64: installed
 vboxhost, 5.0.8, 4.2.0-19-generic, x86_64: installed
GraphicsCard:
 Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 0b) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:198f]
 Advanced Micro Devices, Inc. [AMD/ATI] Mars [Radeon HD 8730M] [1002:6601] (rev ff) (prog-if ff)
InstallationDate: Installed on 2014-06-26 (531 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: Hewlett-Packard HP ZBook 14
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.2.0-19-generic root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to wily on 2015-10-26 (44 days ago)
dmi.bios.date: 04/29/2014
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: L71 Ver. 01.11
dmi.board.name: 198F
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 15.54
dmi.chassis.asset.tag: CNU424B3ZZ
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvrL71Ver.01.11:bd04/29/2014:svnHewlett-Packard:pnHPZBook14:pvrA3009DD10303:rvnHewlett-Packard:rn198F:rvrKBCVersion15.54:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP ZBook 14
dmi.product.version: A3009DD10303
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.12.2+15.10.20151015-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.64-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.0.2-1ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.0.2-1ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.17.2-1ubuntu9.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0+git20150819-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20150808-0ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu3
xserver.bootTime: Fri Dec 11 08:34:48 2015
xserver.configfile: default
xserver.errors: RADEON(G0): [XvMC] Failed to initialize extension.
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 4925
 vendor AUO
xserver.version: 2:1.17.2-1ubuntu9.1

Vadim Peretokin (vperetokin) wrote :
affects: unity (Ubuntu) → bamf (Ubuntu)
To post a comment you must log in.