bamfdaemon crashed with signal 5 in _XReply()

Bug #1193714 reported by Adam Conrad on 2013-06-22
866
This bug affects 142 people
Affects Status Importance Assigned to Milestone
BAMF
Critical
Marco Trevisan (Treviño)
bamf (Ubuntu)
Medium
Marco Trevisan (Treviño)
Nominated for Saucy by Christopher Townsend

Bug Description

This happened while search for an application in the dash. Took out compiz in the process, somehow. Fun.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: bamfdaemon 0.5.0daily13.06.19-0ubuntu1
ProcVersionSignature: Ubuntu 3.9.0-6.14-generic 3.9.6
Uname: Linux 3.9.0-6-generic x86_64
ApportVersion: 2.10.2-0ubuntu2
Architecture: amd64
Date: Sat Jun 22 16:10:03 2013
ExecutablePath: /usr/lib/x86_64-linux-gnu/bamf/bamfdaemon
InstallationDate: Installed on 2012-12-09 (194 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20121209)
MarkForUpload: True
ProcCmdline: /usr/lib/x86_64-linux-gnu/bamf/bamfdaemon
ProcEnviron:
 SHELL=/bin/bash
 XDG_RUNTIME_DIR=<set>
 PATH=(custom, user)
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
Signal: 5
SourcePackage: bamf
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 _XReply () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 XGetWindowProperty () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
Title: bamfdaemon crashed with signal 5 in _XReply()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dialout dip lpadmin plugdev sambashare sbuild sudo

Related branches

Adam Conrad (adconrad) wrote :
Changed in bamf (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu):
status: New → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

For me, when upgraded to today's Unity stack and launched unity via alt-f2 - launching failed and this appeared. The second restart worked fine.

Stephen M. Webb (bregma) on 2013-08-13
information type: Private → Public
Laura Czajkowski (czajkowski) wrote :

For me this happens when alt tabbing through applications on 13.10

tags: added: bugpattern-needed
Jay Tuckey (jay-tuckey) wrote :

Happened for me immediately after starting Libreoffice Writer from the dash.

Tom Cameron (drdabbles) wrote :

Happened after removing Lenovo T430 from docking station with DisplayPort monitor attached as second display

Bruce Pieterse (octoquad) wrote :

This occurred when I tried to reset the compiz settings with:

1. dconf reset -f /org/compiz
2. setsid unity

00raq00 (00raq00) wrote :
Download full text (3.5 KiB)

after these commands it show warns

WARN 2013-08-29 10:40:59 unity.glib.dbus.server GLibDBusServer.cpp:586 Can't register object 'com.canonical.Autopilot.Introspection' yet as we don't have a connection, waiting for it...
WARN 2013-08-29 10:40:59 unity.glib.dbus.server GLibDBusServer.cpp:586 Can't register object 'com.canonical.Unity.Debug.Logging' yet as we don't have a connection, waiting for it...
WARN 2013-08-29 10:41:00 unity <unknown>:0 Failed to register favorites: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name :1.18 was not provided by any .service files
WARN 2013-08-29 10:41:00 unity <unknown>:0 Failed to register favorites: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name :1.18 was not provided by any .service files
WARN 2013-08-29 10:41:00 unity <unknown>:0 Failed to register favorites: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name :1.18 was not provided by any .service files
WARN 2013-08-29 10:41:00 unity <unknown>:0 Failed to register favorites: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name :1.18 was not provided by any .service files
WARN 2013-08-29 10:41:00 unity.libindicator <unknown>:0 Desktop file '/usr/share/applications/google-chrome.desktop' is using a deprecated format for its actions that will be dropped soon.
WARN 2013-08-29 10:41:00 unity <unknown>:0 Failed to fetch applications paths: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name :1.18 was not provided by any .service files
ERROR 2013-08-29 10:41:00 unity.launcher.controller LauncherController.cpp:746 Impossible to add icon 'unity://desktop-icon': it's already on the launcher!
WARN 2013-08-29 10:41:00 unity <unknown>:0 Failed to register favorites: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name :1.18 was not provided by any .service files
WARN 2013-08-29 10:41:00 unity.glib.dbus.server GLibDBusServer.cpp:586 Can't register object 'com.canonical.Unity.Launcher' yet as we don't have a connection, waiting for it...
WARN 2013-08-29 10:41:00 unity <unknown>:0 Failed to get active window: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name :1.18 was not provided by any .service files
WARN 2013-08-29 10:41:00 unity <unknown>:0 Failed to fetch paths: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name :1.18 was not provided by any .service files
WARN 2013-08-29 10:41:00 unity.glib.dbus.server GLibDBusServer.cpp:586 Can't register object 'com.canonical.Unity.Dash' yet as we don't have a connection, waiting for it...
WARN 2013-08-29 10:41:00 unity.glib.dbus.server GLibDBusServer.cpp:586 Can't register object 'org.gnome.SessionManager.EndSessionDialog' yet as we don't have a connection, waiting for it...
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default decoration found, placement will not be correct
compiz (decor) - Warn: No default...

Read more...

Steve Langasek (vorlon) wrote :

This bug seems to be reproducible when compiz crashes (e.g., due to bug #1228965).

Changed in bamf:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 0.5.1
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:bamf at revision 588, scheduled for release in bamf, milestone Unknown

Changed in bamf:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:bamf/0.5 at revision 589, scheduled for release in bamf, milestone 0.5.1

Changed in bamf (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in bamf:
milestone: 0.5.1 → 0.6.0
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.5.1+14.04.20131125-0ubuntu1

---------------
bamf (0.5.1+14.04.20131125-0ubuntu1) trusty; urgency=low

  [ Marco Trevisan (Treviño) ]
  * BamfXutils: trap the X errors when doing async X calls. (LP:
    #1193714)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 588
 -- Ubuntu daily release <email address hidden> Mon, 25 Nov 2013 03:55:07 +0000

Changed in bamf (Ubuntu):
status: In Progress → Fix Released

Thanks

On Mon, Nov 25, 2013 at 5:07 PM, Launchpad Bug Tracker <
<email address hidden>> wrote:

> This bug was fixed in the package bamf - 0.5.1+14.04.20131125-0ubuntu1
>
> ---------------
> bamf (0.5.1+14.04.20131125-0ubuntu1) trusty; urgency=low
>
> [ Marco Trevisan (Treviño) ]
> * BamfXutils: trap the X errors when doing async X calls. (LP:
> #1193714)
>
> [ Ubuntu daily release ]
> * Automatic snapshot from revision 588
> -- Ubuntu daily release <email address hidden> Mon, 25 Nov
> 2013 03:55:07 +0000
>
> ** Changed in: bamf (Ubuntu)
> Status: In Progress => Fix Released
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1234533).
> https://bugs.launchpad.net/bugs/1193714
>
> Title:
> bamfdaemon crashed with signal 5 in _XReply()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/bamf/+bug/1193714/+subscriptions
>

NoOp (glgxg) wrote :

Any idea when this will be fixed for 13.10?

$ apt-cache policy bamfdaemon
bamfdaemon:
  Installed: 0.5.1+13.10.20131011-0ubuntu1
  Candidate: 0.5.1+13.10.20131011-0ubuntu1
  Version table:
 *** 0.5.1+13.10.20131011-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ saucy/main i386 Packages
        100 /var/lib/dpkg/status

I get this crash on every startup of 13.10.

tptptp (tone6120) wrote :

+1

Ubuntu Studio with low latency kernel

Linux n53j 3.11.0-15-lowlatency #8-Ubuntu SMP PREEMPT Sun Dec 15 21:38:06 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Mike Olson (mike-olson3) wrote :

I'm still getting this error after an upgrade to 13.10 yesterday. Status says that a fix has been released. How can I get that fix? Sorry for the n00b question, but any help would be greatly appreciated!

Hi Mike, et. al,

The Fix Released version is for 14.04. A bamf SRU (Stable Release Update) will need to be prepared for 13.10 in order for this to be fixed in Ubuntu. I've nominated this fix for Saucy, but it is up to the Ubuntu distro team to take the fix and prepare the SRU. We have done all we can upstream to fix this for 13.10.

Thanks!

databill (julienjut) wrote :

This bug also affects to me. Everty time I poweron the mechine, this bug happen to occur.
Now I can not use Ubuntu any more, because I can not open any Apps on Graphic mode. I only can use it in traditional terminal mode(Ctrl_alt_f1).

wait for the release version.

Hi Christopher,

In the mean time, do you know of anything special about the fix which makes it difficult/impossible to get running on a 13.10 box? That is, if the more dev-savvy of us were to pull/rebuild the BAMF daemon on our own 13.10 machines, should it work?

Cheers,
Ben

Hi Benjamin,

For 13.10, you can get the lp:bamf/0.5 branch which has this fix and build/install it.

Changed in bamf:
milestone: 0.6.0 → 0.5.1
no longer affects: bamf/0.5

Fix Released in bamf BAMF 0.5.1 "The Trusty BAMF".

Changed in bamf:
status: Fix Committed → Fix Released
Wangermée Guy (wangermee-guy) wrote :

Thanks.

On Wed, Apr 15, 2015 at 1:52 AM, Marco Trevisan (Treviño) <mail@3v1n0.net>
wrote:

> Fix Released in bamf BAMF 0.5.1 "The Trusty BAMF".
>
> ** Changed in: bamf
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1234533).
> https://bugs.launchpad.net/bugs/1193714
>
> Title:
> bamfdaemon crashed with signal 5 in _XReply()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/bamf/+bug/1193714/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers