constantly talks to udisks, keeping CPU busy

Bug #1450177 reported by Martin Ueding on 2015-04-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
baloo (Ubuntu)
Undecided
Unassigned

Bug Description

I just upgraded to Kubuntu 15.04 and the process `/usr/lib/udisks2/udisksd --no-debug` constantly burns around 8% CPU.

I am not sure whether this is connected, but I try to use Awesome 3.4 together with KDE. And there is a “System update available” which is refreshing like 5 times a second.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: udisks2 2.1.5-1
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic x86_64
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CurrentDesktop: KDE
CustomUdevRuleFiles: 60-ssd-scheduler.rules
Date: Wed Apr 29 21:55:47 2015
InstallationDate: Installed on 2014-10-07 (204 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.1)
MachineType: LENOVO 4298PQ1
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.19.0-15-generic root=/dev/mapper/kubuntu--vg-root ro quiet splash vt.handoff=7
SourcePackage: udisks2
UpgradeStatus: Upgraded to vivid on 2015-04-29 (0 days ago)
dmi.bios.date: 12/01/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET56WW (1.26 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4298PQ1
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET56WW(1.26):bd12/01/2011:svnLENOVO:pn4298PQ1:pvrThinkPadX220Tablet:rvnLENOVO:rn4298PQ1:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4298PQ1
dmi.product.version: ThinkPad X220 Tablet
dmi.sys.vendor: LENOVO

Martin Ueding (martin-ueding) wrote :
Martin Ueding (martin-ueding) wrote :

I just tried using KDE only and Awesome WM only. The bug occurs when using KDE only, but does not occur when I use Awesome WM alone.

Martin Pitt (pitti) wrote :

I suppose this is not actually udisks' fault, but something is talking to it all the time. Let's see: Can you please run

  sudo /usr/lib/udisks2/udisksd --replace

for a few seconds? If that keeps being busy all time time, please copy&paste the output of that (supposedly it's a repeating pattern, so it's enough to paste part of it).

If that's quiet, please get a monitor log of the system D-Bus instead, as described on https://wiki.ubuntu.com/DebuggingDBus . Also leave that running for a few seconds (direct its output to a file preferably) and then attach the log.

Thanks!

Changed in udisks2 (Ubuntu):
status: New → Incomplete
Martin Ueding (martin-ueding) wrote :

I tried `udisks --replace` and the log did not say much. It just started up and was quiet, although burning around 8% CPU.

Martin Ueding (martin-ueding) wrote :

Now `dbus-monitor` on the other hand gave give a lot of data in a short amount of time. This apparently corresponds to the flickering of the update notifications that I see here.

`/usr/bindbus-daemon --system ...` burns some 6% of CPU here constantly as well.

Martin Ueding (martin-ueding) wrote :

And now I tried `dbus-monitor --system` which gave me a whole lot of output within ten seconds. There are 123152 lines in the file, and in 1216 of them, the word `udisk` comes up.

Martin Ueding (martin-ueding) wrote :

So it looks like udisks2 is constantly answering some requests about the state of all the disks.

I tried it with a different user account on this machine, there udisks behaves nicely. I tried with the same account (most of `$HOME` mirrored) on a different machine and not seen anything there. So for some reason it appears to be *this* account on *this* machine (ThinkPad X220 Tablet).

Martin Ueding (martin-ueding) wrote :

I just bisected the folders `.config`, `.kde` and `.local` on my system. Without `.local`, I did not have the CPU usage. Eventually I stumbled across the Baloo folder. Using the KDE system settings, I disabled the whole search. After than, the idle CPU usage dropped down to 0%.

I guess that is a bug in Baloo then.

Martin Pitt (pitti) wrote :

Thanks for doing the detective work!

affects: udisks2 (Ubuntu) → baloo (Ubuntu)
Changed in baloo (Ubuntu):
status: Incomplete → New
summary: - /usr/lib/udisks2/udisksd --no-debug burns 8% constantly
+ constantly talks to udisks, keeping CPU busy
Martin Ueding (martin-ueding) wrote :

Well, I did want my battery to last a bit :-). Since I do not use Baloo myself, this does not hurt, but it is something that should not occur either way.

aveem ashfaq (aveemashfaq) wrote :

I am fairly new to KDE and used gnome before so excuse me for my ignorance but the only thing i want to report is that i use kubuntu 15.04 and i have stock configuration of everything. i have an i3-2350m processor and it always runs at 25% even at idle. when i type in "top" in terminal, it shows baloo_file to be taking 25% of my CPU usage. i tried putting the laptop idle for 5 hours for it to sort out itself but nothing happened. i tried restarting it a million times and still it is there. i always have to kill the process for things to get back to normal. so, i did a "sudo apt-get remove baloo*" and now the problem is solved. i just shared it so that any information might help. in the meanwhile, please figure the problem out

Baloo is the file indexer which will index all your files. I regularly
deactivate this service in the KDE system settings since I do not need
it and it uses a fair amount of computing power.

I never had the patience to let any full index service run through on
any system, so I could not tell you how long it would take.
--
http://martin-ueding.de/#pk_campaign=Email

This email is formatted with
[Markdown](https://en.wikipedia.org/wiki/Markdown).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in baloo (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers