baloo_file crashed with SIGSEGV in getint2()

Bug #1300413 reported by Steven Anderson on 2014-03-31
54
This bug affects 7 people
Affects Status Importance Assigned to Milestone
baloo (Ubuntu)
Medium
Unassigned

Bug Description

just logging in after launch of vmware workstation before starting vms

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: baloo 4:4.12.95-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-20.42-generic 3.13.7
Uname: Linux 3.13.0-20-generic x86_64
ApportVersion: 2.14-0ubuntu1
Architecture: amd64
CurrentDesktop: KDE
Date: Mon Mar 31 15:44:34 2014
ExecutablePath: /usr/bin/baloo_file
InstallationDate: Installed on 2014-03-28 (3 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Beta amd64 (20140326)
ProcCmdline: /usr/bin/baloo_file
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f83fa055c3f <_ZN10ChertTable13find_in_blockEPKh3Keybi+15>: movzbl 0x9(%rdi),%r12d
 PC (0x7f83fa055c3f) ok
 source "0x9(%rdi)" (0x00000009) not located in a known VMA region (needed readable region)!
 destination "%r12d" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: baloo
StacktraceTop:
 ChertTable::find_in_block(unsigned char const*, Key, bool, int) () from /usr/lib/libxapian.so.22
 ChertTable::find(Cursor*) const () from /usr/lib/libxapian.so.22
 ChertCursor::find_entry(std::string const&) () from /usr/lib/libxapian.so.22
 ?? () from /usr/lib/libxapian.so.22
 ?? () from /usr/lib/libxapian.so.22
Title: baloo_file crashed with SIGSEGV in ChertTable::find_in_block()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Steven Anderson (wanfuse123) wrote :

StacktraceTop:
 getint2 (c=9, p=<optimized out>) at ../common/unaligned.h:50
 ChertTable::find_in_block (p=p@entry=0x0, key=..., leaf=leaf@entry=false, c=65562) at ../backends/chert/chert_table.cc:467
 ChertTable::find (this=0x1369458, C_=0x15c1490) at ../backends/chert/chert_table.cc:501
 ChertCursor::find_entry (this=0x1802cf0, key=...) at ../backends/chert/chert_cursor.cc:214
 ChertValueManager::get_chunk_containing_did (this=this@entry=0x13699b8, slot=slot@entry=0, did=2658, chunk=...) at ../backends/chert/chert_values.cc:164

Changed in baloo (Ubuntu):
importance: Undecided → Medium
summary: - baloo_file crashed with SIGSEGV in ChertTable::find_in_block()
+ baloo_file crashed with SIGSEGV in getint2()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in baloo (Ubuntu):
status: New → Confirmed
information type: Private → Public
Harald Sitter (apachelogger) wrote :

Do you still get this crash with 4:4.12.97-0ubuntu2?

Changed in baloo (Ubuntu):
status: Confirmed → Incomplete

After I downloaded the latest updates, I haven't seen it crash so far,
though I've seen this process consume a lot of CPU for a while. I assume
it's some sort of background processing indexing my files for easy
searching.

On Tue, Apr 8, 2014 at 4:30 AM, Harald Sitter <email address hidden>wrote:

> Do you still get this crash with 4:4.12.97-0ubuntu2?
>
> ** Changed in: baloo (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1303155).
> https://bugs.launchpad.net/bugs/1300413
>
> Title:
> baloo_file crashed with SIGSEGV in getint2()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/baloo/+bug/1300413/+subscriptions
>

--
Doug Holland

meldroc (meldroc-gmail) wrote :

Actually, I just saw another new version coming in through the updater.
We'll see how this one works.

On Tue, Apr 8, 2014 at 7:49 AM, <email address hidden> <email address hidden> wrote:

> After I downloaded the latest updates, I haven't seen it crash so far,
> though I've seen this process consume a lot of CPU for a while. I assume
> it's some sort of background processing indexing my files for easy
> searching.
>
>
> On Tue, Apr 8, 2014 at 4:30 AM, Harald Sitter <email address hidden>wrote:
>
>> Do you still get this crash with 4:4.12.97-0ubuntu2?
>>
>> ** Changed in: baloo (Ubuntu)
>> Status: Confirmed => Incomplete
>>
>> --
>> You received this bug notification because you are subscribed to a
>> duplicate bug report (1303155).
>> https://bugs.launchpad.net/bugs/1300413
>>
>> Title:
>> baloo_file crashed with SIGSEGV in getint2()
>>
>> To manage notifications about this bug go to:
>>
>> https://bugs.launchpad.net/ubuntu/+source/baloo/+bug/1300413/+subscriptions
>>
>
>
>
> --
> Doug Holland
>

--
Doug Holland

Harald Sitter (apachelogger) wrote :

Going to assume it fixed for the time being.

As for the CPU, yeah it's a background indexer with super low priority, so in general it should not get in the way of other applications (plus, once everything is indexed it should be idle most of the time ;))

Changed in baloo (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers