baloo_file_extractor crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()

Bug #1296654 reported by Michael Zanetti on 2014-03-24
404
This bug affects 90 people
Affects Status Importance Assigned to Milestone
Baloo
Fix Released
Medium
baloo (Ubuntu)
High
Unassigned
Trusty
High
Unassigned

Bug Description

I have excluded ~ from baloo's indexing folders hoping it would stop eating my CPU cores. That seemed to work fine, but now it crashes every once in a while.

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: baloo 4:4.12.95-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-18.38-generic 3.13.6
Uname: Linux 3.13.0-18-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: KDE
Date: Mon Mar 24 10:58:13 2014
ExecutablePath: /usr/bin/baloo_file_extractor
InstallationDate: Installed on 2012-11-10 (498 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64+mac (20120926)
ProcCmdline: /usr/bin/baloo_file_extractor 2855 2854 2853 2852 2851 2850 2849 2848 2847 2846 2845 2844 2843 2842 2841 2840 2839 2838 2836 2835 2834 2833 2832 2831 2829 2828 2827 2825 2823 2822 2815 2814 2813 2811 2810 2809 2808 2804 2803 2802
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: baloo
StacktraceTop:
 __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
 std::terminate() () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
 __cxa_rethrow () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
 QEventLoop::exec (this=this@entry=0x7fff0b8f9e30, flags=...) at kernel/qeventloop.cpp:218
Title: baloo_file_extractor crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
UpgradeStatus: Upgraded to trusty on 2013-10-22 (153 days ago)
UserGroups: adm autopilot cdrom dip fuse libvirtd lp lpadmin plugdev sambashare sbuild sudo users

Baloo has indexed a number of files but not all
console log indicate a crash

Reproducible: Didn't try

Steps to Reproduce:
1. Cleanup baloo DB files and baloorc
2. run baloo_file
3. check message on console
Actual Results:
baloo_file(27120): Indexer crashed while indexing 32477
baloo_file(27120): Blacklisting this file
QProcess: Destroyed while process is still running.
QCoreApplication::postEvent: Unexpected null receiver
baloo_file(27120): Indexer crashed while indexing 32477
baloo_file(27120): Blacklisting this file
QProcess: Destroyed while process is still running.
QProcess: Destroyed while process is still running.
QProcess: Destroyed while process is still running.
QProcess: Destroyed while process is still running.
QProcess: Destroyed while process is still running.
QProcess: Destroyed while process is still running.
baloo_file(27120): Indexer crashed while indexing 32476
baloo_file(27120): Blacklisting this file
QProcess: Destroyed while process is still running.
baloo_file(27120): Indexer crashed while indexing 32477
baloo_file(27120): Blacklisting this file
QProcess: Destroyed while process is still running.
QCoreApplication::postEvent: Unexpected null receiver
baloo_file(27120): Indexer crashed while indexing 32477
baloo_file(27120): Blacklisting this file
baloo_file(27120): Indexer crashed while indexing 39396
baloo_file(27120): Blacklisting this file
Qt has caught an exception thrown from an event handler. Throwing
exceptions from an event handler is not supported in Qt. You must
reimplement QApplication::notify() and catch all exceptions there.

terminate called after throwing an instance of 'Xapian::DatabaseModifiedError'
Aborted

Expected Results:
Indexation done for xxxx files.

Reproductible : I've run manually baloo_file in konsole

baloo_file

end of the log ....
(full log see attachement)

baloo_file(4344) Baloo::CommitQueue::commit: SQL Committed
baloo_file(4344): Unable to get write lock on /home/bruno/.kde4/share/apps/baloo/file/: already locked
baloo_file(4344) Baloo::FileIndexingJob::start: ("51828", "51818", "51815", "51808", "51804", "51802", "51801", "51800", "51799", "51789", "51752", "51577", "51575", "51573", "51572", "51563", "51560", "51548", "51547", "51544", "51539", "51538", "51522", "51511", "51506", "51490", "51488", "51487", "51480", "51478", "51477", "51469", "42945", "9552", "51851", "51830", "51808", "51789", "51752", "51488")
baloo_file(4344) Baloo::CommitQueue::commit: SQL Committed
baloo_file(4344): Unable to get write lock on /home/bruno/.kde4/share/apps/baloo/file/: already locked
baloo_file(4344) Baloo::CommitQueue::commit: SQL Committed
baloo_file(4344): Unable to get write lock on /home/bruno/.kde4/share/apps/baloo/file/: already locked
baloo_file(4344) Baloo::CommitQueue::commit: SQL Committed
baloo_file(4344): Unable to get write lock on /home/bruno/.kde4/share/apps/baloo/file/: already locked
baloo_file(4344) Baloo::CommitQueue::commit: SQL Committed
baloo_file(4344) Baloo::CommitQueue::commit: Adding: 3 docs
Qt has caught an exception thrown from an event handler. Throwing
exceptions from an event handler is not supported in Qt. You must
reimplement QApplication::notify() and catch all exceptions there.

terminate called after throwing an instance of 'Xapian::DatabaseModifiedError'
Aborted

Created attachment 85602
Full session of baloo_file run in console

(beta3, not resolved)

*** Bug 332379 has been marked as a duplicate of this bug. ***

Git commit 5d20b752fb449134d2e9d95be94718a83146e7bd by Vishesh Handa.
Committed on 21/03/2014 at 16:57.
Pushed by vhanda into branch 'KDE/4.13'.

Catch a Xapian::DatabaseModifiedException just in case

The Xapian::WritableDatabase should not be emitting this exception but
bug reports seem to indicate otherwise.

M +7 -2 src/file/commitqueue.cpp

http://commits.kde.org/baloo/5d20b752fb449134d2e9d95be94718a83146e7bd

Michael Zanetti (mzanetti) wrote :

StacktraceTop:
 __gnu_cxx::__verbose_terminate_handler() () from /tmp/apport_sandbox_NiU5Jz/usr/lib/x86_64-linux-gnu/libstdc++.so.6
 ?? () from /tmp/apport_sandbox_NiU5Jz/usr/lib/x86_64-linux-gnu/libstdc++.so.6
 std::terminate() () from /tmp/apport_sandbox_NiU5Jz/usr/lib/x86_64-linux-gnu/libstdc++.so.6
 __cxa_rethrow () from /tmp/apport_sandbox_NiU5Jz/usr/lib/x86_64-linux-gnu/libstdc++.so.6
 QEventLoop::exec (this=0x7fff0b8f9e30, flags=...) at kernel/qeventloop.cpp:218

Changed in baloo (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Rohan Garg (rohangarg) on 2014-03-24
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in baloo (Ubuntu):
status: New → Confirmed
Changed in baloo:
importance: Unknown → Medium
status: Unknown → Fix Released
Brian Murray (brian-murray) wrote :

This is currently the top reported error about 14.04 on errors.ubuntu.com. It'd be good to get this fix incorporated in Trusty.

Changed in baloo (Ubuntu Trusty):
importance: Medium → High
Rohan Garg (rohangarg) wrote :

Will be fixed with the next upload of KDE SC :)

Rohan Garg (rohangarg) wrote :

Should be fixed with baloo 4.12.97 , please re open if you still have the issue after upgrading.

Changed in baloo (Ubuntu Trusty):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.