Baloo Deadlocks System on Startup

Bug #1880428 reported by Sarah Szabo on 2020-05-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
baloo-kf5 (Ubuntu)
Undecided
Unassigned

Bug Description

Similar to https://bugs.launchpad.net/bugs/1837964 when starting the comptuer baloo uses high CPU usage (according to top) and then within 3 minutes deadlocks the system. The only way out of it taht I've seen is to use the ASPCI shutdown (reboot button held)

Unlike the linked post, this is on 20.04LTS and doesn't destroy the desktop. Using balooctl disable removes the problem, but disables the search and forces a re-build, which is somewhat inconvenient.

I can provide more information upon request :)

System specs (inxi -Fx):

sarah@LesserArk:~$ inxi -Fx
System: Host: LesserArk Kernel: 5.4.0-31-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: KDE Plasma 5.18.5
           Distro: Ubuntu 20.04 LTS (Focal Fossa)
Machine: Type: Laptop System: Hewlett-Packard product: HP ENVY 17 Notebook PC v: 097E110000405E00000620100
           serial: <superuser/root required>
           Mobo: Hewlett-Packard model: 1968 v: KBC Version 93.52 serial: <superuser/root required> UEFI: Insyde v: F.70
           date: 10/20/2017
Battery: ID-1: BAT0 charge: 41.2 Wh condition: 41.2/41.2 Wh (100%) model: Hewlett-Packard Primary status: Full
CPU: Topology: Quad Core model: Intel Core i7-4702MQ bits: 64 type: MT MCP arch: Haswell rev: 3 L2 cache: 6144 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 35118
           Speed: 1561 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 1561 2: 1713 3: 1627 4: 1622 5: 1677 6: 1858 7: 1557
           8: 1490
Graphics: Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Hewlett-Packard driver: i915 v: kernel
           bus ID: 00:02.0
           Device-2: NVIDIA GK107M [GeForce GT 750M] vendor: Hewlett-Packard driver: nvidia v: 390.132 bus ID: 01:00.0
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa
           resolution: 1920x1080~60Hz, 1920x1080~75Hz
           OpenGL: renderer: GeForce GT 750M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.132 direct render: Yes
Audio: Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: Hewlett-Packard driver: snd_hda_intel
           v: kernel bus ID: 00:03.0
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
           bus ID: 00:1b.0
           Sound Server: ALSA v: k5.4.0-31-generic
Network: Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel port: 5000 bus ID: 07:00.0
           IF: wlp7s0 state: up mac: e4:70:b8:f8:99:b8
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel
           port: 3000 bus ID: 0f:00.0
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: a0:1d:48:fa:67:c0
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Drives: Local Storage: total: 3.21 TiB used: 1.15 TiB (35.8%)
           ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB
           ID-2: /dev/sdb vendor: LITE-ON IT model: LMS-24L6M-HP size: 22.37 GiB
           ID-3: /dev/sdc vendor: Seagate model: ST2000LM015-2E8174 size: 1.82 TiB
           ID-4: /dev/sdd vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB
           ID-5: /dev/sde type: USB vendor: SanDisk model: Gaming Xbox 360 size: 7.48 GiB
           ID-6: /dev/sdf type: USB vendor: SanDisk model: U3 Cruzer Micro size: 1.91 GiB
RAID: Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 bus ID: 00:1f.2
Partition: ID-1: / size: 398.61 GiB used: 188.77 GiB (47.4%) fs: btrfs dev: /dev/sdd2
           ID-2: /home size: 398.61 GiB used: 188.77 GiB (47.4%) fs: btrfs dev: /dev/sdd2
           ID-3: swap-1 size: 14.90 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdd3
Sensors: System Temperatures: cpu: 55.0 C mobo: 54.0 C gpu: nvidia temp: 50 C
           Fan Speeds (RPM): N/A
Info: Processes: 399 Uptime: 17m Memory: 15.57 GiB used: 5.04 GiB (32.4%) Init: systemd runlevel: 5 Compilers: gcc: 9.3.0
           Shell: bash v: 5.0.16 inxi: 3.0.38

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: baloo-kf5 5.68.0-0ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-31.35-generic 5.4.34
Uname: Linux 5.4.0-31-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: KDE
Date: Sun May 24 14:46:14 2020
InstallationDate: Installed on 2020-05-22 (1 days ago)
InstallationMedia: Kubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
SourcePackage: baloo-kf5
UpgradeStatus: No upgrade log present (probably fresh install)

Sarah Szabo (sarahszabo) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers