[apport] balazar crashed with TypeError in _soya.render()

Bug #82830 reported by zoom2au on 2007-02-02
54
Affects Status Importance Assigned to Milestone
balazar (Ubuntu)
Medium
MOTU

Bug Description

Binary package hint: balazar

crashed upon opening

ProblemType: Crash
Date: Fri Feb 2 21:45:09 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/games/balazar
Package: balazar 0.3.3.ds1-1
ProcCmdline: /usr/bin/python -O /usr/games/balazar
ProcCwd: /home/zoom2au
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/games/balazar']
SourcePackage: balazar
Uname: Linux zoom2au-desktop 2.6.20-5-386 #2 Sat Jan 6 14:44:57 UTC 2007 i686 GNU/Linux

Martijn (martijn.niji) wrote :

Same problem... please put this as confirmed

Daniel Holbach (dholbach) wrote :

Thanks for your bug report.

Changed in balazar:
assignee: nobody → motu
importance: Undecided → Medium
Changed in balazar:
status: Unconfirmed → Confirmed

Do you still have this issue with the latest release of Ubuntu ?

Changed in balazar:
status: Confirmed → Incomplete

Sorry it took me so long to answer. I tried it with an up to date feisty and
with the new gutsy. With feisty I still get the same error, and on gutsy it
won't start at all, showing the following error message on the console:
----------------------------------------------------------------------------------------
* Balazar * Balazar lives in /usr/share/games
Traceback (most recent call last):
  File "/usr/games/balazar", line 39, in <module>
    import soya, soya.tofu4soya
  File "/var/lib/python-support/python2.5/soya/__init__.py", line 28, in
<module>
    from soya._soya import *
ImportError: /var/lib/python-support/python2.5/soya/_soya.so: undefined
symbol: dGeomCylinderGetParams
----------------------------------------------------------------------------------------

Regards
Christian

Am Freitag, 22. Juni 2007 14.00:26 schrieb Jérôme Guelfucci:
> Do you still have this issue with the latest release of Ubuntu ?
>
> ** Changed in: balazar (Ubuntu)
> Status: Confirmed => Incomplete

What version of python-soya do you have in gutsy ?

Christian Meyer (ch-meyer) wrote :

It's version 0.13.1-0ubuntu1

Am Donnerstag 28 Juni 2007 18:06 schrieb Jérôme Guelfucci:
> What version of python-soya do you have in gutsy ?

Ok, it's a problem with python-soya already reported upstream, I will try to have it fixed in Gutsy.

I'm on a Dell D600 with Ubuntu Feisty and also had the same problem with Balazar. Does anybody knows if compiling 'python-soya' from CVS this problem disappear? I will try it and also backporting it from Gutsy, as Jérôme already said (vide bug #72884).

Ok, so now I've backported the 'python-soya' package from Gutsy to Feisty but the problem still remains (balazar doesn't open), but now the console output is different (see balazar.output attached to this link).

I've picked up 'python-soya' sources from here:
http://packages.ubuntu.com/gutsy/python/python-soya

Backported package can be downloaded here:
http://www.dcc.ufam.edu.br/~boa/feisty/python-soya_0.13.1-0ubuntu1.1_i386.deb
http://www.dcc.ufam.edu.br/~boa/feisty/soya_0.13.1-0ubuntu1.1_i386.changes

Yep, thqt's a known bug which we are trying to fix.

2007/7/8, Bruno de Oliveira Abinader <email address hidden>:
>
> Ok, so now I've backported the 'python-soya' package from Gutsy to
> Feisty but the problem still remains (balazar doesn't open), but now the
> console output is different (see balazar.output attached to this link).
>
> I've picked up 'python-soya' sources from here:
> http://packages.ubuntu.com/gutsy/python/python-soya
>
> Backported package can be downloaded here:
>
> http://www.dcc.ufam.edu.br/~boa/feisty/python-soya_0.13.1-0ubuntu1.1_i386.deb
> http://www.dcc.ufam.edu.br/~boa/feisty/soya_0.13.1-0ubuntu1.1_i386.changes
>
> ** Attachment added: "Balazar output to console"
> http://launchpadlibrarian.net/8336253/balazar.output
>
> --
> [apport] balazar crashed with TypeError in _soya.render()
> https://bugs.launchpad.net/bugs/82830
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Should be fixed in Gutsy.

Changed in balazar:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers