package bacula 2.4.2-1ubuntu4~hardy1 failed to install/upgrade: Abhängigkeitsprobleme - lasse es unkonfiguriert

Bug #269251 reported by markusd112 on 2008-09-12
30
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Server papercuts
Medium
Unassigned
bacula (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: bacula

Automatic update procudere fails on ubuntu 8.04.1

ProblemType: Package
Architecture: i386
Date: Fri Sep 12 05:05:37 2008
DistroRelease: Ubuntu 8.04
ErrorMessage: Abhängigkeitsprobleme - lasse es unkonfiguriert
NonfreeKernelModules: nvidia
Package: bacula 2.4.2-1ubuntu4~hardy1
PackageArchitecture: all
SourcePackage: bacula
Title: package bacula 2.4.2-1ubuntu4~hardy1 failed to install/upgrade: Abhängigkeitsprobleme - lasse es unkonfiguriert
Uname: Linux 2.6.24-19-386 i686

markusd112 (markusd112) wrote :
David Lee Lambert (davidl) wrote :

I'm not sure if I had the same problem. I was trying to install Bacula on Hardy, and it failed around this point:

Unpacking bacula-fd (from .../bacula-fd_2.4.2-1ubuntu4~hardy1_i386.deb) ...
Selecting previously deselected package bacula-traymonitor.
Unpacking bacula-traymonitor (from .../bacula-traymonitor_2.4.2-1ubuntu4~hardy1_i386.deb) ...
Setting up bacula-common (2.4.2-1ubuntu4~hardy1) ...
chown: invalid group: `bacula:bacula'
dpkg: error processing bacula-common (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of bacula-console:
 bacula-console depends on bacula-common (= 2.4.2-1ubuntu4~hardy1); however:
  Package bacula-common is not configured yet.

It turned out that I had a "bacula" user but no "bacula" group; after adding one, the package installed fine.

Ante Karamatić (ivoks) wrote :

Markus, problem is:

Config error: Cannot open config file "/etc/bacula/bacula-dir.conf": No such file or directory

And this looks like a duplicate of bug 308903.

Ante Karamatić (ivoks) on 2009-01-09
Changed in bacula:
importance: Undecided → Medium
status: New → Confirmed
Bill (bill-launchpad) wrote :

A workaround for this bug is:

sudo /usr/share/bacula-director/postinst-common
sudo apt-get -f install

Presumably the first command should be run upon installation and it is not.

Mike Newell (mike-spottydogs) wrote :

This is supposed to be fixed in the 2.4.4 package but my installed-two-days-ago and fully-upgraded-tonight version of Intrepid wants to install the 2.4.2 package. So...

I tried the workaround but it didn't work for me. After doing an 'aptitude search "bacula*"' I noticed that while I had done a "aptitude purge bacula" there were a couple of "bacula-*" packages that still had configurations (i.e. a "c" before the package name). I manually went through and did an "aptitude purge bacula-..." for each package that still had a configuration. Once I did that I was able to do an "aptitude install bacula" and it worked fine. Whew!

Gavin McCullagh (gmccullagh) wrote :

I'm experiencing this in Hardy. If a fix is made it should probably be put in for Hardy too.

Ante Karamatić (ivoks) wrote :

@Gavin could you test ubuntu-bacula's PPA?

https://edge.launchpad.net/~ubuntu-bacula/+archive/ppa

At the moment, it only has hardy's 2.2.8 packages. I'll create intrepid and hardy-backports packages during the day.

Ante Karamatić (ivoks) wrote :

I believe this bug is fixed in ubuntu-bacula PPA for interpid and hardy:

https://edge.launchpad.net/~ubuntu-bacula/+archive/ppa

and for those that would like to have bacula packages for hardy backported from intrepid, they are at my personal PPA:

https://edge.launchpad.net/~ivoks/+archive/ppa

Please test those packages and report results. Thank you

Thierry Carrez (ttx) on 2010-02-18
Changed in server-papercuts:
importance: Undecided → Medium
status: New → Confirmed
Thierry Carrez (ttx) on 2010-03-02
Changed in server-papercuts:
milestone: none → lucid-beta-1
Chuck Short (zulcss) wrote :

Im gonig to reject this papercut because it doesnt apply to lucid.

Regards
chuck

Changed in server-papercuts:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers