smbclient 3.2.3 does not handle the -N option consistently with past versions.

Bug #297025 reported by David on 2008-11-12
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
backuppc (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: smbclient

The -N flag, which suppresses the login prompt, and is used by backuppc's template configuration file /etc/backuppc/config.pl in the strings $Conf{SmbClientFullCmd}, $Conf{SmbClientIncrCmd}, and $Conf{SmbClientRestoreCmd}, which do full backups, incremental backups and restores respectively. Beginning with version 3.2.3, smbclient has stopped passing the backup user's password to authenticate with Window's LAN Manager, causing backups and restores to fail when the -N flag is specified (see https://bugs.launchpad.net/ubuntu/+source/backuppc/+bug/283652).

The purpose of the flag is to suppress the login prompt when the password has already been passed, and is certainly not supposed to prevent the password from being passed.

I have edited my /etc/backuppc/config.pl to make backups work, because I am guessing that the prompt is automatically suppressed when the password has already been passed. However, it would save many users a great deal of time trying to figure out what broke backuppc if the prior behavior of smbclient were restored (as well as no longer requiring the -N fag if the password has been passed).

Ubuntu 8.10 (Intrepid)
Linux CERTIBY1 2.6.27-7-generic #1 SMP Tue Nov 4 19:33:06 UTC 2008 x86_64 GNU/Linux

smbclient:
  Installed: 2:3.2.3-1ubuntu3
  Candidate: 2:3.2.3-1ubuntu3
  Version table:
 *** 2:3.2.3-1ubuntu3 0
        500 http://archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

Chuck Short (zulcss) wrote :

Hi,

I was wondering if this is still a problem for you and if you could test the karmic version.

Thanks
chuck

Changed in backuppc (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Chuck Short (zulcss) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Chuck Short (zulcss) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in backuppc (Ubuntu):
status: Incomplete → Invalid
MaxNegro (maxnegro) wrote :

Problem still present in Lucid.

Changed in backuppc (Ubuntu):
status: Invalid → New
Clint Byrum (clint-fewbar) wrote :

Max, since you've experienced this in Lucid, and David on Jaunty, I think that counts as Confirmed. This problem needs to be isolated and further investigated by a developer. Marking Confirmed.

Changed in backuppc (Ubuntu):
status: New → Confirmed
martin lantz (martin-lantz) wrote :

New version 3.3.0 of backuppc released 14 Apr 2013.

bug fixes include:

* Removed -N option from smbclient command in conf/config.pl to remain compatible
  with more recent versions (3.2.3 and later) of smbclient. Reported and discussed
  by various people on the mail list, most recently by Jeff Boyce, Les Mikesell and
  Holger Parplies. Alexander Moisseev also submitted a patch.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers