Missing smb dep8 tests

Bug #1677755 reported by Joshua Powers on 2017-03-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
backuppc (Ubuntu)
Wishlist
Andreas Hasenack
Trusty
Wishlist
Andreas Hasenack
Xenial
Wishlist
Andreas Hasenack

Bug Description

The backuppc package support several transport mechanisms for fetching the data to backup.

This bug is about adding a DEP8 test for the smb (samba/windows) mechanism.

Related branches

Changed in backuppc (Ubuntu):
assignee: nobody → Andreas Hasenack (ahasenack)
Changed in backuppc (Ubuntu Trusty):
assignee: nobody → Andreas Hasenack (ahasenack)
Changed in backuppc (Ubuntu Xenial):
assignee: nobody → Andreas Hasenack (ahasenack)
status: New → In Progress
Changed in backuppc (Ubuntu Trusty):
status: New → In Progress
Brian Murray (brian-murray) wrote :

I don't think this whole bug should be closed if the tests added are just for smb.

Changed in backuppc (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial

Hello Joshua, or anyone else affected,

Accepted backuppc into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/backuppc/3.3.1-2ubuntu3.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in backuppc (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed-trusty
Brian Murray (brian-murray) wrote :

Hello Joshua, or anyone else affected,

Accepted backuppc into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/backuppc/3.3.0-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in backuppc (Ubuntu Trusty):
importance: Undecided → Wishlist
Changed in backuppc (Ubuntu Xenial):
importance: Undecided → Wishlist

These tests should be committed to Disco Dingo before they can be SRUed right?

Andreas Hasenack (ahasenack) wrote :

I was told that this wasn't necessary, since they do not run on the user's premises and they are not the driver for the SRU. They were added to help regression-test the bug.

Of course I'll add them to disco whenever that opens, though. I have a big list of pending things for disco.

Changed in backuppc (Ubuntu):
status: New → Confirmed
Robie Basak (racb) wrote :

> I don't think this whole bug should be closed if the tests added are just for smb.

I agree to keep a bug open for non-smb tests, but that doesn't necessarily have to be _this_ bug. It could be confusing to track the status of smb tests if this bug also gets used for non-smb tests, so how about Andreas creates a new bug for non-smb tests to keep that request alive, and this bug is renamed for smb tests only?

Brian Murray (brian-murray) wrote :

Renaming this bug and making a new one for more dep8 tests makes sense to me.

Andreas Hasenack (ahasenack) wrote :

Thanks. I created https://bugs.launchpad.net/ubuntu/+source/backuppc/+bug/1802943 for the other mechanisms.

summary: - Missing dep8 tests
+ Missing smb dep8 tests
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package backuppc - 3.3.1-4ubuntu2

---------------
backuppc (3.3.1-4ubuntu2) disco; urgency=medium

  * d/t/{control,smb-backup}: simple smb-based DEP8 test (LP: #1677755)

 -- Andreas Hasenack <email address hidden> Fri, 09 Nov 2018 21:08:22 -0200

Changed in backuppc (Ubuntu):
status: Confirmed → Fix Released

The fix for this bug has been awaiting testing feedback in the -proposed repository for trusty for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Andreas Hasenack (ahasenack) wrote :

I'll go through this in the next few days.

Andreas Hasenack (ahasenack) wrote :

xenial verification:

New dep8 tests are green http://people.canonical.com/~ubuntu-archive/proposed-migration/xenial/update_excuses.html#backuppc :

backuppc (3.3.1-2ubuntu3.3 to 3.3.1-2ubuntu3.4)
Maintainer: Ubuntu Developers
119 days old
Not touching package due to block request by freeze (contact #ubuntu-release if update is needed)
autopkgtest for backuppc/3.3.1-2ubuntu3.4: amd64: Pass, arm64: Pass, armhf: Pass, i386: Pass, ppc64el: Pass, s390x: Pass

xenial verification succeeded

tags: added: verification-done-xenial
removed: verification-needed-xenial
Andreas Hasenack (ahasenack) wrote :

trusty verification:

http://people.canonical.com/~ubuntu-archive/proposed-migration/trusty/update_excuses.html#backuppc

The tests didn't run, I don't know why. So I grabbed the source from trusty-proposed and ran them locally:
andreas@nsnx:~/y$ pull-lp-source backuppc trusty-proposed
pull-lp-source: Downloading backuppc version 3.3.0-1ubuntu1.1
pull-lp-source: Downloading backuppc_3.3.0.orig.tar.gz from archive.ubuntu.com (0.528 MiB)
pull-lp-source: Downloading backuppc_3.3.0-1ubuntu1.1.diff.gz from archive.ubuntu.com (0.033 MiB)
(...)

autopkgtest [13:36:21]: version 5.3.1
autopkgtest [13:36:21]: host nsnx; command line: /usr/bin/autopkgtest -o dep8 -U -s --apt-pocket=proposed -B backuppc -- qemu /var/lib/adt-images/autopkgtest-trusty-amd64.img
autopkgtest [13:36:31]: @@@@@@@@@@@@@@@@@@@@ test bed setup
Get:1 http://archive.ubuntu.com trusty-proposed InRelease [65.9 kB]
(...)
autopkgtest [13:48:42]: test smb-backup: -----------------------]
smb-backup PASS
autopkgtest [13:48:43]: test smb-backup: - - - - - - - - - - results - - - - - - - - - -
autopkgtest [13:48:43]: @@@@@@@@@@@@@@@@@@@@ summary
smb-backup PASS
qemu-system-x86_64: terminating on signal 15 from pid 24160 (/usr/bin/python3)

real 12m22,504s

Full log at http://people.ubuntu.com/~ahasenack/backuppc-dep8-trusty-1677755/log

Trusty verification succeeded.

tags: added: verification-done-trusty
removed: verification-needed-trusty
tags: removed: removal-candidate
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package backuppc - 3.3.0-1ubuntu1.1

---------------
backuppc (3.3.0-1ubuntu1.1) trusty; urgency=medium

  * d/rules, d/p/smb-compat-fix.patch: cope with changes in newer smbclient.
    Thanks to Maksym Schipka <email address hidden> (LP: #1576187)
  * d/t/{control,smb-backup}: simple smb-based DEP8 test (LP: #1677755)

 -- Andreas Hasenack <email address hidden> Tue, 23 Oct 2018 09:06:27 -0300

Changed in backuppc (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for backuppc has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package backuppc - 3.3.1-2ubuntu3.4

---------------
backuppc (3.3.1-2ubuntu3.4) xenial; urgency=medium

  * d/rules, d/p/smb-compat-fix.patch: cope with changes in newer smbclient.
    Thanks to Maksym Schipka <email address hidden> (LP: #1576187)
  * d/t/{control,smb-backup}: simple smb-based DEP8 test (LP: #1677755)

 -- Andreas Hasenack <email address hidden> Tue, 16 Oct 2018 17:58:38 -0300

Changed in backuppc (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers