backuppc 3.3.1-2ubuntu3 breaks pool graphs on the Status page

Bug #1612600 reported by maksym on 2016-08-12
76
This bug affects 14 people
Affects Status Importance Assigned to Milestone
backuppc (Ubuntu)
Medium
Unassigned
Xenial
Medium
Brian Murray

Bug Description

Upgraded system from 14.04 LTS to 16.04.1 LTS.

As a result, the rrd pool size graphs stopped displaying, instead showing "default image" icons.

Investigation has shown that this is due to the permissions conflict. Whatever user executes backuppc/index.cgi cannot run /usr/bin/rrdtool.

The fix is as per https://sourceforge.net/p/backuppc/mailman/message/18724263/.

Namely, here's a relevant code snapshot in /usr/share/backuppc/lib/BackupPC/CGI/GeneralInfo.pm:

  $In{image} =~ /([0-9]+)/;
  my $weeks = $1;
  my $real = $<;# NEW
  $< = $>; # NEW
  print "Content-type: image/png\n\n";
  print `/usr/bin/rrdtool graph - --imgformat=PNG --start=end-${weeks}w --end=-300 --title="BackupPC Pool Size (${weeks} weeks)" --base=1000 --height=100 --width=600 --alt-autoscale-max --lower-limit=0 --vertical-label="" --slope-mode --font TITLE:10:Times --font AXIS:8:Times --font LEGEND:8:Times --font UNIT:8:Times -c BACK#FFFFFF DEF:ao="$LogDir/pool.rrd":ckb:AVERAGE CDEF:a=ao,1024,* AREA:a#95B8DB:"CPool in bytes" GPRINT:a:LAST:"Current\\:%8.2lf %s" GPRINT:a:AVERAGE:"Average\\:%8.2lf %s" GPRINT:a:MAX:"Maximum\\:%8.2lf %s\\n"`;
  $< = $real; # NEW
  return;

Robie Basak (racb) on 2016-08-12
tags: added: bitesize
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in backuppc (Ubuntu):
status: New → Confirmed
Tannoiser (tannoiser-gmail) wrote :

if it could be useful this is the "right" patch, just tested with success on my systems.

The attachment "rrd-patch.diff" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Nish Aravamudan (nacc) wrote :

Thank you for filing this bug report! This seems like a legitimate bug and should be fixed in 16.04 and 16.10 (which has the same version as 16.04 currently).

Changed in backuppc (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Robert Trevellyan (trevellyan) wrote :

The diff posted by Tannoiser in #2 works for me too.

tags: added: xenial
tags: added: regression-release
Changed in backuppc (Ubuntu):
importance: Low → Medium
Michael Terry (mterry) wrote :

Thanks for the patch Tannoiser! I've uploaded a merge from Debian + your patch to zesty.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package backuppc - 3.3.1-4ubuntu1

---------------
backuppc (3.3.1-4ubuntu1) zesty; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - debian/backuppc.init, debian/rules: Do not call init script on shutdown
      and reboot (TearDown) (Closes: #488660).
    - (Inline) apply patch to add support for ipv6. (LP: #54918). Depend and
      Build-Depend on libsocket6-perl for that. (LP: #1515986)
    - debian/rules: installing setuid wrapper with setuid bit set, and no
      permissions granted to other (mode 4750).
  * Dropped changes:
    - Dropping par2 from build-deps. We can b-d on universe packages now.
    - Versioned dep on libcgi-pm-perl. The last LTS has the version we need.
    - Escaping braces in Perl regex. Debian added this too.
    - Depending on default-mta instead of enumerated list. Debian did similar.
    - Moving config.pl.diff. Makes it hard to stay in sync with Debian and
      doesn't add any benefit except cleanliness of the path.
  * debian/patches/setuid.patch:
    - Fix status page pool graphs by running rddtool as the backuppc user.
      (LP: #1612600)

 -- Michael Terry <email address hidden> Wed, 14 Dec 2016 15:44:17 -0500

Changed in backuppc (Ubuntu):
status: Triaged → Fix Released
mike Bernson (mike-mlb) wrote :

Fix missing for 16.04.

Any chance of getting this fixed in 16.04. Since 16.04 is an LTS it would be good to also fix the problem in the LTS.

At a min could we get the GeneralInfo.pm fix. This would at least fix the RRD graph.

The patch also fixed the problem for me on 16.04

Johan Ehnberg (johan-ehnberg) wrote :

Can a maintainer please nominate this for xenial separately. The status is misleading since the fix is not in released in xenial, which is what this bug was filed against. The janitor does not act on tags.

Changed in backuppc (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Brian Murray (brian-murray)
Brian Murray (brian-murray) wrote :

I've uploaded this to the SRU queue for review by the SRU team, but it would be good if the bug description were filled out according to http://wiki.ubuntu.com/StableReleaseUpdates.

Hello maksym, or anyone else affected,

Accepted backuppc into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/backuppc/3.3.1-2ubuntu3.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in backuppc (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Falko Trojahn (falko-5) wrote :

Just installed backuppc from xenial-proposed on armhf Ubuntu 16.04.2 LTS:

dpkg -l backuppc |grep ii
ii backuppc 3.3.1-2ubuntu3.2 armhf high-performance, enterprise-grade system for backing up PCs

Seams that the patch is NOT included in package.

Patching from file in #2 didn't work here - after manually including the 3 changed lines the graphs showed up.

So, I've created a rrd-patch2.diff with more context lines -> then patch -p0 <rrd-patch2.diff worked for mee.

Please check again.

Magnus Larsson (magnus-vista) wrote :

I confirm tha the patch2.diff worked on a 16.10-system.

As part of a recent change in the Stable Release Update verification policy we would like to inform that for a bug to be considered verified for a given release a verification-done-$RELEASE tag needs to be added to the bug where $RELEASE is the name of the series the package that was tested (e.g. verification-done-xenial). Please note that the global 'verification-done' tag can no longer be used for this purpose.

Thank you!

Brian Murray (brian-murray) wrote :

Ah, I see what went wrong now and will be uploading a new fix for review by the SRU team.

tags: added: verification-failed
removed: verification-needed
tags: added: verification-failed-xenial
removed: verification-failed

Hello maksym, or anyone else affected,

Accepted backuppc into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/backuppc/3.3.1-2ubuntu3.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-xenial
removed: verification-failed-xenial
Jürgen (jurgen-depicker) wrote :

Thanks, my graphs are back with this update!
Confirmed fixed.

Simon Déziel (sdeziel) wrote :

Jürgen, could you please report on which distro you tested and what was the package number/version that resolved the issue for you. If you could also update the tags accordingly that would be great, thanks.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Jürgen (jurgen-depicker) wrote :

I tested on:
DISTRIB_DESCRIPTION="Ubuntu 16.04.3 LTS"

"Selected version '3.3.1-2ubuntu3.3' (Ubuntu:16.04/xenial-proposed [amd64]) for 'backuppc'".

I'm affraid I cannot change tags, but it seems Brian did :).

Łukasz Zemczak (sil2100) wrote :

Since there's no SRU template in the bug description (no visible test case and regression potential), I'll leave this package to be released by the person that accepted the upload (Brian). I don't have enough information to decide if this is safe and good to go.

Brian Murray (brian-murray) wrote :

I got confirmation from another user on irc that this fix is working, so I'll go ahead and release it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package backuppc - 3.3.1-2ubuntu3.3

---------------
backuppc (3.3.1-2ubuntu3.3) xenial; urgency=medium

  * Fix debian/rules so the patch is actually applied. (LP: #1612600)

 -- Brian Murray <email address hidden> Mon, 21 Aug 2017 09:53:00 -0700

Changed in backuppc (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for backuppc has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers